Rods Dec 8, 2012 @ 8:59am
TF2 LAG
I'm having some lag while playing TF2, the graphics are setup to "high", and vsync is enabled, with my system specs i don't think it was supposed to happen such thing. This same game on Windows runs smooth on High graphics. System Specs:


-Computer-
Processor : 6x AMD FX(tm)-6100 Six-Core Processor
Memory : 8160MB (2462MB used)
Operating System : Ubuntu 12.04.1 LTS
User Name : honorio (honorio)
Date/Time : Sáb 08 Dez 2012 13:55:44 BRT
-Display-
Resolution : 1920x1080 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA ATI SB
Audio Adapter : HDA-Intel - HD-Audio Generic
-Input Devices-
Power Button
Power Button
AT Translated Set 2 keyboard
Microsoft X-Box 360 pad
HDA ATI SB Line
HDA ATI SB Front Mic
HDA ATI SB Rear Mic
HDA ATI SB Front Headphone
HDA ATI SB Line-Out
HD-Audio Generic HDMI/DP,pcm : 3=
USB OPTICAL MOUSE
-Printers-
No printers found
-SCSI Disks-
ATA WDC WD5000AAKX-0
HL-DT-ST DVDRAM GH22NS90

-Version-
Kernel : Linux 3.2.0-35-generic (x86_64)
Compiled : #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012
C Library : Unknown
Default C Compiler : GNU C Compiler version (Ubuntu/Linaro 4.6.3-1ubuntu5)
Distribution : Ubuntu 12.04.1 LTS
-Current Session-
Computer Name : honorio-tux
User Name : honorio (honorio)
Home Directory : /home/honorio
Desktop Environment : Unity (ubuntu)
-Misc-
Uptime : 1 hour, 0 minute
Load Average : 0,00, 0,00, 0,00

Last edited by Rods; Dec 8, 2012 @ 9:00am
Showing 1-15 of 32 comments
< >
8 Dimensional Octagon Dec 8, 2012 @ 9:13am 
Maybe I'm blind, but what is your graphics card and video driver? If it's ATI+FOSS, then it's the driver. If you're feeling adventurous, try the x-swat-updates ppa. If you feel like possible breaking your X installation, try the xorg-edgers (read all the warnings though). If you feel like possibly breaking your Ubuntu installation, try the proprietary drivers.
satsun *2098* Dec 8, 2012 @ 9:21am 
In the video options try toggling "multicore rendering". I think you have to restart the game for the changes to take effect. In Windows, multicore rendering makes no difference for me, TF2 runs fine both ways. In Linux, if I have multicore rendering enabled then I need to disable it and restart the game for the game to run smooth.
Rods Dec 8, 2012 @ 10:21am 
Sorry about the missing information, my GPU is a AMD Radeon HD 6850, multicore is already enable
Rods Dec 8, 2012 @ 10:23am 
ill try to turn the multicore off satsun, thanks for the help
Rods Dec 8, 2012 @ 10:58am 
multicore disabled makes it worse. Don't know what is going on, i can run Trine 2 with full graphics smooth. The fps now is very low. I can barely walk.
Kokoro Dec 9, 2012 @ 7:17am 
I'm having the same thing. I waited and the FPS stabilized, but I'm still feeling some lag with the same specs I have on windows. I have a Nvidia GTS 250 and Intel Quad Core Q8300 2,5Ghz
Rods Dec 9, 2012 @ 7:31am 
Yeah, and i still cant play the game. Play it on low graphics with my specs doesn't make sense at all.
SamuraiLink3 Dec 10, 2012 @ 3:38am 
I was able to solve my lag issue by completely disabling AA, but I'm on an nVidia chipset. Give this a shot.
Rods Dec 10, 2012 @ 4:37am 
i'll try it. I reinstalled my ubuntu 12.04, and then the fglrx, but this time not manually. I did use the jockey-gtk(additional drivers) enabling the latest and restricted drivers, and them installing the 12.11 catalyst by the jockey. The fps got better, but it still low, at least i can walk now, but if the screen get full of players then i'll probably freeze. I'll try to disable the AA and se what happens.
Makeclick Dec 10, 2012 @ 8:51am 
Asus G53J. Ubuntu 12.04.1 x64, Intel core i5, Nvidia gtx460 1.5GB and 4GB ram. Working nicely, but lags sometimes suddenly. NVIDIA Driver Version: 310.14
CASTIRON IV Dec 10, 2012 @ 7:50pm 
I've got some pretty crazy lag too. Running Optimus off my laptop. I can run TF2 fine at 50-60fps with max settings under windows but I'm getting ~15fps under Linux with low settings. I hope this gets fixed soon. i5-2410, gt540m, 6gb ram.
Rods Dec 11, 2012 @ 3:05am 
Yeah, im feeling something like this too, i dont know how to get the exactly fps from the game but i feel its not too high when i play trine2, i am not lagged, but sometimes the fps clearly isnt high, and talking about TF2, the fps is low, its not playable to me. I can run Skyrim, and Arkhan City on ultra settings on Windows without lag, linux is showing a worst performance in games to me, at all.
An Infinite Number of Monkeys Dec 11, 2012 @ 4:24am 
I can't help but think part of the problem is where it says "OpenGL Renderer: Unknown. Are you sure you have 3d accel. rendering working correctly?
Rods Dec 11, 2012 @ 4:38am 
Yeah, everything looks ok on fglrxinfo, and that information was before i reinstall ubuntu and the drivers using the "additional drivers" application(jockey-gtk), i think if there was no open gl redering at all, wouldnt to be possible to play anything, not even launch the game. The problem looks more like a opengl performance issue to run those games, like when i try to emulate World Of Warcraft using wine --opengl, the fps goes down with the half of graphics settings that i would play it on windows. Same feeling of slower performance, on both games (Trine2 and TF2).
inferno480 Dec 11, 2012 @ 5:16am 
I have a very similar problem... TF2 just not feel as "smooth" as the Windows version. :(

Granted, I am running in a very high res (2560x1600), but I am not quite convinced it is necessarily a video performance issue. It almost seems more like "input lag". I tried turning off Mouse Filter and it made no difference. Something sort of weird that I noticed is that the mouse sensitivity setting is up at full blast by default, and I cannot play around with many of the mouse options... but I feel the "lag" just when using the keyboard to move too.

Here are my system specs:

Ubuntu 12.04 w/all of the latest updates
experimental-v310 nVidia Drivers
i7-3370K CPU
Asus SABERTOOTH Z77 Motherboard
16GB RAM
MSI nVidia GTX680 Video Card w/4GB RAM
Running the entire / filesystem from a SATA3 SSD

Tweaking the video settings (making them more-strenuous on the card, or less-strenuous) does not seem to make a difference...the game just seems overall "laggier" than the Windows version, and it seems to be more on the mouse/keyboard than display. The reason I say that is I can center "cl_showfps" and see that I am getting over 150-200+ FPS without VSync and a solid 60 FPS with VSync Enabled. Strange.
Showing 1-15 of 32 comments
< >
Per page: 15 30 50