n0mex Dec 8, 2012 @ 5:26am
Steam doesn't start.
Hello!
I have one problem ....
When I run steam, the client just crashes without doing anything.
After then Steam crashed, I reinstall Ubuntu and again fully updated.
I tried to run steam, but steam again crashed. (not even an error window or something)

System Info:
Ubuntu 12.04 32-bit
Fully updated
Steam was installed from Ubuntu Software Center.

Hardware info (desktop) :
Processor: AMD Athlon(tm) XP 2500+
Memory (RAM) : 2 GB
Graphic Card: Radeon HD 2600 XT AGP (Default driver, because when I installed AMD/Ati 12.6 driver, Ubuntu normally rebooted, but then show only text mode )

I'm sorry for my bad English.
Showing 1-7 of 7 comments
< >
blacke4dawn Dec 8, 2012 @ 5:51am 
Try running it from a terminal and hopefully that will provide useful error messages.
n0mex Dec 8, 2012 @ 6:59am 
I try run steam in terminal

f@f-desktop:~$ steam
/home/f/.local/share/Steam/steam.sh: line 325: 2501 Illegal instruction (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
/home/f/.local/share/Steam/steam.sh: line 325: 2548 Illegal instruction (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
f@f-desktop:~$


I can't find any logs under /var/log .... Where Steam client saved logs ?
Bomaeira Stone Dec 9, 2012 @ 3:08am 
I have the sameproblem poste somewhere else. But noboy gave me an anserver.
In my opinion it's because of the CPU. They wrote Steam works from Athlon XP1500 upwards, but the XP CPU Series (Athlon XP [en.wikipedia.org]) does not support SSE2 [en.wikipedia.org]technologie. Steam calls a native CPU instruction which is not included in the CPU (this is the error message 'illegal instructon')

I had the same problem with the steam server tool SteamCMD.

Hopefully they remove the need of SSE2.

Greetings
ugeen75 Dec 9, 2012 @ 3:14am 
I have a system based on the AMD Brazos APU, video driver FGRLX, and my mouse cursor disappears after installing Steam. When you run through the terminal get the following:

"Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(Steam)/version(1354925460_client)
Installing breakpad exception handler for appid(Steam)/version(1354925460_client)
unlinked 0 orphaned pipes
Installing breakpad exception handler for appid(Steam)/version(1354925460_client)

(process:2579): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20121208211830_1.dmp
success = no
error: Failed to open/read local data from file/application
/home/eugene/.local/share/Steam/steam.sh: строка 287: 2579 Ошибка сегментирования (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@" "
Bomaeira Stone Dec 9, 2012 @ 3:55am 
The log files should be here: (found it in another discussion)

/tmp/dumps
Bomaeira Stone Dec 9, 2012 @ 4:21am 
Complete strace output of this bug (from steamcmd for linux32):
http://dl.dropbox.com/u/32140924/strace_steamcmd.log

The last line: "Ungültiger Maschinenbefehl (Speicherabzug geschrieben)"
means in english: "Illegal instruction (core dumped)"
Last edited by Bomaeira Stone; Dec 9, 2012 @ 4:26am
Coman Dec 9, 2012 @ 5:38am 
I have same problem (Sempron CPU). It's looks like Steam for Linux requires SSE2. Hope fix it because on Windows or even WINE runs fine on non SSE2 CPU.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Dec 8, 2012 @ 5:26am
Posts: 7