Steam for Linux

Steam for Linux

Mr. Wooden Alligator Dec 7, 2012 @ 6:49pm
64 bit installation problem
Hello - I'm running Linux Mint 11 on a 64 bit machine. I have tried installing the steam.deb file using the software center, gdebi, and dpkg. In all three instances, I'm told that the package is the wrong architecture and it refuses to install. Apparently people have had luck with 64 bit ubuntu based distros, how have they done it?

Thanks
< >
Showing 1-15 of 19 comments
sombre_temps Dec 7, 2012 @ 6:56pm 
with dpkg you can force architecture with the "--force-architecture" option. But you'll have to ensure your system provide all the 32bit libraries needed
Mr. Wooden Alligator Dec 7, 2012 @ 7:07pm 
Originally posted by sombre_temps:
with dpkg you can force architecture with the "--force-architecture" option. But you'll have to ensure your system provide all the 32bit libraries needed

I forced the architecture and it says I'm missing libraries, however, upon trying to install the libraries it either says they are already installed or cannot be located. Here is the output:

sudo dpkg --force-architecture -i steam.deb
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
Selecting previously deselected package steam:i386.
(Reading database ... 196360 files and directories currently installed.)
Unpacking steam:i386 (from steam.deb) ...
dpkg: dependency problems prevent configuration of steam:i386:
steam:i386 depends on libgl1-mesa-glx.
steam:i386 depends on libgl1-mesa-dri.
steam:i386 depends on libjpeg-turbo8.
steam:i386 depends on libcurl3-gnutls (>= 7.16.2-1).
steam:i386 depends on libogg0 (>= 1.0rc3).
steam:i386 depends on libpixman-1-0 (>= 0.24.4-1).
steam:i386 depends on libsdl1.2debian (>= 1.2.10-1).
steam:i386 depends on libtheora0 (>= 1.0~beta1).
steam:i386 depends on libvorbis0a (>= 1.1.2).
steam:i386 depends on libvorbisenc2 (>= 1.1.2).
steam:i386 depends on libvorbisfile3 (>= 1.1.2).
steam:i386 depends on zenity (>= 3.4.0-0ubuntu4).
steam:i386 depends on libasound2 (>= 1.0.23).
steam:i386 depends on libc6 (>= 2.15).
steam:i386 depends on libcairo2 (>= 1.6.0).
steam:i386 depends on libcups2 (>= 1.4.0).
steam:i386 depends on libdbus-1-3 (>= 1.2.14).
steam:i386 depends on libfontconfig1 (>= 2.8.0).
steam:i386 depends on libfreetype6 (>= 2.3.9).
steam:i386 depends on libgcc1 (>= 1:4.1.1).
steam:i386 depends on libgcrypt11 (>= 1.4.5).
steam:i386 depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
steam:i386 depends on libglib2.0-0 (>= 2.14.0).
steam:i386 depends on libgtk2.0-0 (>= 2.24.0).
steam:i386 depends on libnspr4 (>= 1.8.0.10).
steam:i386 depends on libnss3 (>= 3.12.3).
steam:i386 depends on libopenal1 (>= 1:1.13).
steam:i386 depends on libpango1.0-0 (>= 1.22.0).
steam:i386 depends on libpng12-0 (>= 1.2.13-4).
steam:i386 depends on libpulse0 (>= 1:0.99.1).
steam:i386 depends on libstdc++6 (>= 4.6).
steam:i386 depends on libx11-6 (>= 2:1.4.99.1).
steam:i386 depends on libxext6.
steam:i386 depends on libxfixes3.
steam:i386 depends on libxi6 (>= 2:1.2.99.4).
steam:i386 depends on libxrandr2 (>= 2:1.2.99.3).
steam:i386 depends on libxrender1.
steam:i386 depends on zlib1g (>= 1:1.2.3.3.dfsg).
dpkg: error processing steam:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
steam:i386


_____________


Then:

sudo apt-get install libgl1-mesa-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgl1-mesa-glx is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
___
sudo apt-get install libgl1-mesa-dri
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgl1-mesa-dri is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

__

etc etc

Thoughts?
chromatix Dec 7, 2012 @ 7:17pm 
I'm also using Mint 14 64-bit. Simply letting the steam.deb open in gdebi seems to work fine. It adds a hundred or so packages as dependencies, most of which are the 32-bit compatibility stack.
Mr. Wooden Alligator Dec 7, 2012 @ 7:35pm 
Weird. When I open the package in gdebi it just says "Status: Error: Wrong architecture 'i836'"

Maybe my version of gdebi needs updating? It's currently 0.7.0
sombre_temps Dec 7, 2012 @ 7:43pm 
the latest stable gdebi is 0.8.5
sombre_temps Dec 7, 2012 @ 7:46pm 
Linux Mint 11 might not provide it
Mr. Wooden Alligator Dec 7, 2012 @ 7:57pm 
Originally posted by sombre_temps:
Linux Mint 11 might not provide it
I'll install it myself and report back.
escaped Dec 7, 2012 @ 8:02pm 
Having the same problems.

dpkg: dependency problems prevent configuration of steam:i386:
steam:i386 depends on multiarch-support (>= 2.15-0ubuntu10.2); however:
Version of multiarch-support on system is 2.15-0ubuntu10.
steam:i386 depends on libcurl3-gnutls (>= 7.16.2-1); however:
dpkg: error processing steam:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
steam:i386
chaomai Dec 7, 2012 @ 8:09pm 
try: sudo apt-get -f install
or
remove steam and use gdebi install it again(gdebi will solve the dependency):
sudo apt-get purge steam
sudo apt-get install gdebi-core
sudo gdebi steam.deb
Last edited by chaomai; Dec 7, 2012 @ 8:14pm
Mr. Wooden Alligator Dec 7, 2012 @ 8:21pm 
Okay, so I have gdebi 0.8.5 installed and it's still saying "Status: Error: Wrong architecture 'i836'" and not allowing me to install.

Do you guys have any more ideas? Maybe it's a problem with multiarch?
Mr. Wooden Alligator Dec 7, 2012 @ 8:23pm 
Originally posted by wheatmai:
try: sudo apt-get -f install
or
remove steam and use gdebi install it again(gdebi will solve the dependency):
sudo apt-get purge steam
sudo apt-get install gdebi-core
sudo gdebi steam.deb

sudo gdebi steam.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
This package is uninstallable
Wrong architecture 'i386'
sombre_temps Dec 7, 2012 @ 8:32pm 
It's probably possible to install steam with "dpkg --force-architecture --force-depends -i steam.deb". But this will likely produce a broken steam, as some dependencies might not be fulfilled
Last edited by sombre_temps; Dec 7, 2012 @ 8:35pm
akoma1s Dec 7, 2012 @ 8:45pm 
Run
sudo dpkg --add-architecture i386 && sudo apt-get update; sudo apt-get -f install
and then try to install steam.deb again.

I should note here though that the steam.deb package is designed for a distribution with multiarch support, which Linux Mint 11 most probably is not (but I'm not a Linux Mint user). Try upgrading to Linux Mint 12 or 13 (which are based on Ubuntu 11.10+, featuring multiarch support for the first time), or else you'll probably be in for a world of pain.
KaBoom Dec 8, 2012 @ 3:17am 
Try to install first the ia32-libs package and install steam with the command sudo dpkg -i --force-architecture steam.deb
Mr. Wooden Alligator Dec 8, 2012 @ 4:06am 
Y

Originally posted by akoma1s:
Run
sudo dpkg --add-architecture i386 && sudo apt-get update; sudo apt-get -f install
and then try to install steam.deb again.

I should note here though that the steam.deb package is designed for a distribution with multiarch support, which Linux Mint 11 most probably is not (but I'm not a Linux Mint user). Try upgrading to Linux Mint 12 or 13 (which are based on Ubuntu 11.10+, featuring multiarch support for the first time), or else you'll probably be in for a world of pain.

I'm pretty sure you nailed it. After seeing what wasn't working properly, apparently I have ia32-libs but ia32-libs-multiarch is not available in Mint 11. I haven't been distro shopping in a *while* since I happen to like 11, but then, if everything is starting to break on me it might be that time.

In the mean time, I'm going to see if I can get ia32-libs-multiarch to work - if so I'll post results.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Dec 7, 2012 @ 6:49pm
Posts: 19