Steam for Linux > Genel Başlıklar > Konu Detayları
Jellonator 7 Ara 2012 @ 1:08pm
Issue Report: KDE auto-hide
In the KDE interface(Kubuntu), if the panels are set to auto-hide and the Steam window is maximized, the window begins blinking and the window becomes somewhat unresponsive. Other than that, it works fine so far.
1 yorumdan 1 ile 1 arası gösteriliyor
< >
Djhg2K 7 Ara 2012 @ 1:39pm 
I get a different issue, using Ubuntu 12.04.1 i686 with kde-full installed.


When I have Steam maximized everything seems to work fine unless I:
  • move the cursor to the bottom of the screen triggering the panel animation
  • right click to bring up the context menu
  • click on "VIEW FRIENDS LIST"

Basically anything that causes the main window to be partially covered. In these cases the screen flickers while a change is happening and for a frame or so I can see whatever is behind Steam.

When the main window isn't maximized it behaves perfectly fine, just like for Jellonator.

Edit:
After further testing it turns out if you stretch the window out to the borders it has the same effect. Interestingly enough, if you leave just a little bit of room on any side, everything works just fine again.

Even more interestingly, if I disable the "Border snap zone" in KDE ("System Settings" -> "Window Behavior" -> "Window Behavior" -> "Moving", decrease until it says "none"), everything works like a charm, unless the window is maximized which I was unable to find a workaround for.

A possible fix would be for Steam to simply disable window snapping alltogether for window managers with the same feature. Not sure if this would solve the issue when maximized, but at least it's something to work with.
En son Djhg2K tarafından düzenlendi; 7 Ara 2012 @ 2:05pm
1 yorumdan 1 ile 1 arası gösteriliyor
< >
Sayfa başına: 15 30 50
Gönderilme Tarihi: 7 Ara 2012 @ 1:08pm
İleti: 1