Dispetcher14 7. dec 2012 kl. 3:21am
Hi all. I have Slackware 13.37
I repacked package, install glibc2.15
Now,start of Steam get me Segmentation fault.

Who use Steam on Slackware too?
Viser 1-12 af 12 kommentarer
< >
Routhinator 7. dec 2012 kl. 5:07am 
Most are running this on Debian/Ubuntu based systems as that is all that Valve is supporting for now. You may be on your own for this.

However, if you are running 64-bit, make sure you have the 32-bit libs installed. Also make sure you have your NVIDIA or ATI drivers installed and using the version steam requires as mentioned in the official docs.
414N 7. dec 2012 kl. 5:10am 
I'm trying to make it work but I still have some issues.
However, some people started a discussion on Linux Questions[www.linuxquestions.org] about steam on Slackware with useful directions.
You shouldn't, however, upgrade glibc without upgrading the entire distribution...
Sidst redigeret af 414N; 7. dec 2012 kl. 5:14am
mdkcore 7. dec 2012 kl. 11:26am 
I'm using Slackware current x86_64 and it's working perfectly. Try taking a look on:
and on:

there are some exports that you need to do if using multilib (to get seamonkey libs, for example)
gwagen 7. dec 2012 kl. 2:14pm 
One other quick note, once you install all the multilib stuff (assuming slack 64) you have to re-install your nvidia driver (assuming an nvidia card) because the installer cleverly knows about the existance of multilib and doesn't install the compatibility libraries unless they are needed.

Seems completely reasonable and fairly obvious in retrospect but steam just segfaults if the libraries are missing so you don't get a lot of feedback about what the problem could be.

Since the information is kindof spread all over the alien thread above here are the two things you (probably) need in your .bashrc / shell config:

export LD_LIBRARY_PATH="/usr/lib/seamonkey:$LD_LIBRARY_PATH"

Shandy 7. dec 2012 kl. 2:50pm 
The gentoo community has seen good instructions for a manual install. Sounds like you are missing some deps.
Dispetcher14 8. dec 2012 kl. 9:43am 
Ok, thanks for answers.
I think, at some days i will install slackware 14, because, khm, at experiments I some broke my 13.37 :)
Please, will not think, that i bad slackware user, fact is that i prefer live without updates, and sometimes (how with Steam), this leads to problems, and i want to use this"pulling down" for update :)
Alien Bob 2. jan 2013 kl. 4:53am 
I found this thread by accident (the forum here is a mess). For Slackware 14 you can read my blog post http://alien.slackbook.org/blog/valves-steam-client-for-linux/ which has a link to a Slackware package for the Steam client and instructions on how to use it.
Note that your 64-bit Slackware needs to be updated to a multilib system - instructions for that process are here: http://docs.slackware.com/slackware:multilib

I hope that more people running Slackware will start using Steam client for Linux. Feedback is always welcome, preferably as comments on that blog post but I may look here on the forum from time to time.

Cheers, Eric
D-Rock 2. jan 2013 kl. 12:34pm 
It works great in Slackware! My setup is Slackware64-current (14.0 also works) using Alien Bob's Multilib.

Do these three things

1. Install Alien Bob's Multilib. That's everything here and subdirectories: http://slackware.com/~alien/multilib/current/

Do this before you install your proprietary graphics drivers or reinstall your proprietary graphics drivers after you do it. This solved my segfault.

AND the Steam-specific 32-bit dependencies: http://www.slackware.com/~alien/slackbuilds/steamclient/deps/multilib/

2. Update your video card with the newest proprietary drivers.

3. Install Alien Bob's Steam Slackbuild: http://www.slackware.com/~alien/slackbuilds/steamclient/pkg/14.0/

As a final note, I did not have to create a pulseaudio user/group. However I force it to use ALSA with the command 'export SDL_AUDIODRIVER=alsa' when I start steam

All games I have tried work (Serious Sam, World of Goo, TF2), updates work, everything Just Werks. Thanks Valve, thanks Alien Bob.

edit: my mistake; order fixed

Sidst redigeret af D-Rock; 26. jan 2013 kl. 7:28pm
Alien Bob 5. jan 2013 kl. 12:55pm 
Oprindeligt skrevet af D-Rock:
1. Update your video card with the newest proprietary drivers. Do this before you install multilib or reinstall multilib after you do it. This solved my segfault.

That is most certainly wrong to do. If you first install the proprietary graphics driver and then multilib files, you will not get the 32-bit graphics driver files installed. THe correct order should be: first install multilib packages, then the (Nvidia or Ati) graphics proprietary driver.
Installing the graphics driver last will ensure that the accelerated OpenGL library gets installed (libGL.so). That GL library is also part of the "mesa" package but the mesa version is not accelerated. The proprietary version must overwrite the mesa version for yu to have OpenGL accelerated graphics.

Why you have a segfault if you install in that order, I have no idea. Have you tried using strace or another debugging tool to find out what happens right before the segfault? Do you get error messages?

Alien Bob 1. feb 2013 kl. 4:44am 
And now in english please.
psihnofrost {GNU\Slackware}~UA~ 3. feb 2013 kl. 9:25pm 
turned out not to run the steam , and the problem was in the fact that the driver for the video card is not set up.
Dispetcher14 22. feb 2013 kl. 10:37pm 
Today installed new version to 14.0 And it works!
Viser 1-12 af 12 kommentarer
< >
Per side: 15 30 50
Dato postet: 7. dec 2012 kl. 3:21am
Indlæg: 12