Dr. hoOmE 6 déc 2012 à 22h30
Issue Report: TF2 with poor FPS
Hello,

I've have a poor FPS on Team Fortress 2, on higher settings it's come to lower than 10 FPS.

I've tryed to tell Source to run with my 6 cores with -threads 6
I've tryed to tell Source to use 2GB of my RAM with -heapsize 2048000
i've tryed to downgrade my driver from 310.19 to 304.48 (installed by apt-get repositories).
I've tryed to run on Windowed and FullScreen and lower the resolution from 1920x1080 to 1680x900.
I've tryed to disable Cool'nQuiet, it's really enhance any game speed on linux, but, not Team Fortress 2 native.
I've tryed to disable VSync on Nvidia Panel and on Game Panel.
I'm using KDE 4, and i've tryed to disable kwin composite by press ALT+SHIFT+F12 (the default key to disable all effects).
I've tryed to enhance the priority of the "hl2_linux" process (renice -9 "hl2_linux pid").

The best playing is to put every setting on low, even, i've got 30 to 15 FPS, almost unplayable. Disabling AA seems to get more FPS, but not much to make a difference.

I don't use Microsoft Windows for quite some time now, and, i've only got the beta release today, so, i've never tested Team Fortress 2 nativly on Linux before, the odd thing is that, on Wine i have alot more FPS than the native version.

Screenshots:
Team Fortress 2 Native 1680x900 Without any AA: http://dl.dropbox.com/u/6867350/jpeg20.jpeg
Team Fortress 2 Under Wine 1680x1200 With AA 8x: http://dl.dropbox.com/u/6867350/jpeg23.jpeg

It's cleary a difference of FPS rsrs

Another detail that i've seen is that the Training has a good FPS even with the higher settings, but, the multiplayer, has a really poor FPS and has some FPS spikes, like, normally the training got 100 or 120 FPS, but, when i'm move the characther too fast, the FPS drop to 40 then back to 100/120.

Just one detail, i've use SDL_AUDIODRIVER=alsa and i'm dont use PulseAudio because it not work with my audiocard, currently i'm with 304.48 Driver from repository, but, before, i was with 310.19 (installed from nvidia site) and has absolutly no diferrences.

Processor Information:
Vendor: AuthenticAMD
Speed: 3200 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Debian GNU/Linux testing (wheezy) (32 bit)
Kernel Name: Linux
Kernel Version: 3.6.8-home
X Server vendor: The X.Org Foundation
X Server release: 11204000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2/3DNOW!

Driver Version: 4.2.0 NVIDIA 304.48
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20,04" x 11,26" (22,95" diag)
50,9cm x 28,6cm (58,3cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 767 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 8113 Mb

Miscellaneous:
UI Language: English
LANG: pt_BR.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 469452 Mb
Largest Free Hard Disk Block: 126873 Mb

Installed software:

Recent Failure Reports:
Fri Dec 7 05:09:35 2012 GMT: file ''/tmp/dumps/crash_20121207030932_1.dmp'', upload yes: ''CrashID=bp-a2370825-6aa5-4d8e-b5a5-1d7a92121206''
Fri Dec 7 05:09:53 2012 GMT: file ''/tmp/dumps/crash_20121207030951_1.dmp'', upload yes: ''CrashID=bp-2231aaa9-0327-4f14-b676-0ff862121206''
Fri Dec 7 05:14:08 2012 GMT: file ''/tmp/dumps/crash_20121207031406_1.dmp'', upload yes: ''CrashID=bp-3e6c8e69-5691-4d03-87c0-d4e782121206''
Fri Dec 7 05:26:10 2012 GMT: file ''/tmp/dumps/crash_20121207032609_1.dmp'', upload yes: ''CrashID=bp-700db211-3c36-45e6-a091-dba992121206''
Fri Dec 7 05:58:53 2012 GMT: file ''/tmp/dumps/crash_20121207035852_1.dmp'', upload yes: ''CrashID=bp-c8ee46a0-c3b1-46cf-8457-e55f22121206''
Fri Dec 7 06:08:11 2012 GMT: file ''/tmp/dumps/crash_20121207040810_1.dmp'', upload yes: ''CrashID=bp-0fff6c71-d974-4fe5-932e-47c622121206''

Dernière modification de Dr. hoOmE; 6 déc 2012 à 22h30
Affichage des commentaires 1 à 4 sur 4
< >
Evil Penguin 6 déc 2012 à 22h36 
Why not post this in the right sub-forum?
http://steamcommunity.com/app/221410/discussions/2/

Edit: Sorry, I'm guessing that you're not officially in the beta?
Dr. hoOmE 6 déc 2012 à 22h45 
SolidSteel a écrit :
Why not post this in the right sub-forum?
http://steamcommunity.com/app/221410/discussions/2/

Edit: Sorry, I'm guessing that you're not officially in the beta?

I'm really sorry, i'm on offial beta yes, actually, the email cames today, before i'm only run TF2 from wine.

I didn't see that is the wrong forum, i'm new here.

I don't know if you is a moderator or anyone can please move this topic to the right sub-forum.

Sorry again.
Evil Penguin 6 déc 2012 à 22h48 
I see you're running Ubuntu 11.10.
Have you tried (just for testing) newer versions of Ubuntu to see how it works?
Dr. hoOmE 6 déc 2012 à 22h52 
SolidSteel a écrit :
I see you're running Ubuntu 11.10.
Have you tried (just for testing) newer versions of Ubuntu to see how it works?

Actually, i'm on Debian, i follow the steps to install libc 2.15.

I can install Debian Sid, that is the version "compatible" with Ubuntu 12.10 to see, but, i've only tested on Debian Wheezy.

Just a question, it isn't a way to know who is in the beta and who is not? Actually, it will make all sense to block this forum only for those who are on limited beta, since we are the only ones that can run steam on linux until now (without any layers like wine). Really, i don't have the courage from that guys that use a "bug" to open steam outside the limited beta, who know, i't can leave to a massive ban (i think that has something like that on the valve agreement).
Affichage des commentaires 1 à 4 sur 4
< >
Par page : 15 30 50