Steam for Linux

Steam for Linux

wrong architecture
When I try to install steam for linux, I get an error:
gdebi steam.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
This package is uninstallable
Wrong architecture 'i386'

Anybody know how I can fix this?
Last edited by The EpicVaporware; Dec 6, 2012 @ 7:26pm
< >
Showing 1-15 of 33 comments
Grootsman Telhan Dec 8, 2012 @ 2:33am 
Enter the following commands, followed by a return (say Y or enter your information when asked):
dpkg --add-architecture i386
apt-get update
apt-get install ia32-libs
dpkg -i steam.deb
apt-get -f install

Steam is now installed!
(replace steam.deb by the full path to steam.deb)
Ubuntu 11.04, have the above problem, I get this:

dpkg: unknown option --add-architecture
gameplayer Dec 11, 2012 @ 12:44pm 
I have the same problem on crunchbang 64-bit (kernel: 2.6.32, 7.5). Help would be appreciated.
oats Dec 11, 2012 @ 12:46pm 
I have the same problem, I'm using x86_64 Kubuntu 12.04.
Last edited by oats; Dec 11, 2012 @ 12:46pm
&infin Monkeys Dec 11, 2012 @ 12:48pm 
You're running a 64-bit kernel. You need to install the ia32 compatibility libraries in order to install a 32-bit package. HaXaDoX's explanation above should set you right.
&infin Monkeys Dec 11, 2012 @ 12:49pm 
Ah. That should be --foreign-architecture instead of --add-architecture in his instructions above.
gameplayer Dec 11, 2012 @ 12:52pm 
Welp. It just says 'dpkg: unknown option --foreign-architecture'.
&infin Monkeys Dec 11, 2012 @ 12:54pm 
No: do a dpkg --version, please and uname -a
&infin Monkeys Dec 11, 2012 @ 12:55pm 
Oh, and dpkg --print-architecture please.
gameplayer Dec 11, 2012 @ 12:59pm 
Dpkg version: 'version (amd64)'.
uname-a: 'Linux Crunchbang-PC 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64 GNU/Linux'
Dpkg print architecture: amd64
Am I doing something wrong?
&infin Monkeys Dec 11, 2012 @ 1:05pm 
No.: That's what I'm trying to figure out. 1sec.

No, you're not. Not exactly. Multiarchitecture support was added in dpkg 1.16 :)

see if doing --force-architecture instead will let you install that .deb. Also, what distro are you using?
gameplayer Dec 11, 2012 @ 1:08pm 
So I wrote in:
dpkg --force-architecture i386 steam.deb
And it said:
dpkg: need an action option
&infin Monkeys Dec 11, 2012 @ 1:11pm i386 there. --force-architecture tells dpkg to ignore the package's arch.
gameplayer Dec 11, 2012 @ 1:11pm 
dpkg --force-architecture steam.deb
dpkg: need an action option
&infin Monkeys Dec 11, 2012 @ 1:12pm 
Oh...and you want to tell it to install, too, so this:

dpkg -i --force-architecture steam.deb
Last edited by &infin Monkeys; Dec 11, 2012 @ 1:12pm
< >
Showing 1-15 of 33 comments
Per page: 15 30 50

Date Posted: Dec 6, 2012 @ 7:25pm
Posts: 33