Steam for Linux > 일반 토론 > 제목 정보
Bomaeira Stone 2012년 12월 4일 오후 12시 04분
Is SSE2 CPU extension really needed for SteamCMD?
Hello!

I installed an old computer as LAN server for our small private LAN party and wanted to set up an CS:GO server with our own stats etc.

The computer has an Athlon XP 1900+ CPU in it which should be supported as written here: Steam for Linux > Limited Beta > Getting Started

Now is the question whether this is a bug at the moment or not. Will it be fixed or will the system requirements are fixed?

The steamCMD crashed with "illegal instruction" and after searching the web I found some hints that this could be an SSE2 error. This makes sense to me (software developer for embedded systems).

Here a list of SSE support of CPUs until 2006: ( www.heise.de [heise.de])

Would be nice to get information about this (so I can wait or put the server to a virtual machine or other hardware).

Greetings,
Bomaeira
4개 중 1-4 표시중
< >
TheEight-BitLink 2014년 1월 14일 오후 7시 37분 
This is certainly frustrating. I have a Poweredge with dual PIIIs at 1.2 ghz each. Should be plenty, but it doesn't have SSE2.From what I understand, this isn't necessary in the Windows steam CMD.
Lord Battlesheep 2014년 1월 15일 오전 1시 06분 
Yes, AMD Athlon XP 1900+ (K7) doesn't support SSE2 instructions. Steam needs at least Opreton (K8) or Pentium-4 as said in that link.
No, it's not a bug, SSE2 support is really required to run Steam (at least, on Linux). It will probably hardly be fixed any time soon, if ever. Valve doesn't care about "old hardware", over 99% users have SSE2 anyway.
There was a similar thread here not long ago.
"Illegal instruction" means that the instruction is not supported in CPU instruction set (or the program reads an instruction from the wrong place, or reads it wrong). Shortly, yes, it's because 1900+ has no SSE2.
PS. SSE != SSE2.
Lord Battlesheep님이 마지막으로 수정; 2014년 1월 15일 오전 3시 52분
nestor_makhno 2014년 2월 7일 오후 5시 58분 
I'm having the same issue here. I would love to see this bug fixed.
aliceif 2014년 2월 7일 오후 8시 23분 
It's not a bug, it's a design choice.
Steam decided for whatever reason only support CPUs with that feature and not older ones.
Do you cry over Steam not supporting PowerPC Macs either?
aliceif님이 마지막으로 수정; 2014년 2월 7일 오후 8시 25분
4개 중 1-4 표시중
< >
페이지당: 15 30 50

Steam for Linux > 일반 토론 > 제목 정보
게시된 날짜: 2012년 12월 4일 오후 12시 04분
게시글: 4