Steam for Linux > Genel Başlıklar > Konu Detayları
8 Dimensional Octagon 3 Ara 2012 @ 5:32pm
For the nth time, TF2 black screen fix
Many people have posted solutions, but I have yet to see all of them in one post, so here they are. You may not need all of them to get TF2 working. If anyone has any additional solutions please post them in the comments and I will add them.

1) s3tc texture compression. Either do `export force_s3tc_enable=true` before running steam or add `force_s3tc_enable=true` right under the `#!/bin/bash` in /usr/bin/steam

2) Locale issues. Either do `export LANG=C` and `export LC_NUMERIC=POSIX` before running steam or add `LANG=C` and `LC_NUMERIC=POSIX` under the `#!/bin/bash` in /usr/bin/steam. Apparently this has been fixed.

3) No symlinks. There must be no symlinks involved in getting to the SteamApps directory, or tf2 will fail on startup. If you don't want/don't have the space for tf2 in your home directory, just add /opt/Steam as another steam library or the sole steam library.

4) Tell TF2 not to use a joystick. Add -nojoy to the launch options for TF2.

5) SELinux prevents TF2 from starting. Run `sudo setsebool -P allow_execheap 1` in the terminal to fix this.

6) Windowed mode. Add -window, -sw, -startwindowed, or -windowed to the launch options.

7) Proprietary drivers. Some people have had luck installing the drivers from ATI's website. Be warned though that this often causes a plethora of other issues.

I hope this helps as it helped me.
En son 8 Dimensional Octagon tarafından düzenlendi; 13 Ara 2012 @ 6:18pm
27 yorumdan 1 ile 15 arası gösteriliyor
< >
play3man 4 Ara 2012 @ 12:53am 
Still black screen. But i get this in terminal:

"ATTENTION: default value of option force_s3tc_enable overridden by environment."
En son play3man tarafından düzenlendi; 4 Ara 2012 @ 12:54am
mruuh 4 Ara 2012 @ 1:35am 
#3 can't be correct, I had ~/Steam/SteamApps pointing to /somewhere/else/SteamApps, and TF2 worked just fine. They has to be some other condition for a symlink to be harmful here...
That, or maybe one of recent updates broke it.
mruuh 4 Ara 2012 @ 1:36am 
play3man tarafından gönderilen ileti:
But i get this in terminal:

"ATTENTION: default value of option force_s3tc_enable overridden by environment."
That's because you do override it with the export command. :)
MistaED 4 Ara 2012 @ 4:31am 
Symlinking to the .gcf's is fine though if there's not enough space in your home directory, works perfectly here, just nothing else because by default ntfs mounted in ubuntu doesn't have the execute bit set on files so native linux scripts and binaries will fail to execute too.
johndrinkwater [🐧︀ 🎮] 4 Ara 2012 @ 5:44am 
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.
play3man 4 Ara 2012 @ 5:48am 
johndrinkwater tarafından gönderilen ileti:
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.

Exactly! And I'm pretty sick from that silence from Valve side about this problem...
AnAkkk 4 Ara 2012 @ 7:09am 
And for the nth time, the locale issue has already been fixed a few updates ago :)
jibolin 4 Ara 2012 @ 7:12am 
textures still corrupted, on debian wheezy laptop (HD4000)
8 Dimensional Octagon 4 Ara 2012 @ 8:28am 
AnAkIn tarafından gönderilen ileti:
And for the nth time, the locale issue has already been fixed a few updates ago :)
The locale thing was never an issue for me, I just put it there because other people said it fixed it.
8 Dimensional Octagon 4 Ara 2012 @ 8:35am 
mruuh tarafından gönderilen ileti:
#3 can't be correct, I had ~/Steam/SteamApps pointing to /somewhere/else/SteamApps, and TF2 worked just fine. They has to be some other condition for a symlink to be harmful here...
That, or maybe one of recent updates broke it.
I had an /opt/Steam folder and an /opt/SteamApps folder (with /opt/Steam/SteamApps symlinked to /opt/SteamApps) I moved the SteamApps folder into the Steam folder (getting rid of any symlinking), and TF2 worked. Out of curiosity, I moved the SteamApps folder back out, but this time only symlinked the gcfs, and the problem returned. I put the gcfs back and it worked again. I then renamed /opt/Steam to /opt/Steam.old and symlinked /opt/Steam to it, and the problem returned again. I undid that and it worked again. If it's not the symlinks I don't know what it could be. (Then again, is your home folder on a separate partition? Maybe the problem is a combination of having .steam and Steam on a separate partition AND having symlinks?)
8 Dimensional Octagon 4 Ara 2012 @ 8:39am 
johndrinkwater tarafından gönderilen ileti:
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.
Thanks! And yeah, I totally agree it's Valve's responsibility to fix it definitively.
jibolin 4 Ara 2012 @ 8:59am 
anyone running the game ok with Intel graphics ?
clearly there is a problem with s2tc handling, so with end up with no s3tc
jibolin 5 Ara 2012 @ 2:54pm 
here they say "This is the recommended version for use with Steam on Linux"
about mesa 9.0.1
http://intellinuxgraphics.org/2012Q4.html

i'am running mesa 8.0.4, i haven't installed 9.0.1 yet, since i don't want to do a dirty .tgz install
(debian wheezy)
En son jibolin tarafından düzenlendi; 5 Ara 2012 @ 3:07pm
27 yorumdan 1 ile 15 arası gösteriliyor
< >
Sayfa başına: 15 30 50
Gönderilme Tarihi: 3 Ara 2012 @ 5:32pm
İleti: 27