Steam for Linux > 일반 토론 > 제목 정보
8 Dimensional Octagon 2012년 12월 3일 오후 5시 32분
For the nth time, TF2 black screen fix
Many people have posted solutions, but I have yet to see all of them in one post, so here they are. You may not need all of them to get TF2 working. If anyone has any additional solutions please post them in the comments and I will add them.

1) s3tc texture compression. Either do `export force_s3tc_enable=true` before running steam or add `force_s3tc_enable=true` right under the `#!/bin/bash` in /usr/bin/steam

2) Locale issues. Either do `export LANG=C` and `export LC_NUMERIC=POSIX` before running steam or add `LANG=C` and `LC_NUMERIC=POSIX` under the `#!/bin/bash` in /usr/bin/steam. Apparently this has been fixed.

3) No symlinks. There must be no symlinks involved in getting to the SteamApps directory, or tf2 will fail on startup. If you don't want/don't have the space for tf2 in your home directory, just add /opt/Steam as another steam library or the sole steam library.

4) Tell TF2 not to use a joystick. Add -nojoy to the launch options for TF2.

5) SELinux prevents TF2 from starting. Run `sudo setsebool -P allow_execheap 1` in the terminal to fix this.

6) Windowed mode. Add -window, -sw, -startwindowed, or -windowed to the launch options.

7) Proprietary drivers. Some people have had luck installing the drivers from ATI's website. Be warned though that this often causes a plethora of other issues.

I hope this helps as it helped me.
8 Dimensional Octagon님이 마지막으로 수정; 2012년 12월 13일 오후 6시 18분
27개 중 1-15 표시중
< >
play3man 2012년 12월 4일 오전 12시 53분 
Still black screen. But i get this in terminal:

"ATTENTION: default value of option force_s3tc_enable overridden by environment."
play3man님이 마지막으로 수정; 2012년 12월 4일 오전 12시 54분
mruuh 2012년 12월 4일 오전 1시 35분 
#3 can't be correct, I had ~/Steam/SteamApps pointing to /somewhere/else/SteamApps, and TF2 worked just fine. They has to be some other condition for a symlink to be harmful here...
That, or maybe one of recent updates broke it.
mruuh 2012년 12월 4일 오전 1시 36분 
play3man님이 먼저 게시:
But i get this in terminal:

"ATTENTION: default value of option force_s3tc_enable overridden by environment."
That's because you do override it with the export command. :)
MistaED 2012년 12월 4일 오전 4시 31분 
Symlinking to the .gcf's is fine though if there's not enough space in your home directory, works perfectly here, just nothing else because by default ntfs mounted in ubuntu doesn't have the execute bit set on files so native linux scripts and binaries will fail to execute too.
johndrinkwater [🐧︀ 🎮] 2012년 12월 4일 오전 5시 44분 
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.
play3man 2012년 12월 4일 오전 5시 48분 
johndrinkwater님이 먼저 게시:
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.

Exactly! And I'm pretty sick from that silence from Valve side about this problem...
AnAkkk 2012년 12월 4일 오전 7시 09분 
And for the nth time, the locale issue has already been fixed a few updates ago :)
jibolin 2012년 12월 4일 오전 7시 12분 
textures still corrupted, on debian wheezy laptop (HD4000)
8 Dimensional Octagon 2012년 12월 4일 오전 8시 28분 
AnAkIn님이 먼저 게시:
And for the nth time, the locale issue has already been fixed a few updates ago :)
The locale thing was never an issue for me, I just put it there because other people said it fixed it.
8 Dimensional Octagon 2012년 12월 4일 오전 8시 35분 
mruuh님이 먼저 게시:
#3 can't be correct, I had ~/Steam/SteamApps pointing to /somewhere/else/SteamApps, and TF2 worked just fine. They has to be some other condition for a symlink to be harmful here...
That, or maybe one of recent updates broke it.
I had an /opt/Steam folder and an /opt/SteamApps folder (with /opt/Steam/SteamApps symlinked to /opt/SteamApps) I moved the SteamApps folder into the Steam folder (getting rid of any symlinking), and TF2 worked. Out of curiosity, I moved the SteamApps folder back out, but this time only symlinked the gcfs, and the problem returned. I put the gcfs back and it worked again. I then renamed /opt/Steam to /opt/Steam.old and symlinked /opt/Steam to it, and the problem returned again. I undid that and it worked again. If it's not the symlinks I don't know what it could be. (Then again, is your home folder on a separate partition? Maybe the problem is a combination of having .steam and Steam on a separate partition AND having symlinks?)
8 Dimensional Octagon 2012년 12월 4일 오전 8시 39분 
johndrinkwater님이 먼저 게시:
Another common fix is to add -nojoy to the launch options, but of course all these mask the true problems that would be nice to have resolved OOTB.
Thanks! And yeah, I totally agree it's Valve's responsibility to fix it definitively.
jibolin 2012년 12월 4일 오전 8시 59분 
anyone running the game ok with Intel graphics ?
clearly there is a problem with s2tc handling, so with end up with no s3tc
jibolin 2012년 12월 5일 오후 2시 54분 
here they say "This is the recommended version for use with Steam on Linux"
about mesa 9.0.1
http://intellinuxgraphics.org/2012Q4.html

i'am running mesa 8.0.4, i haven't installed 9.0.1 yet, since i don't want to do a dirty .tgz install
(debian wheezy)
jibolin님이 마지막으로 수정; 2012년 12월 5일 오후 3시 07분
27개 중 1-15 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 12월 3일 오후 5시 32분
게시글: 27