Steam for Linux > Γενικές συζητήσεις > Λεπτομέρειες θέματος
OhneBrandon 3 Δεκ, 2012 @ 2:46μμ
glGetError when launching Team Fortress 2
Whenever I try and open Team Fortress 2, not the Team Fortress 2 beta, on my computer, I always get the same error that says “Could not find required OpenGL entry point ‘glGetError’! Either your video card is unsupported, or your OpenGL driver needs to be updated.” I know Linux is not the same as Windows at all, but I was able to run Team Fortress 2 just fine on the same computer.

When I searched the forums I seen that I needed to install the libgl1-mesa-dri package. When I did dpkg --get-selections | grep mesa I get:

libgl1-mesa-dri:amd64 install
libgl1-mesa-dri:i386 install
libgl1-mesa-glx:amd64 install
libgl1-mesa-glx:i386 install
libglapi-mesa:amd64 install
libglapi-mesa:i386 install
libglu1-mesa:amd64 install
libglu1-mesa:i386 install


Of course, here is my hardware.

Processor Information:
Vendor: GenuineIntel
Speed: 2400 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-18-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) G33 x86/MMX/SSE2

Driver Version: 1.4 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x8086
DeviceID: 0x29c2
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1440 x 900
Desktop Resolution: 1440 x 900
Primary Display Size: 16.06" x 10.04" (18.94" diag)
40.8cm x 25.5cm (48.1cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC888

Memory:
RAM: 5960 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 228693 Mb
Largest Free Hard Disk Block: 20285 Mb

Installed software:

Recent Failure Reports:


Do you guys have any ideas on what I can try?
Εμφάνιση 1-14 από 14 σχόλια
< >
little.helper 30 Ιαν, 2013 @ 11:31μμ 
Same issue for me here . Did you find a solution?
Flutterstare 31 Ιαν, 2013 @ 2:46πμ 
Same for me, and I'm using an Intel Chipset :S
Deazel 31 Ιαν, 2013 @ 7:25πμ 
Me as well. X79 Chipset and a GTX 690..
hirsute 31 Ιαν, 2013 @ 11:40πμ 
Most older integrated chipsets can't run tf2 because of the way valve set up its dx -> ogl translator. What's your cpu/gpu model ?
(If you don't know : grep model /proc/cpuinfo )
Flutterstare 31 Ιαν, 2013 @ 11:57πμ 
Αναρτήθηκε αρχικά από hirsute:
Most older integrated chipsets can't run tf2 because of the way valve set up its dx -> ogl translator. What's your cpu/gpu model ?
(If you don't know : grep model /proc/cpuinfo )

Mine is:

model : 15
model name : Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz
model : 15
model name : Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz
Deazel 31 Ιαν, 2013 @ 12:02μμ 
I got mine fixed by uninstalling all drivers, ending X and reinstalling the 3.10 Nvidia drivers from the Geforce site.
hirsute 31 Ιαν, 2013 @ 1:57μμ 
ignacio, turns out I can't help with just cpuinfo. Linking intel CPUs to chipset models is a real PITA. At some point, I had found the arcane incantation to figure that out, but I seem to have lost that bookmark :-(. Still, a core 2 from 2007 is probably too old.

@Deazel : you have a high end dedicated GPU, whatever your problem is/was it's almost certainly different from OP's.
OhneBrandon 31 Ιαν, 2013 @ 2:57μμ 
I never found a solution to this. I ended up just using my Windows Partition for games (sadly). It was only Team Fortress 2 I could not play, too.
Deazel 1 Φεβ, 2013 @ 5:22πμ 
Oh, I see now. OP has Intel drivers. They're not really supported by Linux yet sadly :(
Drunken Spycrab 2 Φεβ, 2013 @ 5:14μμ 
Is there any workround for this issue?
OhneBrandon 2 Φεβ, 2013 @ 5:17μμ 
No, there is no work around yet.
Deazel 2 Φεβ, 2013 @ 5:18μμ 
I'm going to see what I can find with my laptop later guys, but let me just show you something.

Graphics Drivers for Linux
https://01.org/linuxgraphics/downloads
OhneBrandon 2 Φεβ, 2013 @ 5:23μμ 
I tried updating my Mesa driver. That didn't work at all for me.
Deazel 2 Φεβ, 2013 @ 5:27μμ 
Αναρτήθηκε αρχικά από OccupyDemonoid:
I tried updating my Mesa driver. That didn't work at all for me.

I see. Just a thought. I'll try using my Intel 3000HD later on my laptop. Sorry. :\
Εμφάνιση 1-14 από 14 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 3 Δεκ, 2012 @ 2:46μμ
Αναρτήσεις: 14