Steam for Linux > Obecné diskuze > Detaily tématu
david0rk 30. lis. 2012 v 7.59 odp.
Serious Sam BFE libpci.so.3 Missing
The file exists on my system (maybe be complaining because my system is x86_64 and its looking for x86 version of the file)

Clicking Ok does nothing, Clicking cancel launches the game.

Thus far, the game runs decent on my machine (a bit crappy at first during cutscenes/videos/etc) but once i cut back GFX options to medium the game runs decent (usually 40-70 fps) but shadows from trees and things sometimes flash...

once the beta is over and the kinks are worked out I think i'll be buying this game.
Zobrazeno 1-11 z 11 komentářů
< >
david0rk 30. lis. 2012 v 8.04 odp. 
screenshot of the error (w/steam console output) http://i.imgur.com/5mddW.png

Any one trying to get the game running at a playable speed heres what worked for me:

game settings
all simple settings = medium.
all antialiasing options = off.
ambient occlusion =off



SYSINFO:

Processor Information:
Vendor: GenuineIntel
Speed: 2661 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-18-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. ATI Radeon HD 5800 Series

Driver Version: 4.2.11903 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x6899
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 18.62" x 11.65" (21.93" diag)
47.3cm x 29.6cm (55.7cm diag)
Primary VRAM Not Detected

Sound card:
Audio device:

Memory:
RAM: 5959 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 67059 Mb
Largest Free Hard Disk Block: 46199 Mb

Installed software:

Recent Failure Reports:
Sat Dec 1 03:41:24 2012 GMT: file ''/tmp/dumps/crash_20121130224114_1.dmp'', upload yes: ''CrashID=bp-74ba587c-b6e2-431b-b869-402702121130
''

Tele42 30. lis. 2012 v 8.23 odp. 
currently everything steam and steam related must be assumed to be 32bit unless proven otherwise.
david0rk 30. lis. 2012 v 8.39 odp. 
well, it definitely runs, fairly well too.
imnotarobot 30. lis. 2012 v 10.24 odp. 
yep, i'm getting the same thing missing "libpci.so.3" click cancel and the game plays fine. i know croteam added a check for libpci3 in a recent patch because i guess there are some issues if you dont have it. i'm certain it is checking the wrong location. i too am on 64bit and i know libpci3 and the libpci3.dev files are installed by checking in synaptic and the game appears to work find. i think they could probably just remove the check, in the next patch.

i was having really low frame rates when i first tried the game it was under 25fps but i found that setting GPU to high and dropping anti aliasing to 4x (med) and mirroring to med, i'm getting btwn 40 and 60 in campaign and usually around 70 to 90 in survival. still a lot less than in windows but definately playable. This is on a HD6870 at 1920x1080 with the latest AMD beta driver. i gotta say the game looks nice, and is really quite fun. oh,and it helped a ton to set the CPU govenor to performance or disabling coolnquite in the bios altogether.
blackout24 1. pro. 2012 v 1.11 dop. 
They made it a dependency because it is used to properly detect your Graphics Card which might not work otherwise in some cases and on x86_64 you of course need the lib32 version of that intalled too.
ThOR27 1. pro. 2012 v 7.14 dop. 
sudo apt-get install libpci3:i386
MistaED 1. pro. 2012 v 6.18 odp. 
I got this as well, and these are the steps I went through: 1. Hit ok on the missing libpci3 and it exists out. 2. Hit cancel and an additional window pops open about a catalog mismatch and exits when I click ok. 3. Run it the third time and no popup window at all and the game runs, yay! I just have one issue now, and it's when I play in fullscreen it tries to use both my dual monitors but only displays on the default one so that I only see the left half of the screen (so the game is trying to display at 3840x1200 but I only see 1920x1200 of it). Going into windowed mode works correctly on the one monitor but I have the unity shell around it. Nvidia 310.14 on a Geforce GTX 670 2GB.
keks 2. pro. 2012 v 4.30 dop. 
MistaED původně napsal:
I got this as well, and these are the steps I went through: 1. Hit ok on the missing libpci3 and it exists out. 2. Hit cancel and an additional window pops open about a catalog mismatch and exits when I click ok. 3. Run it the third time and no popup window at all and the game runs, yay! I just have one issue now, and it's when I play in fullscreen it tries to use both my dual monitors but only displays on the default one so that I only see the left half of the screen (so the game is trying to display at 3840x1200 but I only see 1920x1200 of it). Going into windowed mode works correctly on the one monitor but I have the unity shell around it. Nvidia 310.14 on a Geforce GTX 670 2GB.

All those problems have been fixed in the Sam3 public beta. Please opt in and see if you still have any problems.
radioactivebug 4. pro. 2012 v 3.27 odp. 
I'm seeing the exact same issues as MistaED. I'm not sure how to get it into windowed mode.

edit: I didn't know what you mean about public beta. I just figured that out.
Naposledy upravil radioactivebug; 4. pro. 2012 v 3.29 odp.
⑨-cat 7. pro. 2012 v 2.28 dop. 
MistaED původně napsal:
I got this as well, and these are the steps I went through: 1. Hit ok on the missing libpci3 and it exists out. 2. Hit cancel and an additional window pops open about a catalog mismatch and exits when I click ok. 3. Run it the third time and no popup window at all and the game runs, yay

I tried this, but on hitting OK it closed out and absolutely nothing else opened. It still brings up the libpci3 popup whenever I open the game.
Duralex 7. pro. 2012 v 11.10 odp. 
This is what worked for me: Copying a 32bit version of libpci.so.3 to my /usr/lib32/ folder in my 64 bit install from my 32 bit install (both are running Gentoo btw with similar configurations).
Zobrazeno 1-11 z 11 komentářů
< >
Na stránku: 15 30 50
Datum odeslání: 30. lis. 2012 v 7.59 odp.
Počet příspěvků: 11