Steam for Linux > 일반 토론 > 제목 정보
Haikarainen 2012년 11월 30일 오전 7시 41분
Can't launch Team Fortress 2!
I heard that TF2 wen't available for non-beta users as well, but I can't manage to get it to run. I run it, screen turns black (as it seems to launch a fullscreen application) but then reverts back to normal and no TF2.

Output: http://pastebin.com/hVGh9yRA

ArchLinux 64bit
AMD 6870 Black Edition Dualfan

Also in Big Picture mode it complains about me only having 1.4kb of GPU memory, which of course isn't true. This happens when I change the resolution.

EDIT: As people seem to neglect my comments below and just spam me with comment notifiers just to leave me disappointed; Try the latest Catalyst Beta drivers, they've fixed the problem for many.
Haikarainen님이 마지막으로 수정; 2013년 2월 21일 오전 4시 45분
21개 중 1-15 표시중
< >
spl 2012년 11월 30일 오전 8시 03분 
What driver version are you using for your gfx card? It sounds like you might just need to update.

Also, just to be sure.. You are running "Team Fortress 2" right, and not "Team Fortress 2 Beta"?
I ask because of two things. 1) I've seen a few people who thought the "TF2 Beta" was what linux testers were supposed to run (which it isn't) and 2) because I talked to someone who claimed that "TF2" ran fine, but "TF2 Beta" gave them a black screen like you are seeing.
spl님이 마지막으로 수정; 2012년 11월 30일 오전 8시 07분
DaVince 2012년 11월 30일 오전 8시 26분 
A lot of other people are getting the same black screen issue, so I'm sure it's in their (Valve's) issue tracker by now. (Regular TF2 works fine for me; beta is still downloading here.)
DaVince님이 마지막으로 수정; 2012년 11월 30일 오전 8시 27분
Haikarainen 2012년 11월 30일 오전 8시 52분 
spacelike Linux님이 먼저 게시:
What driver version are you using for your gfx card? It sounds like you might just need to update.

Also, just to be sure.. You are running "Team Fortress 2" right, and not "Team Fortress 2 Beta"?
I ask because of two things. 1) I've seen a few people who thought the "TF2 Beta" was what linux testers were supposed to run (which it isn't) and 2) because I talked to someone who claimed that "TF2" ran fine, but "TF2 Beta" gave them a black screen like you are seeing.

AMD Catalyst 12.9
https://www.archlinux.org/packages/community/x86_64/catalyst-dkms/

I'm not running their old beta, but just "Team Fortress 2" listed under "Linux Games" :P

DaVince님이 먼저 게시:
A lot of other people are getting the same black screen issue, so I'm sure it's in their (Valve's) issue tracker by now. (Regular TF2 works fine for me; beta is still downloading here.)

Thats nice to hear
Bumbero 2012년 11월 30일 오전 9시 01분 
SDLAUDIO: SDL_OpenAudioDevice() failed: Could not setup connection to PulseAudio
Just as a warning, you won't get sound more than likely unless you launch Steam with an added parameter, since you don't have PulseAudio installed. The Wiki gives the command that you can use to try and get it to work: https://wiki.archlinux.org/index.php/Steam#Start_with_black_screen.

However, I have a dual-boot set up between Arch Linux and Ubuntu (both 64-bit). It launches fine in Ubuntu for me, but in Arch I experience almost exactly the same issue. I haven't looked into it fully, but I'm fairly certain it's the graphics driver. Seems you need to use the experimental/beta drivers. I use them in Ubuntu and it works fine. I just used the ones provided in the repos on Arch, though.

Edit: I should probably add that I have the same GPU as you and experience this.
Bumbero님이 마지막으로 수정; 2012년 11월 30일 오전 9시 02분
name_dima_ru 2012년 12월 1일 오전 1시 45분 
i too have this situatit but if i push Shift+Tab i see menu but if exit in menu again black monitor and only sound

if you want have sound install

pulseaudio and pulseaudio-esound-compat:amd64 and i same install gnome-controll-center

but black monitor if not iconofy Team Fortress 2

if i click black desktop i listen sound push button some region monitor

i think what game dont up x server and is down x need think up game
name_dima_ru님이 마지막으로 수정; 2012년 12월 1일 오전 1시 50분
Ripper003 2012년 12월 1일 오전 2시 02분 
I have a similar issue, TF2 is downloaded and will go to fullscreen, but all I get is a black screen. It seems to be running in the background as I can hear the Valve loading screen and some other in-game sounds just no video.
I think I'm using TF2 Beta but I didn't exactly check since I guessed it would run fine.
Ubuntu 12.10 AMD64
Intel i3 Gen1 Processor
3GB DDR3 RAM
Intel Integrated HD Graphics
name_dima_ru 2012년 12월 1일 오전 3시 42분 
i too have Intel Integrated HD Graphics and Ubuntu AMD64 samsung r530 but have how this video situatit

http://www.youtube.com/watch?v=iv-AsGiO3lU
name_dima_ru님이 마지막으로 수정; 2012년 12월 1일 오전 3시 44분
Ripper003 2012년 12월 1일 오전 4시 21분 
Just tried the normal TF2 and still have the same issue, worth filing a bug report?
MistaED 2012년 12월 1일 오후 7시 00분 
Hi,

I get the blank screen as well and the valve/source video audio plays for 1 second before exiting to the desktop. Running steam from a terminal I could see some debug print statements and it gets choked up at trying to load in a Bik shader which I assume doesn't exist on linux/opengl and why there's an .avi alternative video to use instead. Anyway it fails to play the video on my machine so I launched TF2 with the -novid launch options (you can set it by right-clicking the game in steam under properties and the General tab).

Doing this gets me a new error: Can't find background image materials/Console/startup_loading.vtf

So if you have the blank screen bug try putting -novid in there for now, it might work for you and you won't get the missing vtf texture issue. :) This is with Team Fortress 2 (not beta).
MistaED 2012년 12월 2일 오전 12시 14분 
Hi,

Ok I've fixed my issue of the missing vtf, I had SteamApps symlinked from my ntfs drive and I think it gets confused so instead I just leave it alone and symlink to the .gcf's directly and it worked perfectly after that.

Definitely try the -novid flag, it fixed the blank screen bug for me.
Ripper003 2012년 12월 3일 오전 10시 57분 
Tried the -novid tag and all that happened was I didn't hear the Valve loading screen in the background it must've jumped straight to the TF2 menu, no black screen fix for me :(
Sammy 2012년 12월 19일 오후 7시 54분 
Same problem here.

- Launch TF2
- Get the Preparing to Launch Team Fortress 2 Window
- Screen goes black for a split second
- Back to desktop

Going to try installing different video drivers.
Haikarainen 2012년 12월 21일 오전 10시 21분 
Latest beta drivers fixed the issue (catalyst-dkms if youre using arch, from testing repo)
Zoyx 2012년 12월 22일 오후 2시 56분 
Using Ubuntu 12.10 32-bit with proprietary Catalyst drivers for my 7850 HD. Using the drivers that Ubuntu provides. TF2 flashes, then back to desktop. I am playing Osmos right now without issue.
Sammy 2012년 12월 25일 오후 4시 34분 
Beta drivers worked. Terrible performance with crossfire enabled will try again with it disabled.
21개 중 1-15 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 11월 30일 오전 7시 41분
게시글: 21