林头 Nov 29, 2012 @ 5:17pm
Gentoo Steamui.so failed
Gentoo 64bit, Fatal Error: Failed to load steamui.so

All dependencies were installed through the gentoo steam-overlay, manual installation of actual steam.
Showing 1-15 of 19 comments
< >
ojensen5115 Dec 6, 2012 @ 3:59pm 
same issue here. Console output:
Setting up Steam content in /home/ojensen/.local/share/Steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1.0_client)
Installing breakpad exception handler for appid(steam)/version(1354745237_client)
Installing breakpad exception handler for appid(steam)/version(1354745237_client)
Last edited by ojensen5115; Dec 6, 2012 @ 4:00pm
r250r Dec 6, 2012 @ 4:59pm 
Yeah I've got the same thing. Tracing flow through the scripts would be easier if no two scripts had the same name :)
Aatch Dec 6, 2012 @ 5:10pm 
I had this issue, on Archlinux though, you are likely missing some dependencies.

The PKGBUILD for the pacman package lists these dependencies:
'bash'
'desktop-file-utils'
'hicolor-icon-theme'
'curl'
'dbus'
'freetype2'
'gdk-pixbuf2'
'ttf-liberation'

as standard and these have to be 32-bit:
'glu'
'libpng12'
'sdl'
'libpulse'
'alsa-lib'
'libvorbis'
'libgcrypt'
'nss'
'openal'
'gtk2'
'glu'

(The actual 32-bit Arch packages are:
'lib32-sdl' 'lib32-libvorbis' 'lib32-alsa-lib' 'lib32-libgcrypt' 'lib32-gtk2' 'lib32-nss' 'lib32-openal' 'lib32-libpng12' 'lib32-libpulse' 'lib32-libcanberra' 'lib32-glu'
just so you know)

Hopefully that helps.

Oh, and if you want the basic explanation of why you get that error, basically it loads steamui.so which triggers ld to load more libraries (which might load more and so on), when they fail (because they don't exist), then steam reports steamui.so as failed.
Last edited by Aatch; Dec 6, 2012 @ 5:11pm
r250r Dec 6, 2012 @ 5:58pm 
Thanks Aatch!

I jumped through hoops with LD_LIBRARY_PATH, LD_PRELOAD, ldd, etc to figure out what libs were necessary. But it turns out that all we need to do is 'emerge steam-client-meta':
https://github.com/anyc/steam-overlay/pull/7

edit: or, use 'emerge steam-meta' to get both the installer and the 32-bit packages
edit2: so far, so good -- TF2 beta is downloading :D
Last edited by r250r; Dec 6, 2012 @ 6:38pm
bwdenton Dec 6, 2012 @ 6:41pm 
portage noob question, how to i get portage to pull in "steam-meta"? is it like apt? do i add a source? thanks in advance
bwdenton Dec 6, 2012 @ 6:54pm 
nevermind, fixed my problems
Shandy Dec 6, 2012 @ 7:23pm 
(Assuming amd64) Just make sure that you emerge these deps AFTER emerging gcc 4.6.3:
>=app-emulation/emul-linux-x86-baselibs-20121028
>=app-emulation/emul-linux-x86-gtklibs-20121028
>=app-emulation/emul-linux-x86-opengl-20121028
>=app-emulation/emul-linux-x86-sdl-20121028
>=app-emulation/emul-linux-x86-soundlibs-20121028
>=app-emulation/emul-linux-x86-xlibs-20121028
virtual/opengl
also the fonts:
media-fonts/font-bitstream-100dpi
blacke4dawn Dec 6, 2012 @ 7:52pm 
@Shandy
Why?
I just pulled in steam-meta and steam started up without any problems after emerge was done with all, and fore reference those packages were pulled in before that gcc.
Shandy Dec 6, 2012 @ 8:25pm 
Steam wasn't in portage when I installed it.
tremens Dec 6, 2012 @ 8:33pm 
this is what i did:

-first satisfy the dependencies using portage referencing:
http://wiki.gentoo.org/index.php?title=Steam&redirect=no#Dependencies
-you only need to
emerge --ask @steam
once after creating
/etc/portage/sets/steam

then install steam to a user home directory like so:
cd ~/

mkdir Steam

cd Steam

wget http://media.steampowered.com/client/installer/steam.deb

ar vx steam.deb data.tar.gz

tar xOf data.tar.gz ./usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz | tar xvJ

rm -f steam.deb data.tar.gz ./usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz

./steam.sh


source:
http://forums.opensuse.org/english/get-technical-help-here/games/print-480270-installing-steam-linux-beta-4.html
Last edited by tremens; Dec 7, 2012 @ 1:50am
master_zion Dec 6, 2012 @ 10:11pm 
Try this!
2 commands... Works on Ubuntu 12.10 X64
------------------

export LD_LIBRARY_PATH=/usr/lib32:/usr/lib/i386-linux-gnu/mesa:$LD_LIBRARY_PATH/usr/bin/steam:~/.steam/bin32


~/.steam/bin32

master_zion Dec 6, 2012 @ 10:19pm 
if not worked, try remove the local usser folder, re-execute using menu and repeat last step
rm -rf ~/.steam/bin32
ashl1 Dec 7, 2012 @ 12:31am 
Why don't you use just simple command?
layman -a gamerlay
emerge steam-meta
steam
And you only will worry about to solve package dependencies...
blacke4dawn Dec 7, 2012 @ 7:38am 
@Shandy
Still doesn't explain why you think installing them in that order would be necessary, espcially considering that only the gcc package is compiled localy.

As for the ebuild, didn't know (and really care) about it until I saw an update to the gamerlay overlay (which for some reason is actually used as opposed to the official games overlay).
Kobnar Dec 7, 2012 @ 9:55am 
I had the same problem. To fix it I used LD_DEBUG to find my problem which led me to manually installing the following packages:
  • virtual/libstdc++-3.3
  • media-libs/libtxc_dxtn-1.0.1
... and unmasking a more recent gcc:
  • sys-devel/gcc-4.6.3
Then I added the "gamerlay" overlay (because I didn't know about it at the time) and emerged steam-meta.

Steam starts up fine for me now. I'm just having issues connecting to the server. Hope this helps!
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Nov 29, 2012 @ 5:17pm
Posts: 19