Steam for Linux

Steam for Linux

NovemberBrow May 19, 2013 @ 6:25pm
Transparency bug in Linux after installing X.Org Drivers
The situation is more or less like this: I've been playing for a while now Trine 2 in ubuntu 13.04 with AMD proprietary drivers. Yet, the game ran sluggish and had frequent freezes.
After reading for a while, I decided to follow the advice of changing to X.Org open drivers. Everything now runs smooth and fast, even Left 4 Dead 2 Beta, CSS and TF2 but i happen to see everything like "transparent".

Hard: Gygabyte AM3+ (GA-970 I think)
AMD FX-6200 Bulldozer 6-core
ATI Radeon HD 5870 1gb
Soft: Ubuntu 13.04 Raring Ringtail (up to date)
X.Org ATI Open Drivers

I took 2 screenshots yesterday:
http://cloud-2.steampowered.com/ugc/576737307021862486/F6384C8C9CCA16824194EA1610B661A8ADD8BECE/

http://cloud-2.steampowered.com/ugc/576737307021859871/98C246AB35BE4EA3BA2D64727D1628F3FF4A3864/
(sorry, I really don't know how to embed the images)

Thanks in advance, NovemberBrown
< >
Showing 1-5 of 5 comments
[Linux]Destiser May 20, 2013 @ 2:28am 
Already tried disabling AA? Lowering the graphics details of trine2?
NovemberBrow May 21, 2013 @ 10:24am 
I have tested with Low Graphics, Windowed Mode, Vsync off, etc.
Rob May 21, 2013 @ 12:55pm 
When you say Xorg open drivers, you mean to say you're using one of the open source drivers from the kernel? Which one is it exactly and could you present your X server configuration file? :) It can be found @ /etc/X11/xorg.conf
NovemberBrow May 21, 2013 @ 2:20pm 
Section "ServerLayout" Identifier "aticonfig Layout" Screen 0 "aticonfig-Screen[0]-0" 0 0 Screen "amdcccle-Screen[1]-1" 1920 0 EndSection Section "Module" EndSection Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection Section "Monitor" Identifier "0-DFP2" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" Option "PreferredMode" "1920x1080" Option "TargetRefresh" "60" Option "Position" "0 0" Option "Rotate" "normal" Option "Disable" "false" EndSection Section "Monitor" Identifier "0-DFP4" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" Option "PreferredMode" "1920x1080" Option "TargetRefresh" "60" Option "Position" "0 0" Option "Rotate" "normal" Option "Disable" "false" EndSection Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" Option "Monitor-DFP2" "0-DFP2" BusID "PCI:1:0:0" EndSection Section "Device" Identifier "amdcccle-Device[1]-1" Driver "fglrx" Option "Monitor-DFP4" "0-DFP4" BusID "PCI:1:0:0" Screen 1 EndSection Section "Screen" Identifier "aticonfig-Screen[0]-0" Device "aticonfig-Device[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection Section "Screen" Identifier "amdcccle-Screen[1]-1" Device "amdcccle-Device[1]-1" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

This is what I have, it's called xorg.conf.fglrx-0

I ran a few commands, let me know if that's all is needed...

~$ lspci | grep VGA 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cypress XT [Radeon HD 5870] ~$ find /dev -group video /dev/fb0 /dev/dri/card0 /dev/dri/controlD64 ~$ glxinfo | grep -i vendor server glx vendor string: SGI client glx vendor string: Mesa Project and SGI OpenGL vendor string: X.Org
Rob May 21, 2013 @ 4:11pm 
I was hoping you had a desktop compositor like Compiz and that it may have ♥♥♥♥ed up. Check to see that you have the latest proprietary driver available. If there are beta versions available like we have with nvidia cards then give that a go. This seems very likely to be a driver issue.

Create a backup of you X server configuration file and run this command:
aticonfig --initial

It will autogenerate a new config, it's a tool available to those with a proprietary driver. Nvidia have the same thing, we get nvidia-xconfig. Restart xorg via task manager or a hard reboot.

If that doesn't work follow these steps to reinstall the driver properly:
http://askubuntu.com/questions/124292/what-is-the-correct-way-to-install-ati-catalyst-video-drivers-fglrx/286775#286775
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: May 19, 2013 @ 6:25pm
Posts: 5