./mattyy1hp.sh May 12, 2013 @ 10:37am
[Debian] Steam desktop icons - nothing happen
I'm on Debian Testing (currently still Wheezy) and there is an issue with desktop icons - nothing happens.

EDIT: I just noticed that my testing is now Jessie.

The icons are just launchers for command "steam steam://rungameid/GAMEID" so I've tried running this command in a terminal and this is what it says:

mattyy1hp@mattyy1hp-laptop:~$ steam steam://rungameid/380
Running Steam on debian 64-bit
STEAM_RUNTIME is enabled automatically
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/libcef.so)
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libglib-2.0.so.0)
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libnspr4.so)
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcrypt.so.11)
/home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/mattyy1hp/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)

I've Steam installed via the GhostSquad57's installer (https://github.com/GhostSquad57/Steam-Installer-for-Wheezy).
Does anyone know a solution?

I can launch any game via Steam with no problems but I just wanted to know if there is a solution for launching via icons.
Last edited by ./mattyy1hp.sh; May 13, 2013 @ 12:28pm
Showing 1-3 of 3 comments
< >
instabilis May 12, 2013 @ 10:49am 
You could have a missing dependency. You may need to install the 32-bit package for glibc, specifically version 2.15 or greater.
Last edited by instabilis; May 12, 2013 @ 11:01am
./mattyy1hp.sh May 13, 2013 @ 12:27pm 
Thanks for the reply.

I've tried putting i386 glibc library from Ubuntu package to ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/. It didn't help.
But according to this ( http://www.phoronix.com/scan.php?page=news_item&px=MTM2ODY ), Debian Jessie will come with with glibc 2.17 so I will wait for that.
It will be the easiest way.

gradinaruvasile May 14, 2013 @ 9:36am 
I run Steam for a long time on Debian 32 and 64 bit with the Ubuntu 2.15 libc. No issues.
You just have to preload the libc like this (the folder can be arbitrary, just has to contain the libc libs (all libs from the ubuntu libc6 .deb in my case):

LD_LIBRARY_PATH=${HOME}/bin/steam/lib/i386-linux-gnu/ /path/to/steam $argument

/path/to/steam = path to the steam executable
$argument = the target application, ex steam://open/friends

Or install the 2.17 Debian libc from experimental (i did it and works, dont forget the i386 version that is needed by steam).
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: May 12, 2013 @ 10:37am
Posts: 3