LostParadise May 4, 2013 @ 10:00am
Left 4 Dead 2 Error :Could not load library matchmaking
Hi, guys!
I just finnished downloading L4D2 and after the Intro Video a window appeared telling me this...
then the game crashes...
I googled but I found nothing exept some Windows users problems...
I Tried to Verify Game Cache but nothing happend...
Im using Archlinux 64bit...
Thank you!
Showing 1-15 of 19 comments
< >
SUSEd May 4, 2013 @ 10:01am 
Launch steam and game with Steam Runtime enabled.
If its not by default, launch this
env STEAM_RUNTIME=1 steam
Last edited by SUSEd; May 4, 2013 @ 10:02am
LostParadise May 4, 2013 @ 10:04am 
Thank for the quick answer!
I just tried this but didnt work...
SUSEd May 4, 2013 @ 10:05am 
Originally posted by LostParadise:
Thank for the quick answer!
I just tried this but didnt work...

Weird. This helped me.
kivan_CZ May 4, 2013 @ 10:16am 
Having the same issue, while trying run the game using primusrun. With optirun it does not run at all...
LostParadise May 4, 2013 @ 10:22am 
Originally posted by kivan_CZ:
Having the same issue, while trying run the game using primusrun. With optirun it does not run at all...
exactly the same here...Im still trying thinks but nothing worked until now...
LostParadise May 4, 2013 @ 10:27am 
thats what Im seeing when in terminal then Im launching the game...

Using breakpad crash handler
Setting breakpad minidump AppID = 223530
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198016434955 [API loaded yes]
Steam_SetMinidumpSteamID: Setting Steam ID: 76561198016434955
Gtk-Message: Failed to load module "canberra-gtk-module"
[0504/202555:ERROR:resource_bundle.cc(411)] Failed to load /home/stathis/.local/share/Steam/SteamApps/common/Left 4 Dead 2 Beta/cef_gtk.pak
Some features may not be available.
[0504/202555:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
/home/stathis/.local/share/Steam/SteamApps/common/Left 4 Dead 2 Beta/./hl2.sh: line 67: 2465 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 223530 "Left 4 Dead 2 Beta", ProcID 2465
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
LostParadise May 4, 2013 @ 10:47am 
UPDATE:
i just tried to run the game without primusrun and started nornally...so it must be a problem with optirun(and primusrun)...any ideas now?
AC/DC ROCKS!!!!!!!!!!! May 4, 2013 @ 3:14pm 
same problem here, linux Mint 14 64 bits :(
LostParadise May 4, 2013 @ 3:24pm 
it seems to be a general issue..
check this...
http://steamcommunity.com/app/223530/discussions/0/810923580581417316/
lets hope for a quick fix...
RYAD May 5, 2013 @ 12:51am 
Hey guys. I had the same issue and could resolve it via following command (Steam must already be started):

$ cd "$HOME/.steam/steam/SteamApps/common/Left 4 Dead 2 Beta"
$ vblank_mode=0 PRIMUS_SYNC=1 STEAM_RUNTIME=1 primusrun ./hl2_linux -game left4dead2_beta -steam

Works for me like a charm! Thanks for the hint LostParadise.
Last edited by RYAD; May 5, 2013 @ 1:29am
SUSEd May 6, 2013 @ 10:50am 
Thats what i found on Reddit
right click on the game, properties and click on set lunch options and paste this
LD_PRELOAD=left4dead2/bin/matchmaking.so primusrun %command%
It seems to be a good temporary solution.
bomaars May 7, 2013 @ 4:34am 
For me running with optirun fixed it.
[Linux]Dr Gregory House Md Jul 4, 2013 @ 4:40pm 
I don't use primusrun and I get this issue on L4D2 (Beta) on Linux.
Ene Jul 5, 2013 @ 12:21am 
I have same issue and this information which I copy to lunch options helped me: LD_PRELOAD=left4dead2/bin/matchmaking.so
Originally posted by SUSEd:
Thats what i found on Reddit
right click on the game, properties and click on set lunch options and paste this
LD_PRELOAD=left4dead2/bin/matchmaking.so primusrun %command%
It seems to be a good temporary solution.
Backofenpommes Jul 10, 2013 @ 3:04am 
I had the same problem with primusrun and found a solution based on the stuff i read before:

Before that, i just startet l4d2 with an own script (not out of Steam, but Steam had to be started already), containing this lines:
---------
cd "~/.steam/steam/SteamApps/common/Left 4 Dead 2"
vblank_mode=0 PRIMUS_SYNC=1 primusrun ./hl2_linux -game left4dead2 -steam
---------


But to start it out of steam, use this solution:
Go to your L4D2-Steam-folder, and edit the hl2.sh with a texteditor.
Change the line (nearly at the bottom)
---------
${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
---------
to
---------
vblank_mode=0 PRIMUS_SYNC=1 LD_PRELOAD="$LD_PRELOAD:left4dead2/bin/matchmaking.so" primusrun ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
---------

Then you don't have to edit any launch options. I also had the problem, that the ingameoverlay of steam were not accesible, but this is also solved by the changes above. Notice that LD_PRELOAD contains already a library for the overlay, and is overwritten, if you just give LD_PRELOAD a new Value. Therefore you must use _PRELOAD="$LD_PRELOAD:/path/to/new/library".


Originally posted by CBCEternalexodus:
I don't use primusrun and I get this issue on L4D2 (Beta) on Linux.

I would try something like i wrote above, but just use this line instead (cutting out primusrun-stuff):
LD_PRELOAD="$LD_PRELOAD:left4dead2/bin/matchmaking.so" ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"


BTW: if you don't know, where your L4D2-directory is, do this:
change the launch-options of L4D2 to

echo "%command%" > ~/l4d2path.txt

Then start the game via steam (nothing should happen), and clear the launch-options again.
You should now have a file named l4d2path.txt in your home-directory, containing the path of your L4D2-directory.

I hope i could help some desperate people.

Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: May 4, 2013 @ 10:00am
Posts: 19