X'grnsxs May 1, 2013 @ 8:49am
[solution] OpenSuSE 12.3 GLX direct Rendering disabled
Hi everyone

Since changing my system to openSuSE 12.3 I always got the message "OpenGL GLX Context is not using direct rendering, which may cause performance problems."

So here comes a very simple possible solution that should be tried BEFORE you mess around with your video driver configuration.

Your direct rendering hardware is represented by a device file in /dev. For Nvidia it is /dev/nvidiactl
This file is writeable for the group "video", so not being member of this group, prevents programs started in userspace from writing directly to the hardware.

Simply check if your user starting steam is member of this group. If not, join the group, logoff relogin and your problem is likely to be gone.

If this did not help, start Steam in a shell and look for permission errors in /dev related to graphics devices. Then lookup which group has write-access to this file. In normal cases this should always be "video".
If it is not, you have to carefully look up the reasons for this... Be careful not to crash your video-driver-setup by setting wrong permissions etc ;)
Last edited by X'grnsxs; May 1, 2013 @ 8:59am
Showing 1-1 of 1 comments
< >
[Linux] Junior s2 Camila May 1, 2013 @ 12:33pm 
Yes, it worked. Thanks!

I just opened YasT-User Group and Management, and added myself to video group

http://img542.imageshack.us/img542/3544/snapshot1qv.png
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: May 1, 2013 @ 8:49am
Posts: 1