Junior s2 Camila Apr 30, 2013 @ 8:55pm
OpenGL GLX Context is not using direct rendering, which may cause performance problems.
OpenGL GLX Context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457

PIC: http://img850.imageshack.us/img850/4550/snapshot1ct.png
Showing 1-13 of 13 comments
< >
govert May 1, 2013 @ 2:55am 
If using a 64 bit Linux make sure you have the 32 bit libraries for your videocard driver installed.
Last edited by govert; May 1, 2013 @ 2:56am
mattyy1hp |Linux| May 1, 2013 @ 4:31am 
I had this issue on Debian Wheezy.
Reinstalling the AMD drivers with --force option solved it.
Last edited by mattyy1hp |Linux|; May 1, 2013 @ 4:31am
X'grnsxs May 1, 2013 @ 8:40am 
I have a very simple solution for this in the case that you are pretty sure your video driver is set up correctly.

If you continue to get this Error message, please check if the user that starts steam, is member of the "video" group on your system.
The file that grants access to your direct rendering hardware is e.g. for Nvidia Graphics /dev/nvidiactl. For AMD Graphics, it will be different. Please start Steam in a console window to check for write-permission errors for video device files if you are curious about this.

These files are writeable for the "video" group. So join this group, log out the user, log in and tadaaa, there's good chance your direct rendering will work now.

Please try this out, befor messing up your drivers...
Alessandro May 4, 2013 @ 2:07am 
If you're using Ubuntu 13.04 and you applied any of the fixes mentioned by Canonical to make Skype work again, see http://steamcommunity.com/app/221410/discussions/0/828935361060603538/#c828937979248655323
Junior s2 Camila May 4, 2013 @ 9:28am 
Originally posted by X'grnsxs:
I have a very simple solution for this in the case that you are pretty sure your video driver is set up correctly.

If you continue to get this Error message, please check if the user that starts steam, is member of the "video" group on your system.
The file that grants access to your direct rendering hardware is e.g. for Nvidia Graphics /dev/nvidiactl. For AMD Graphics, it will be different. Please start Steam in a console window to check for write-permission errors for video device files if you are curious about this.

These files are writeable for the "video" group. So join this group, log out the user, log in and tadaaa, there's good chance your direct rendering will work now.

Please try this out, befor messing up your drivers...
On openSUSE the solution is even simpler:

Open YasY - User Management - Edit
and then add your user to the video group, no need to edit any files.

reboot
jasonmicron May 10, 2013 @ 12:42pm 
For anyone running under Fedora / RHEL / CentOS / etc on an x86_64 system:

1) You MUST be using the Nvidia driver, not the nouveau driver
2) When running the Nvidia installer, make SURE you answer YES when prompted to install the 32-bit libraries
3) Restart Steam

-----------------------------------
If you are running KMOD or AKMOD to handle your Nvidia driver:
1) sudo yum install xorg-x11-drv-nvidia-libs.i686
2) Restart Steam

------------------------------------
If you have a fresh install, type "sudo yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686".

Optional reading, but might be necessary for some of you:

Some hints for grub - append to the end of the vmlinuz line in your boot options:
rdblacklist=nouveau nouveau.modeset=0 rd.driver.blacklist=nouveau

Don't forget that if you are running grub2 to issue the "grub2-mkconfig -o /boot/grub2/grub.cfg" command, or else your changes won't apply. For grub1 users, just modify /boot/grub/grub.cfg and append that to the end of the vmlinuz="..." line. Definitely easier to do in grub1. This way the driver will not load up after reboots.

To see if nouveau is being used, reboot and type "lsmod | grep -i nouveau". You shouldn't get any returns. If you do, nouveau is still being used.
Cartman Jun 8, 2013 @ 5:52am 
Force steam to use the 32b libraries of mesa/fglrx/etc..
http://ubuntuforums.org/showthread.php?t=2131982&p=12682804#post12682804
Teatime Dec 3, 2013 @ 3:30am 
Originally posted by jasonmicron:
For anyone running under Fedora / RHEL / CentOS / etc on an x86_64 system:
-----------------------------------
If you are running KMOD or AKMOD to handle your Nvidia driver:
1) sudo yum install xorg-x11-drv-nvidia-libs.i686
2) Restart Steam

------------------------------------
If you have a fresh install, type "sudo yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686".

Confirmed, this worked thanks on Fedora 19 64bit. I am using the akmod version.
Helmut Mar 27 @ 8:32am 
If you are running KMOD or AKMOD to handle your Nvidia driver:
1) sudo yum install xorg-x11-drv-nvidia-libs.i686
2) Restart Steam

------------------------------------
If you have a fresh install, type "sudo yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686".

jep. worked. thx!
javajeff Mar 30 @ 10:04am 
nvidia Geforce GTX 750Ti: I am in the video group. I cannot install nvidia drivers or boot to a live CD without nomodeset. This card is only supported in the nvidia drivers. I still have this issue. I just bought this card because I thought I would be able to game in Linux easily. :)

This is everything I have done:
1) install Mint 16 and added this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

2) installed nvidia drivers, but there was a "pre-install script error." However, the install continued and I said yes to everything. There is one file in /usr/lib/nvidia called pre-install that is empty.

3) /etc/modprobe.d/blacklist.conf added to the end:
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

4) Current state:
$ lsmod | grep -i nouveau
nouveau 943295 0
mxm_wmi 13021 1 nouveau
wmi 19070 2 mxm_wmi,nouveau
video 19318 1 nouveau
i2c_algo_bit 13413 1 nouveau
ttm 83995 1 nouveau
drm_kms_helper 52651 1 nouveau
drm 296739 5 ttm,drm_kms_helper,nvidia,nouveau
Last edited by javajeff; Mar 30 @ 10:07am
peter_parker May 5 @ 6:42am 
If you're using Ubuntu + Bumblebee, edit /etc/bumblebee/bumblebee.conf and make sure you're using primus. Change the line

Bridge=auto

to

Bridge=primus
javajeff May 5 @ 7:25pm 
I am using a brand new Desktop card: nvidia Geforce GTX 750Ti. I still have not figured out how to get OpenGL support. The main problem is that I cannot unistall the nvidia drivers from the website. My card is not supported by anything but those drivers, so Live CDs do not work without using the nomodeset boot parameter for software rendering mode. This is what I have to do:
http://askubuntu.com/questions/425140/unable-toboot-with-nvidia-gtx-750-ti-even-with-latest-beta-drivers
Last edited by javajeff; May 5 @ 7:30pm
Showing 1-13 of 13 comments
< >
Per page: 15 30 50