Möbius Stripper Apr 28, 2013 @ 1:58pm
All Source Engine games seem to not work on my Linux Client
When I try to open any Source Engine game on my Linux Client, this occurs.

http://steamcommunity.com/sharedfiles/filedetails/?id=142015725

Basically, it's a black screen instead of the Valve startup clip, and the "Steam in-game interface" prompt appears but its frames clip over itself. The rest of the game is the black screen, although I can hear the music. It seems I can't click on anything. The Steam in-game interface works to an extent, although somewhat slowly.

This problem started happening the first day I installed the Steam client months ago. Team Fortress 2 worked, although incredibly glitchy. It had some resolution problems, so what I did (Or so I think, it was a couple months ago so I don't remember much.) was change the resolution settings either between fullscreen/windowed or changed the resolution.

I've tried everything I could. Turn on/off the Steam in-game interface, defragment the cache, even reinstall Steam and TF2 themselves.

It's been months, and it's really been getting on my nerves, especially with Left 4 Dead 2 for Linux just over the horizon. Can anybody help me?

Also, this problem doesn't occur on my Wine/Playonlinux versions, although those have other problems that prevent me from playing.

Edit: Here's my hardware and driver and whatnot.

OS: Ubuntu 12.10 32-bit (Should I upgrade to 13.04?)
Graphics: Nvidia GeForce GTX-550 Ti
CPU: Intel i3 Dual Core, 3.20Ghz
RAM: 12GB
Driver: "Experimental Nvidia binary xorg driver, kernel module and vdpau library from nvidia-experimental-310 (Proprietary)"

Last edited by Möbius Stripper; Apr 28, 2013 @ 2:08pm
Showing 1-15 of 21 comments
< >
Junior s2 Camila Apr 28, 2013 @ 2:17pm 
I don't think you NEED to upgrade, but 13.04 is really more reliable than 12.10 for what I can see. I had this black screen once and all I had to do was Verify Game's Cache.
Möbius Stripper Apr 28, 2013 @ 2:32pm 
I did a verification, but it didn't do anything. I suppose I'll try upgrading in a bit.
The Wounded Apr 28, 2013 @ 2:38pm 
start steam from a terminal and see what the output is, that could give more information on what is wrong
Möbius Stripper Apr 28, 2013 @ 2:57pm 
Originally posted by The Wounded:
start steam from a terminal and see what the output is, that could give more information on what is wrong

Here, http://pastebin.com/T2v73WH6
Doc Holliday Apr 28, 2013 @ 3:16pm 
nvidia-experimental-310 looks to be to old try to install a newer one
Junior s2 Camila Apr 28, 2013 @ 3:19pm 
Originally posted by Nemesis:
nvidia-experimental-310 looks to be to old try to install a newer one
He can't do it safely on 12.10. 13.04 comes with 313 and it works flawlessly, better than 310.
Doc Holliday Apr 28, 2013 @ 3:23pm 
Originally posted by Linux Junior s2 Camila:
Originally posted by Nemesis:
nvidia-experimental-310 looks to be to old try to install a newer one
He can't do it safely on 12.10. 13.04 comes with 313 and it works flawlessly, better than 310.
upgrading up 13.04 and newer Drivers been a fix for a lot of Nvidia users
Doc Holliday Apr 28, 2013 @ 3:26pm 
and BTW having a 32bit OS only lets you use 4GB of your 12GB's of ram
Shark Apr 28, 2013 @ 3:38pm 
Originally posted by Nemesis:
and BTW having a 32bit OS only lets you use 4GB of your 12GB's of ram
It also limits applications to 2gb of ram, to bad the only 64 bit games I know are wow and crysis.
Doc Holliday Apr 28, 2013 @ 4:04pm 
Originally posted by Wouter:
Originally posted by Nemesis:
and BTW having a 32bit OS only lets you use 4GB of your 12GB's of ram
It also limits applications to 2gb of ram, to bad the only 64 bit games I know are wow and crysis.
it limits all on Linux aswell Go 64bit and set your Linux Box Free
Hardtimes Apr 28, 2013 @ 4:20pm 
Ubuntu 12.10 ships with a PAE-enabled kernel, allowing access to up to 64 GB of system memory. In this case, 32-bit applications are limited to 4 GB, not 2. The package 'nvidia-experimental-310', which is 310.14, will work fine. Looks to me like the driver is mis-installed, resulting in the game finding the wrong gl/glx libraries.
blackout24 Apr 28, 2013 @ 4:22pm 
Originally posted by Hardtimes:
Ubuntu 12.10 ships with a PAE-enabled kernel, allowing access to up to 64 GB of system memory. In this case, 32-bit applications are limited to 4 GB, not 2. The package 'nvidia-experimental-310', which is 310.14, will work fine. Looks to me like the driver is mis-installed, resulting in the game finding the wrong gl/glx libraries.

PAE is a load of ♥♥♥♥♥♥*t I wish people would stop promoting that crap. This guy should know: http://cl4ssic4l.wordpress.com/2011/05/24/linus-torvalds-about-pae/
Last edited by blackout24; Apr 28, 2013 @ 4:22pm
Hardtimes Apr 28, 2013 @ 5:02pm 
I'm not promoting PAE by any means. It does indeed suck. Just clarifying.

@Brucifer - Remove all nvidia packages and reboot. Then install nvidia-experimental-310 and reboot again.
Möbius Stripper Apr 28, 2013 @ 5:16pm 
I've heard a lot about PAE, didn't know much about it's use in Linux though. Not surprised that it's the same in Linux. I installed 12.10 using a 64-bit Live Disk I made, making sure it's 64-bit, so I'm not sure as to why I have a 32-bit OS after that. Does anyone know? Also, could I simply select 64-bit when I install 13.04 and have it work, retaining all my data?

Anyways, back on topic; the graphics card and driver has worked fine with all of my other games, as well as playing these same games on WINE. I have several other drivers available for my use (seen here, http://i.imgur.com/bMsle9A.png), although they don't seem to work at all when I try to open the game.
Möbius Stripper Apr 28, 2013 @ 5:40pm 
Originally posted by Hardtimes:
I'm not promoting PAE by any means. It does indeed suck. Just clarifying.

@Brucifer - Remove all nvidia packages and reboot. Then install nvidia-experimental-310 and reboot again.

nvidia-experimental-310 is already installed. Or, should I remove that as well?
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Apr 28, 2013 @ 1:58pm
Posts: 21