Steam for Linux > การสนทนาทั่วไป > รายละเอียดกระทู้
Google.com 26 เม.ย. 2013 @ 11:27am
[Solved] Ubuntu 13.04 OpenGL GLX Error
Today when I launched steam i am greeted by this message:
"OpenGL GLX context is not using direct rendering, which may cause performance problems."
I did a few searches, and most results came back with nvidia dependencies. The few which didnt had suggestions which did not work.
when i do glxinfo | grep "render" i get:
direct rendering: Yes
OpenGL renderer string: AMD Radeon HD 6800 Series
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image,

any thoughts?
ได้รับการแก้ไขครั้งสุดท้ายโดย Google.com; 26 เม.ย. 2013 @ 3:40pm
กำลังแสดง 1-15 จาก 26 ความเห็น
< >
Doc Holliday 26 เม.ย. 2013 @ 12:09pm 
what catalyst you have installed?
Google.com 26 เม.ย. 2013 @ 12:49pm 
i was running 13.3 beta 2. then i got the issue so i upgraded to 13.4. still had the issue, so right now i have removed the amd drivers completely. maybe i will try again with 13.2 or whatever the last non-beta release was
Doc Holliday 26 เม.ย. 2013 @ 1:02pm 
what happens when you run fglrxinfo with the catalyst installed
ได้รับการแก้ไขครั้งสุดท้ายโดย Doc Holliday; 26 เม.ย. 2013 @ 1:02pm
Doc Holliday 26 เม.ย. 2013 @ 1:05pm 
ได้รับการแก้ไขครั้งสุดท้ายโดย Doc Holliday; 26 เม.ย. 2013 @ 1:06pm
Saner than a coconut 26 เม.ย. 2013 @ 1:10pm 
โพสต์ดั้งเดิมโดย Nemesis:
13.4 just released http://linuxgamerzone.com/index.php/software/30-amd-catalyst-13-4-proprietary-linux-graphics-driver-released

Oooh, new driver, thanks for sharing.
Google.com 26 เม.ย. 2013 @ 1:11pm 
from fglrxinfo i get:

display: :0.0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 4.2.12173 Compatibility Profile Context 12.10.17

i upgraded on release day from 12.10 to 13.04. I have reinstalled my AMD drivers to 13.3 beta 3. but steam still complains the same.
drewb🐧 26 เม.ย. 2013 @ 1:16pm 
Steam is 32-bit so you have to ensure your 32-bit OpenGL support is working also. There are several other posts in this forum dealing with this exact issue and they have suggestions for AMD driver updates.
Google.com 26 เม.ย. 2013 @ 1:20pm 
i have been using Ubuntu for a while now, and i have never seen this issue in Steam until after upgrading to Ubuntu 13.04. I have followed the same guide for installing my AMD drivers for the last 6 months or so.

@drewb - is there a particular command i need to use to check the 32-bit support specifically?
i am sure this is an AMD issue, as when i remove the drivers then steam doesnt complain.

I tried the 13.4 AMD drivers, and they did not help. maybe i am missing a package or a dependency or something, but i dont know what.
Doc Holliday 26 เม.ย. 2013 @ 1:27pm 
โพสต์ดั้งเดิมโดย Sirik:
i have been using Ubuntu for a while now, and i have never seen this issue in Steam until after upgrading to Ubuntu 13.04. I have followed the same guide for installing my AMD drivers for the last 6 months or so.

@drewb - is there a particular command i need to use to check the 32-bit support specifically?
i am sure this is an AMD issue, as when i remove the drivers then steam doesnt complain.

I tried the 13.4 AMD drivers, and they did not help. maybe i am missing a package or a dependency or something, but i dont know what.
do you have synaptic installed?
Google.com 26 เม.ย. 2013 @ 1:28pm 
yes i do.. any idea what i should be looking for? previous google searches said something about mesa packages... but i seem to have all of those installed
Doc Holliday 26 เม.ย. 2013 @ 1:34pm 
โพสต์ดั้งเดิมโดย Sirik:
yes i do.. any idea what i should be looking for? previous google searches said something about mesa packages... but i seem to have all of those installed
Broken packages
Google.com 26 เม.ย. 2013 @ 1:40pm 
ok... i went into package manager and selected 'fix broken packages' the status bar updated saying it had fixed dependecy problems. now what should i look for? restarting steam shows the same error.. maybe i need to wipe my computer and re-install 12.04 ubuntu instead?
Doc Holliday 26 เม.ย. 2013 @ 1:43pm 
โพสต์ดั้งเดิมโดย Sirik:
ok... i went into package manager and selected 'fix broken packages' the status bar updated saying it had fixed dependecy problems. now what should i look for? restarting steam shows the same error.. maybe i need to wipe my computer and re-install 12.04 ubuntu instead?
restart steam see if it works you maybe miss a 32bit package
Google.com 26 เม.ย. 2013 @ 1:44pm 
i already tried that.. same error
กำลังแสดง 1-15 จาก 26 ความเห็น
< >
ต่อหน้า: 15 30 50