Hakan Dogan Apr 20, 2013 @ 4:31pm
Psychonauts bug
I have Ubuntu 12.04, downloaded Psychonauts and runs so far BUT

the character moves without me pushing the "up" buttom. It keeps running.

How to solve this bug? This didn't happen on Windows 7.
Showing 1-6 of 6 comments
< >
fac3l3ss Apr 22, 2013 @ 11:37am 
What is your Keyboard? Your system might be assuming you have a joystick plugged in. I had the same issue and solved it. Need more information to help though...
Last edited by fac3l3ss; Apr 22, 2013 @ 12:31pm
Firewolf May 9, 2013 @ 7:03pm 
I had the same problem. The first time I ran Psychonauts (no controller), all was fine. Then, after getting my controller set up, I ran it again, and, again, no issues (except that I press the wrong buttons). BUT this third time, with no controller, I got exactly what you describe. A few more tries, same result. But once I plugged in the controller again and started it, it now works fine again. And I can unplug the controller without causing issues (though the controller won't function again until I quit and restart with it plugged in).
Anyway, hope that helps. And just in case it matters, I'm not using the Steam version. I got the Humble Double Fine Bundle, so it's got nothing to do with Steam.
MichaelNevermore May 24, 2013 @ 6:04pm 
Originally posted by fac3l3ss:
What is your Keyboard? Your system might be assuming you have a joystick plugged in. I had the same issue and solved it. Need more information to help though...
How did you solve it? I have the same issue. I can't even play the game.

I'm not using an external controller, just the keyboard built into my laptop. I'm running Ubuntu 13.04. Anything else you need to know? Please help.....
Firewolf May 27, 2013 @ 11:17pm 
I figured out how to fix it!!! YAY!!! First time helping people with Linux!!
Before I get to the fix, I'll explain what happens on my computer.
I have a screwed-up mouse/keyboard combo (made by Microsoft) that stops working whenever I bump the reciever. Not sure if the bugginess is related, but I thought I'd mention it. Anyway, the important thing is, it registers as a joystick, and when I explore it with jstest, it shows a BUNCH of axises, most of them at a large negative value. That's the problem: Psychonauts sees it as a joystick, reads the values as very large and negative, and responds accordingly.
I've come up with several methods to get around the bug:
1: don't use whatever keyboard/mouse/whatever is registering as a joystick-- by far the easiest if it's an external mouse/keyboard and you have another mouse (playing with the touchpad is kinda annoying). Not gonna work for built-in mouse/keyboard.
2: As I mentioned in my previous post, if you HAVE a joystick, plug that in before starting Psychonauts. You can then unplug it, as Psychonauts only checks what joysticks are connected when it starts up. I don't understand why this works, but it does.
3: if the above options don't work for you, then go to the root of the problem (which requires root, so if you're not an administrator, I don't know what to tell you). There's a file /dev/input/js0 (or possibly a different number depending on circumstances) that cooresponds to your "joystick" either delete it or rename it. I cannot promise that doing so won't cause some sort of issue, but it works fine for me. I renamed it to "/dev/input/js0 blah" and it no longer registers as a joystick. Start Psychonauts, and it should work, no problems. The file will come back every time the offending device is plugged in (or, I assume, whenever the system restarts), so you'll need to delete it every time. I suggest writing a script that will delete the file and then launch Psychonauts for you. That way, you just run the script when you want to play, and won't have to worry about this too much. Yay scripts!!
And if you have multiple files beginning with js, delete/rename them all. It's possible you've got multiple things registering improperly as joysticks.

Hope this helps people. And go, Linux community!
Teisei May 28, 2013 @ 4:11am 
You should calibrate your controllers and set deadzones. This should prevent unintentional axis motion.
Hakan Dogan Jul 10, 2013 @ 3:54pm 
Hey here is a solution: "Your Microsoft keyboard is probably being detected as a joystick, and it's borking up the input the game is receiving.

If you don't have any actual joysticks/pads/etc, a quick fix you could try is disabling the joydev module. This can be done in the terminal by typing "sudo rmmod joydev". This will revert at every reboot, though (and if you have actual devices depending on this, don't do it:) " - zuti

http://ubuntuforums.org/showthread.php?t=1996702
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Apr 20, 2013 @ 4:31pm
Posts: 6