Steam for Linux

Steam for Linux

Steam for Linux > Discusiones generales > Detalles del tema
capcavern 19 abr. 2013 a las 16:39
USB Wired Xbox360-wine-xbox360cemu-xboxdrv
This topic is old but I have been trying to use a consistent method to have a USB Wired Xbox360 controller working with Steam Games.And the only method that worked for me is the following. I'm not talking about Keyboard-Mouse remapping of course.

1)Here how I got it to work.
downloaded xbox360cemu.v.3.0

2)Then copy

at the root of the folder where the executable reside ,in the steam folder ex: /home/rcmn/PlayOnLinux's virtual drives/AssassinsCreed/drive_c/Program Files (x86)/Steam/SteamApps/common/Assassins Creed

3) install xboxdrv

4) connect the USB Wired Xbox360 controller

5) run in a terminal:
sudo xboxdrv --silent --detach-kernel-driver --trigger-as-button --ui-axismap x2=ABS_Z,y2=ABS_RZ --ui-buttonmap A=BTN_B,B=BTN_X,X=BTN_A,TR=BTN_THUMBL,TL=BTN_MODE,GUIDE=BTN_THUMBR

So far It worked with :
- Assassins Creed (Steam version) (need to be activated in the option menu)
- Dishonored (Steam version)
- deus ex - human revolution (Steam Version)

Did not work:
- Rayman Origins (Steam version). I tried many options but I can't get to work ,even when I push the reset function in the options menu. It does not remap to the gamepad like it should.

If anyone Has any suggestions I'll be happy to hear them.

sometime at the start of certain games( in the menu), the left Thumstick send continuous command making the menu select go wild. But you just have to move it once to reset it. After that there is no issues.(maybe some random skip in menus)
But I haven't see problems in game.
Última edición por capcavern; 19 abr. 2013 a las 16:40
< >
Mostrando 1-1 de 1 comentarios
j.salem 23 ago. 2013 a las 0:18 
Hi, I am on the same boat. Your method worked for some other game I tried (Braid, Limbo), but not for XCOM:EU. When I try to remap the keybindings and I press something on the joypad, the game correctly recognises the button press; but if I try to switch the input method to "Xbox630 Controller" it just sits there telling that I need to reconnect the gamepad.

My guess is that XCOM:EU (and possibly other titles) does some weird thing to hook up the gamepad, and wine doesn't manage that perfectly.

I also tried with several (newer and older) versions of x360ce, with same results.
< >
Mostrando 1-1 de 1 comentarios
Por página: 15 30 50

Steam for Linux > Discusiones generales > Detalles del tema
Publicado el: 19 abr. 2013 a las 16:39
Mensajes: 1