Steam for Linux

Steam for Linux

GMm3 Apr 17, 2013 @ 9:37am
missing the following 32-bit libraries, and Steam may not run: libtrace.so
When I start the Steam client I get the following error:
You are missing the following 32-bit libraries, and Steam may not run: libtrace.so

Basic info is:
Linux Mint Debian X64
Nvidia GTX460SE
NVIDIA Driver Version: 313.30

Terminal return:
:~$ steam Running Steam on linuxmint 1 64-bit STEAM_RUNTIME is enabled automatically Error: You are missing the following 32-bit libraries, and Steam may not run: libtrace.so Installing breakpad exception handler for appid(steam)/version(1364601080_client) Installing breakpad exception handler for appid(steam)/version(1364601080_client) [2013-04-17 09:31:48] Startup - updater built Mar 29 2013 11:40:39 [2013-04-17 09:31:48] Verifying installation... [2013-04-17 09:31:48] Verification complete [2013-04-17 09:32:17] Shutdown


:~$ glxinfo | grep render direct rendering: Yes OpenGL renderer string: GeForce GTX 460 SE/PCIe/SSE2 GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, GL_NV_parameter_buffer_object2, GL_NV_path_rendering, GL_NVX_conditional_render, GL_NVX_gpu_memory_info,

LIBGL_DEBUG=verbose glxinfo | grep -i -A 5 -B 5 direct name of display: :0.0 display: :0 screen: 0 direct rendering: Yes server glx vendor string: NVIDIA Corporation server glx version string: 1.4 server glx extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control, -- OpenGL vendor string: NVIDIA Corporation OpenGL renderer string: GeForce GTX 460 SE/PCIe/SSE2 OpenGL version string: 4.3.0 NVIDIA 313.30 OpenGL shading language version string: 4.30 NVIDIA via Cg compiler OpenGL extensions: GL_AMD_multi_draw_indirect, GL_ARB_arrays_of_arrays, GL_ARB_base_instance, GL_ARB_blend_func_extended, GL_ARB_clear_buffer_object, GL_ARB_color_buffer_float, GL_ARB_compatibility, GL_ARB_compressed_texture_pixel_storage, GL_ARB_conservative_depth, GL_ARB_compute_shader, GL_ARB_copy_buffer, GL_ARB_copy_image, GL_ARB_debug_output, GL_ARB_depth_buffer_float, GL_ARB_depth_clamp, GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, GL_ARB_draw_indirect, GL_ARB_draw_elements_base_vertex, GL_ARB_draw_instanced, GL_ARB_ES2_compatibility, GL_ARB_ES3_compatibility, GL_ARB_explicit_attrib_location, GL_ARB_explicit_uniform_location, GL_ARB_fragment_coord_conventions, GL_ARB_fragment_layer_viewport, GL_ARB_fragment_program, GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader, GL_ARB_framebuffer_no_attachments, -- GL_ARB_geometry_shader4, GL_ARB_get_program_binary, GL_ARB_gpu_shader5, GL_ARB_gpu_shader_fp64, GL_ARB_half_float_pixel, GL_ARB_half_float_vertex, GL_ARB_imaging, GL_ARB_instanced_arrays, GL_ARB_internalformat_query, GL_ARB_internalformat_query2, GL_ARB_invalidate_subdata, GL_ARB_map_buffer_alignment, GL_ARB_map_buffer_range, GL_ARB_multi_draw_indirect, GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_occlusion_query2, GL_ARB_pixel_buffer_object, GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_program_interface_query, GL_ARB_provoking_vertex, GL_ARB_robust_buffer_access_behavior, GL_ARB_robustness, GL_ARB_sample_shading, GL_ARB_sampler_objects, GL_ARB_seamless_cube_map, -- GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_texture_float, GL_ATI_texture_mirror_once, GL_S3_s3tc, GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_bindable_uniform, GL_EXT_blend_color, GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access, GL_EXT_draw_buffers2, GL_EXT_draw_instanced, GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample, GL_EXTX_framebuffer_mixed_formats, GL_EXT_framebuffer_multisample_blit_scaled, GL_EXT_framebuffer_object, GL_EXT_framebuffer_sRGB, GL_EXT_geometry_shader4,

Any help would be greatly appreciated!
< >
Showing 1-6 of 6 comments
Dusk of Oolacile Apr 17, 2013 @ 9:58am 
Maybe install the (32-bit) package that provides the libtrace.so file?
Thyriel Apr 17, 2013 @ 11:27am 
Packages are called libtrace3 and probably libtrace-tools
Last edited by Thyriel; Apr 17, 2013 @ 11:27am
GMm3 Apr 17, 2013 @ 12:27pm 
I have libtrace3 and libtrace-tools installed and still get the error.

When I take the libtrace.so form '/home/chris/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/nvidia-cg-toolkit/examples/Tools/trace/libtrace.so.gz' and put into /home/chris/.local/share/Steam/ubuntu12_32. Steam will start but give the glx not direct rendering error
GMm3 Apr 17, 2013 @ 4:59pm 
Here is something I just found. When i run sudo upgrade-system and it gets to the orphaned packages it part. It reports that ia32-libs*, and libc6-i386* are orphaned and will be removed. So there must be something with 32bit install?
Blumimic Apr 17, 2013 @ 5:04pm 
I think it says that because those two packages were renamed.
GMm3 Apr 18, 2013 @ 1:13pm 
Well i tried a whole new clean install of LMDE x64 today and installed the 32bit stuff and when I run upgrade system it say's the 32bit stuff is openhanded and removes it.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Apr 17, 2013 @ 9:37am
Posts: 6