bladerunner Apr 9, 2013 @ 6:26am
[Linux] Warning: Could not find '/tmp/<random string here>', starting '/bin/bash' instead.
As above, ever since I had to reinstall everything due to a botched kubuntu ppa build, I'm getting this error on startup. It's annoying because I have Steam on autostart, and it always opens up a terminal to tell me it can't find that file, then continues to work flawlessly. Here's my output of 'ls /tmp' (only the file that Steam was looking for):


Warning: Could not find '/tmp/tmpG1_sP6', starting '/bin/bash' instead. Please check your profile settings.

myname@l502x ~/.local/share/Steam $ ls /tmp | grep tmp
4.0K -rwx------ 1 myname myname 1.2K Apr 9 14:07 tmpG1_sP6

The permissions on /tmp are drwxrwxrwt, owner root:root.

And this is the output from running /usr/bin/steam:
konsole(5545): "Could not find binary: " "/tmp/tmpG1_sP6"

Any ideas? Thanks :)
Last edited by bladerunner; Apr 9, 2013 @ 7:43am
Showing 1-3 of 3 comments
< >
Thyriel Apr 9, 2013 @ 9:13am 
delete the user in terminal and recreate it with the "-s /bin/bash" option. See Arch Wiki for Details, should work on ubuntu too when you add sudo:
https://wiki.archlinux.org/index.php/Users_and_Groups
bladerunner Apr 9, 2013 @ 12:08pm 
Tried it, but it didn't work, unfortunately. And I maybe should have added that I'm on Mint 14 KDE x64. Thanks for the help, anyway :).

On a side note, sudo can't possibly work because you need to not be logged in as the user you're deleting :). I just logged in as root from tty1 and recreated my user from there.
bladerunner Apr 9, 2013 @ 12:54pm 
Weird, installing gnome-terminal fixes it. But what a waste of 30MB. Better go report it on the issue tracker.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Apr 9, 2013 @ 6:26am
Posts: 3