Byte me Apr 6, 2013 @ 8:13pm
Low fps for TF2 on Linux 11.10
I'm sure there's many discussions about this, but the ones I've found are either outdated or not very helpful.

Here's some quick info on my computer:
Intel Core 2 Duo 2.00GHz
GeForce 9600M GT/PCI/SSE2
Ubuntu 11.10 32-bit

Before switching to linux I was able to play fine with no lag, or low ping, but now the lag is horrendous! I've put all my settings in tf2 to low, no bloom, no antialiasing, etc. Everything is lowest to the low. What can I do to play tf2 without so much lag/low fps? TF2 is supposed to be Linux friendly now, right? Am I missing something?
Last edited by Byte me; Apr 6, 2013 @ 8:17pm
Showing 1-7 of 7 comments
< >
-FwG- ^ Bucky21659 Apr 6, 2013 @ 9:36pm 
Just a heads up, don't expect to get any useful support on an old outdated version of Ubuntu, you need at least 12.04 or 12.10.. then again they're about to come out with 13.04 so..
And don't call it 'Linux 11.10.' That has trollbait written all over it..

tl;dr
Upgrade to 12.04 or 12.10.
Thyriel Apr 7, 2013 @ 4:04am 
1. Steam has minimum requirement Ubuntu 12.04, upgrade it.
2. most likely you did not install propietary drivers correctly (or not at all)
blackout24 Apr 7, 2013 @ 4:13am 
I always wonder why some people stick with 2 or even 3 year old Ubuntu versions. What's their reasoning? I noticed that here a few times that some still use 10.04. I can imagine why someone would still use 10.10 or earlier, because they had Gnome 2. But with 11.10 you have Unity when it was still a clusterf*ck and barely usable.

2 year old Ubuntu probably also means 2 years old graphics driver. We are at 313.30 already ;-)
Fibbles Apr 7, 2013 @ 10:50am 
Because 10.04 is a Long Term Support version of Ubuntu. Not sure why Saline has installed 11.10 though. I'm guessing he's new to this and has just downloaded the first image he could find.
Byte me Apr 7, 2013 @ 2:40pm 
Originally posted by -FwG- ^ Bucky21659:
And don't call it 'Linux 11.10.' That has trollbait written all over it..

Either way, you understood what I meant. :) The original title was "Low fps for TF2 on Linux", I added 11.10 much later right before submitting my question.


I installed 11.10 from my usb about 2 years ago, but wasn't aware you had to upgrade it. I'll look into doing that now. Thanks.
Shark Apr 7, 2013 @ 2:44pm 
Originally posted by NaCl + H2O:
Originally posted by -FwG- ^ Bucky21659:
And don't call it 'Linux 11.10.' That has trollbait written all over it..

Either way, you understood what I meant. :) The original title was "Low fps for TF2 on Linux", I added 11.10 much later right before submitting my question.


I installed 11.10 from my usb about 2 years ago, but wasn't aware you had to upgrade it. I'll look into doing that now. Thanks.
You should be able to do that from the update manager.
Byte me Apr 7, 2013 @ 4:44pm 
yup yup, it's updating right now
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Apr 6, 2013 @ 8:13pm
Posts: 7