Steam for Linux > 一般討論 > 主題細節
DeadWire 2013 年 03 月 25 日 @ 下午 9 時 59 分
Newbie in need of help with Nvidia X Settings
Me again so once more forgive my so-so English......I'm running a 660ti in Kubuntu 12.04 and by default i have some nasty screen tearing. Now I can fix the tearing by changing the screen resolution and refresh rate from AUTO to what they specifically are (1680x1050 60Hz)......problem is the settings revert to AUTO, if I restart the computer I again have to set everything to stop the tearing,its a minor annoyance, but still is there any way to stop the X server settings from reverting to AUTO detecting the resolution and refresh rate?
最後修改者:DeadWire; 2013 年 03 月 25 日 @ 下午 10 時 00 分
顯示 1-9,共 9 則回應
< >
LA_MERC_MadMAX 2013 年 03 月 25 日 @ 下午 10 時 43 分 
Hi there,
Open Konsole and run 'sudo nvidia-settings' enter your password when prompted and nvidia-settings will open. Make your changes, hit apply to test them to make sure they are good and click 'save configuration to file' save it to /etc/X11/xorg.conf


Reboot and you should have your correct settings.
DeadWire 2013 年 03 月 25 日 @ 下午 11 時 13 分 
Thanks that seems to have done the trick
LA_MERC_MadMAX 2013 年 03 月 26 日 @ 上午 12 時 32 分 
Sweet. Cool deal!
[Linux] frankweslar 2013 年 03 月 26 日 @ 上午 2 時 21 分 
Don't use "sudo" with graphical applications

Use gksu or gksudo
DeadWire 2013 年 03 月 26 日 @ 上午 3 時 11 分 
Ok did that and got this in the terminal "VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Default Device" must have a Driver line."

......also the tearing on the upper part of my screen issue seems to come back on every startup, any ideas what the problem could be?
TarrasQ 2013 年 03 月 26 日 @ 上午 9 時 27 分 
Is that validation error before or after you try to save your new settings?
I think I'd try to mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup just in case, so that nvidia-settings can write a completely new file. Maybe you already had an xorg.conf and it's a bit broken for some reason. That way your settings may not be saved at all or they're not loaded on boot.
DeadWire 2013 年 03 月 26 日 @ 下午 3 時 10 分 
It was before and has not happened since......that said this damn tearing is near to becoming a major annoyance
Cheogh 2013 年 03 月 26 日 @ 下午 4 時 08 分 
You may need to unclick the merge check box then click save.
最後修改者:Cheogh; 2013 年 03 月 27 日 @ 上午 12 時 12 分
DeadWire 2013 年 04 月 6 日 @ 上午 4 時 59 分 
This all seemed to be an issue with my GPU and anything based on 12.04, since I installed the 13.04 BETA the issue has vanished even in Unity where it was at its worst
顯示 1-9,共 9 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 03 月 25 日 @ 下午 9 時 59 分
回覆: 9