Steam for Linux > Discussioni generali > Dettagli della discussione
DeadWire 25 mar 2013, ore 21:59
Newbie in need of help with Nvidia X Settings
Me again so once more forgive my so-so English......I'm running a 660ti in Kubuntu 12.04 and by default i have some nasty screen tearing. Now I can fix the tearing by changing the screen resolution and refresh rate from AUTO to what they specifically are (1680x1050 60Hz)......problem is the settings revert to AUTO, if I restart the computer I again have to set everything to stop the tearing,its a minor annoyance, but still is there any way to stop the X server settings from reverting to AUTO detecting the resolution and refresh rate?
Ultima modifica da DeadWire; 25 mar 2013, ore 22:00
Visualizzazione di 1-9 commenti su 9
< >
LA_MERC_MadMAX 25 mar 2013, ore 22:43 
Hi there,
Open Konsole and run 'sudo nvidia-settings' enter your password when prompted and nvidia-settings will open. Make your changes, hit apply to test them to make sure they are good and click 'save configuration to file' save it to /etc/X11/xorg.conf


Reboot and you should have your correct settings.
DeadWire 25 mar 2013, ore 23:13 
Thanks that seems to have done the trick
LA_MERC_MadMAX 26 mar 2013, ore 0:32 
Sweet. Cool deal!
[Linux] frankweslar 26 mar 2013, ore 2:21 
Don't use "sudo" with graphical applications

Use gksu or gksudo
DeadWire 26 mar 2013, ore 3:11 
Ok did that and got this in the terminal "VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Default Device" must have a Driver line."

......also the tearing on the upper part of my screen issue seems to come back on every startup, any ideas what the problem could be?
TarrasQ 26 mar 2013, ore 9:27 
Is that validation error before or after you try to save your new settings?
I think I'd try to mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup just in case, so that nvidia-settings can write a completely new file. Maybe you already had an xorg.conf and it's a bit broken for some reason. That way your settings may not be saved at all or they're not loaded on boot.
DeadWire 26 mar 2013, ore 15:10 
It was before and has not happened since......that said this damn tearing is near to becoming a major annoyance
Cheogh 26 mar 2013, ore 16:08 
You may need to unclick the merge check box then click save.
Ultima modifica da Cheogh; 27 mar 2013, ore 0:12
DeadWire 6 apr 2013, ore 4:59 
This all seemed to be an issue with my GPU and anything based on 12.04, since I installed the 13.04 BETA the issue has vanished even in Unity where it was at its worst
Visualizzazione di 1-9 commenti su 9
< >
Per pagina: 15 30 50
Data di pubblicazione: 25 mar 2013, ore 21:59
Messaggi: 9