CyBob_7 Mar 25, 2013 @ 7:18pm
Logitech Dual Action Gamepad Help for TF2
I was wondering if anyone has had any luck getting the Logitech dual action gamepad working for tf2 under steam for linux. I had placed a file named joystick.cfg into ../steam/steamapps/cybob_7/Team Fortress 2/tf/cfg, which is loaded by the console, but when trying to map any of the buttons or use the sticks, nothing registers. I had found the cfg file after some googling and is as follows:

joy_name "Logitech Dual Action USB"
joystick 1
joy_advanced 1
joy_advaxisx 3
joy_advaxisy 1
joy_advaxisz 4
joy_advaxisr 2
joy_advaxisu 0
joy_advaxisv 0
joy_forwardsensitivity -1
joy_sidesensitivity 1
joy_pitchsensitivity 1.0
joy_yawsensitivity -1.25
joy_autoaimdampenrange 0.85
joy_autoaimdampen 0.5
joy_lowend 0.65
joy_lowmap 0.15
joy_accelscale 2.0
joy_accelmax 2.0
joy_response_move 0
joy_response_look 1

hud_fastswitch 2

+jlook

tf_build_menu_controller_mode 1
tf_disguise_menu_controller_mode 1
joy_display_input 1

joyadvancedupdate

console output:
Found joystick 'Logitech Logitech Dual Action' (030000006d04000016c2000010010000),but no recognized controller configuration for it.

And a few lines down:
Using joystick 'Logitech Dual Action USB' configuration
JOY_AXIS_X: mapped to Side (absolute)
JOY_AXIS_Y: mapped to Forward (absolute)
JOY_AXIS_Z: mapped to Turn (absolute)
JOY_AXIS_R: mapped to Look (absolute)
JOY_AXIS_U: unmapped
JOY_AXIS_V: unmapped
Advanced Joystick settings initialized

The controller has been calibrated and works fine under another of my games, bastion. I just had the thing lying around. This is more of a curiosity to see if it can work than anything else. Any help is appreciated. I am currently running Linux Mint 14 KDE.

Thanks,
Cybob_7
Showing 1-4 of 4 comments
< >
capcavern Mar 26, 2013 @ 11:59am 
xboxdrv doesn't work for you ?
#sudo apt-get install xboxdrv
#sudo xboxdrv --detach-kernel-driver --mimic-xpadsudo xboxdrv --detach-kernel-driver --mimic-xpad
xDShot™ Mar 26, 2013 @ 2:02pm 
My Logitech F310 doesn't work in TF2 Linux.
SUSEd Mar 27, 2013 @ 2:29am 
Same with F510. Devs broke config, not system problem.
CyBob_7 Mar 27, 2013 @ 10:52am 
So I found a package for ubuntu and linux mint users called joystick. I ran the commands
sudo apt-get update
sudo apt-get install joystick

From there I ran the kde's calibration tool from System Settings > Input Devices , selecting the joystick option in the side pane. I had found that users with gtk could also give a program called jstest-gtk a go. Bastion was working after this calibration. Still I was having issues with tf2 not recognizing the gamepad's input. Then I tried messing around in big picture mode. In the settings, I found settings for mapping a controller. It is fairly straight forward, and all the buttons were matched up according to the picture, except for one which I figure is the center xbox button(don't have one of those). After that, I ran tf2 again. And it worked! Hope this helps anyone else having problems w/ gamepads.

Also, does xboxdrv work for non xbox controllers capcavern? That may have helped as well, but since I got it working last evening, I didn't bother. Thanks though.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Mar 25, 2013 @ 7:18pm
Posts: 4