Steam for Linux

Steam for Linux

r.everaert Mar 25, 2013 @ 6:14am
[Linux] Since last update need STEAM_RUNTIME=1 to start steam
Hi,

If I don't prefix the steam executable by STEAM_RUNTIME=1, the game report a missing libSDL2 library and crash.

Is there a file where that information can be kept?

Of course I can place it in .bashrc or .bash_profile but I would prefer to keep that parameter under the control of thje steam client. BTW, the same question appliy to SDL_AUDIODRIVER because I don't use pulseaudio.

My linux distro is a Gentoo Linux 64 bits
< >
Showing 1-13 of 13 comments
instabilis Mar 25, 2013 @ 7:07am 
You need to take a look at the steam sh file in whichever bin/ directory you have it in, uncomment lines 179 - 181

# Uncomment this if your distribution supports the Steam Linux Runtime #if [ -z "$STEAM_RUNTIME" ]; then # STEAM_RUNTIME=1 #fi
Last edited by instabilis; Mar 25, 2013 @ 7:07am
r.everaert Mar 25, 2013 @ 10:45am 
Strange, that code was already uncommented but the varaible set to 0. Anyway, I set it to 1 and everything is fine.

Thanks.
drewb🐧 Mar 25, 2013 @ 10:49am 
STEAM_RUNTIME should be automatically set, you shouldn't have to do anything. Do you have the latest version of Steam?

The basic steam.sh doesn't have the block that instabilis shows, but it's possible that whatever you used to install Steam is forcing the variable somehow. How did you get Steam?
Baked_Potato Mar 25, 2013 @ 10:53am 
This is the exactly same thing for me. and im also on Gentoo 64. and i am running the latest version of steam
r.everaert Mar 25, 2013 @ 10:57am 
Through the "steam" overlay for Gentoo Linux.
instabilis Mar 25, 2013 @ 12:50pm 
Originally posted by drewb🐧:
The basic steam.sh doesn't have the block that instabilis shows, but it's possible that whatever you used to install Steam is forcing the variable somehow. How did you get Steam?
I was referring to bin_steam.sh, admittedly I was referencing an older version, the lines are 186-189 in the latest version.

The steam.desktop file is hardcoded to launch /usr/bin/steam, which only gets updated with the rest of the system if you're using a repo, or not at all if you installed Steam with the .tar.gz
Last edited by instabilis; Mar 25, 2013 @ 1:09pm
drewb🐧 Mar 25, 2013 @ 1:20pm 
When you run Steam from a terminal do you get a message like 'STEAM_RUNTIME is disabled by the user'? If so somewhere there's already a STEAM_RUNTIME definition that you'll need to remove. It's possible Gentoo's install does that, I'm not sure.

The Steam code itself doesn't set STEAM_RUNTIME=1 any more, it's set to a path, so anything with STEAM_RUNTIME=1 is older or not part of Steam. If you've set STEAM_RUNTIME=1 outside of Steam you should see a 'STEAM_RUNTIME is enabled by the user' message.
boot Mar 25, 2013 @ 1:56pm 
Originally posted by drewb🐧:
When you run Steam from a terminal do you get a message like 'STEAM_RUNTIME is disabled by the user'? If so somewhere there's already a STEAM_RUNTIME definition that you'll need to remove. It's possible Gentoo's install does that, I'm not sure.

The Steam code itself doesn't set STEAM_RUNTIME=1 any more, it's set to a path, so anything with STEAM_RUNTIME=1 is older or not part of Steam. If you've set STEAM_RUNTIME=1 outside of Steam you should see a 'STEAM_RUNTIME is enabled by the user' message.

The "Steam" overlay in Gentoo has the runtime disabled by default.


It's running fine here, I'm also on the latest steam client beta.
Have you updated the overlay recenlty?

There's also a github page for issues with this overlay.
https://github.com/anyc/steam-overlay
Last edited by boot; Mar 25, 2013 @ 1:57pm
TheJJ Mar 25, 2013 @ 7:39pm 
===================================================
enable the use flag abi_x86_32 for media-libs/libsdl from the gamerlay
===================================================
rebuild libsdl:2, and you should be good to go with STEAM_RUNTIME=0 (-> disabled)
Baked_Potato Mar 26, 2013 @ 7:18am 
Originally posted by TheJJ:
===================================================
enable the use flag abi_x86_32 for media-libs/libsdl from the gamerlay
===================================================
rebuild libsdl:2, and you should be good to go with STEAM_RUNTIME=0 (-> disabled)

try'd that. didnt work :P but i really dont care because i just run it with steam runtime=1 in the shortcut and it works fine :)
koniiiik May 6, 2013 @ 2:43pm 
Gentoo users should add the following line to /etc/portage/package.use:
games-util/steam-launcher steamruntime
and then re-emerge steam-launcher, this should set STEAM_RUNTIME to 1 by default.
492 Aug 11, 2013 @ 4:41am 
ok... i'm new to ubuntu, i understand this is prob gentoo users specific but I have a feeling its the same thing with mine...

running ubuntu 12.04
when I terminal 'steam' i get

Running Steam on ubuntu 12.04 32-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1374875626_client)
Xlib: extension "GLX" missing on display ":0.0".
Installing breakpad exception handler for appid(steam)/version(1374875626_client)
Installing breakpad exception handler for appid(steam)/version(1374875626_client)
unlinked 1 orphaned pipes
removing stale semaphore last operated on by process 17642 with name 0eBlobRegistryMutex_73BC5B4EF672DC23ED7D5D05CB665387
removing stale semaphore last operated on by process 17642 with name 0eBlobRegistrySignal_73BC5B4EF672DC23ED7D5D05CB665387
removing stale semaphore last operated on by process 17642 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 17642 with name 0eSteamEngineLock
Xlib: extension "GLX" missing on display ":0.0".

I have no idea where to change the run_time = 1 thing just to try this solution and see if it fixed my issue

please give me some more information on where to change the setting, thanks
492 Aug 11, 2013 @ 4:42am 
Originally posted by ToTeX_Baked:
Originally posted by TheJJ:
===================================================
enable the use flag abi_x86_32 for media-libs/libsdl from the gamerlay
===================================================
rebuild libsdl:2, and you should be good to go with STEAM_RUNTIME=0 (-> disabled)

try'd that. didnt work :P but i really dont care because i just run it with steam runtime=1 in the shortcut and it works fine :)


how do you do the shortcut exact?
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Mar 25, 2013 @ 6:14am
Posts: 13