tele2win Mar 17, 2013 @ 6:40am
opensuse 12.2: 1 way to get get sound working
When I got Steam for linux, I was excited to start goofing around but found there were issues with sound and my distro of choice, opensuse 12.2. After several hours of searching here is what I've come up with that seems to make the 5 games I have all play nicely together. I hope this helps someone who might be having a tough time.

1. add the following to ~/.bashrc: export SDL_AUDIODRIVER=pulseaudio
2. UNCOMMENT the following line in /etc/openal/alsoft.conf: (note that this IS all one line)
drivers = pulse,alsa,core,oss,solaris,sndio,mmdevapi,dsound,winmm,port,opensl,null,wave

Why did I do it this way? I also have UT2004 and Nexuiz Classic in addition to Counter Strike Source, Half Life, and Red Orchestra Ostfront. If I used alsa, I had sound in CSS, and HL, but NOT in RO or UT2004 because those two games use openal for audio. Taking these steps got me sound in all the games EXCEPT Nexuiz. I had to change the launch script to "nexuiz-linux-glx.sh" and then that worked fine.

I also have my system set up as a digital audio workstation and these things seem to have no bad effects on it.

System Specs:

Operating System: opensuse 12.2 64-bit
Kernel: 3.4.33-desktop
Desktop: KDE 4.8.5
Graphics Card: Nvidia GTX 480
Graphics Driver: Nvidia Proprietary 310.40
System Board: Gigabyte GA-X58A-UD3R
Sound Devices: On-board Intel, Nvidia Graphics Card HD, Fender Mustang 1 USB Audio Dev
Sound Server Choice: Pulse Audio with support for Alsa and OpenAL
Steam Games: Half-Life, Counter Strike Source, Red Orchestra Ostfront
Non-Steam Games: UT2004, Nexuiz Classic

Please note that there might be a better way but this works for me...

Showing 1-15 of 27 comments
< >
arc| Gps Mar 17, 2013 @ 1:55pm 
I used to start steam wit sdk audiodriver = pulseaudio.
I do not need that anymore, since one of the steam updates. (about a month ago)
The games are Half life, Teamfortress, counterstrike.
Serious Sam 3 never needed anything.

OpenSUSE 12.2 and now 12.3


Audio device: Realtek ALC892
(on board sound)
Last edited by arc| Gps; Mar 17, 2013 @ 1:55pm
tele2win Mar 17, 2013 @ 2:22pm 
Cool! I'm not sure why I needed to do this then... Might be because I did an upgrade versus a clean install? Or a difference in the sound card. I'm not sure what the onboard sound is seen as in Windows.

Have you encountered any issues with 12.3?

Thanks!!
arc| Gps Mar 17, 2013 @ 7:29pm 
After install I had no internet. I espect that they fixed this already.
I installed it the day it was released ( last wednesday)
When I went to the openSUSE forums to ask for help, there was already a sticky topic, on how to get it fixed.
No commadnline needed, just through yast. :)

No other issues.

Installing steam, one click install.
( after install i removed that repo though )
Installing amd catalyst 13.1 one click install.
Aditional codecs, one click install.

I also did not have to add any repo's, that was done automaticly with the one click install too.

12.3 start up about twice as fast as 12.2 :)
You get kernel 3.7.

And I love the dark theme.
Last edited by arc| Gps; Mar 17, 2013 @ 7:31pm
tele2win Mar 17, 2013 @ 8:57pm 
Thanks!!! Good to know. I will probably back up and try it out... Also need to make sure must-have apps will run on it. ;)

Thanks!!!
{XFCE}Zatorys Mar 18, 2013 @ 3:30pm 
Originally posted by arc| Gps:
After install I had no internet. I espect that they fixed this already.
I installed it the day it was released ( last wednesday)
When I went to the openSUSE forums to ask for help, there was already a sticky topic, on how to get it fixed.
No commadnline needed, just through yast. :)

No other issues.

Installing steam, one click install.
( after install i removed that repo though )
Installing amd catalyst 13.1 one click install.
Aditional codecs, one click install.

I also did not have to add any repo's, that was done automaticly with the one click install too.

12.3 start up about twice as fast as 12.2 :)
You get kernel 3.7.

And I love the dark theme.


man im using 12.3 and its FTW :)
SUSEd Mar 19, 2013 @ 2:25am 
I'm using 12.3 and seems that sound fixed in TF2, it works without SDL_AUDIODRIVER=pulseaudio.
But not in CS:S.
tele2win Mar 20, 2013 @ 2:13pm 
Hey SUSEd,

Have you been able to get it to work?

tele
tele2win Mar 20, 2013 @ 2:16pm 
Cool {XFCE}Zatorys... :)

Are you using VMWare Workstation or JACK with Ardour2? Those are probably my three biggest must have apps...

tele
arc| Gps Mar 20, 2013 @ 3:32pm 
Originally posted by SUSEd:
I'm using 12.3 and seems that sound fixed in TF2, it works without SDL_AUDIODRIVER=pulseaudio.
But not in CS:S.

That is anoying. but I asume you already posted it on the github ?
I do not understand why the souce games have or had this problem,
arc| Gps Mar 20, 2013 @ 3:38pm 
Originally posted by tele2win:
Cool {XFCE}Zatorys... :)

Are you using VMWare Workstation or JACK with Ardour2? Those are probably my three biggest must have apps...

tele

I do not know about ardour or jack, but lmms worked right out of the box.
No money right now, but for lmms and such I might get a soundcard.
And a simple midi keyboard.

http://www.thomann.de/nl/akai_lpk_25.htm

Its a dutch site, but that does not matter for the picture.

LMMS ( fruity loops for Linux so to say, with midi support)
http://lmms.sourceforge.net/

http://www.youtube.com/watch?v=BKkg9qDpF1g

http://www.youtube.com/watch?v=7pRAlayVClU
Last edited by arc| Gps; Mar 20, 2013 @ 3:42pm
SUSEd Mar 20, 2013 @ 11:21pm 
When i'm launching steam without SDL_AUDIODRIVER=pulseaudio and launch TF2 sound works fine and no error messages appears.
But when i'm launching CS:S appears message that target 'pulse' not found.
So now i'm launching steam with SDL_AUDIODRIVER=alsa.
tele2win Mar 21, 2013 @ 9:09pm 
Hey SUSEd,

get your computer ready as if you are ready to run css...

then try typing this from the command prompt?

I want to see the output?

set | grep SDL_AUDIODRIVER

tele
SUSEd Mar 22, 2013 @ 12:08am 
Originally posted by tele2win:
Hey SUSEd,

get your computer ready as if you are ready to run css...

then try typing this from the command prompt?

I want to see the output?

set | grep SDL_AUDIODRIVER

tele

$ set | grep SDL_AUDIODRIVER
$ SDL_AUDIODRIVER=pulse
tele2win Mar 22, 2013 @ 3:59am 
Hey SUSEd,

Try editing the file in /home/<whatever your username is>/.bashrc and adding this line to it:
export SDL_AUDIODRIVER=pulseaudio
NOTE: ".bashrc" is a hidden file...

After that, log out and then log back in again.

Next, when you launch Steam go to Steam > Settings > Voice and check that Voice is set to use "Pulse Audio Default".

Lastly, exit Steam and then go back in again and try out each of your games...

tele
tele2win Mar 22, 2013 @ 4:03am 
Oooops to be more clear, you don't need to add the "NOTE: ".bashrc" is a hidden file..." Just add "export SDL_AUDIODRVIER=pulseaudio" with no quotes to .bashrc

tele
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Mar 17, 2013 @ 6:40am
Posts: 27