TechG4m3r Mar 14, 2013 @ 12:16pm
TF2 "Update OpenGL Driver" WTF???
I use openSUSE 12.3 and my brother uses Kubuntu12.04 and in both computers the graphics drivers are fully up-to-date(I use nvidia310.40,he uses amd13.1) ever since an update TF2 keeps telling me to update my opengl drivers, but as far as I know they're already up-to-date. Why wrong? I'm using GTX260 bro uses ATi Radeon 4850.
Showing 1-8 of 8 comments
< >
Doc Holliday Mar 14, 2013 @ 12:18pm 
you use 64bit?
SUSEd Mar 14, 2013 @ 12:24pm 
Do you checked steam for updates?
TechG4m3r Mar 14, 2013 @ 12:25pm 
x86_64 both PC's. My steam's up-to-date.
Stormsight Mar 14, 2013 @ 2:54pm 
i have the same problem on 2 laptops, the older one has an nvidia GeForce Go 7400, where i think the needed version of opengl is not supperted, but on my new laptop where i have a wmware virtual machine with linux mint 14 and an amd 7970m it still tells me:
could not find required opengl entry point 'glcolormaskindexedext'! either your card is unsuppoerted or your opengl driver needs to be updated
Kamikaze Mar 14, 2013 @ 10:35pm 
Check this part of your Help -> System Information in Steam:
Video Card:
Driver: NVIDIA Corporation GeForce GT 240/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 313.26
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xca3
Number of Monitors: 2

The driver version (seems to) reflects what OpenGL capability your current card & driver can offer. At least, I've noticed this version string is different between my two systems and the only thing different about them is one has a newer NVIDIA card. It's possible that the proprietary NVIDIA driver did not install correctly on your system.
You should probably also check glxinfo if you have it, or nvidia-setttings and check the 'OpenGL/GLX Information' tab and look at the 'Direct Rendering' line to make sure it's 'Yes'
TechG4m3r Mar 15, 2013 @ 4:20am 
Originally posted by ;828933455609614395:
Check this part of your Help -> System Information in Steam:
Video Card:
Driver: NVIDIA Corporation GeForce GT 240/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 313.26
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xca3
Number of Monitors: 2

The driver version (seems to) reflects what OpenGL capability your current card & driver can offer. At least, I've noticed this version string is different between my two systems and the only thing different about them is one has a newer NVIDIA card. It's possible that the proprietary NVIDIA driver did not install correctly on your system.
You should probably also check glxinfo if you have it, or nvidia-setttings and check the 'OpenGL/GLX Information' tab and look at the 'Direct Rendering' line to make sure it's 'Yes'
The Direct Rendering line is a bit strange, if I launch nvidia-settings as normal user it shows me 'No' if I launch it as root it shows me 'Yes'. Anyway still doesn't help me, TF2 won't launch.
Kamikaze Mar 15, 2013 @ 4:34am 
I realise you're not running ubuntu, but this bug could be relevant:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/370249

Run:
ls -l /dev/nvidia*
Check that your user has access to read and write from those devices. If not, fix the permissions and/or add yourself into whatever group has r/w access to it.

If that doesn't solve it, you might have conflicting versions of libGL.so on your system, or possibly incorrect permissions on your libGL.so.
[Linux] Salmonvich Mar 15, 2013 @ 6:07am 
On openSUSE 12.3 x86_64 and with the same NVIDIA GTX260 as you with latest drivers, I can confirm that the following did the trick:

User and and Group Management > Users > Edit > Details > Additional Groups > Video

You will need to reboot after.

I can duplicate the error by undoing the above change. Hope this helps!
Last edited by [Linux] Salmonvich; Mar 15, 2013 @ 6:11am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Mar 14, 2013 @ 12:16pm
Posts: 8