Rods Mar 12, 2013 @ 9:16pm
Games wont launch
I cant run any games from steam. Some of them even open the config screen like Trine 2, but, when i try to load, it just open a black window(because im using window mode) and close it a few seconds later. Dont know what is happening, i've already tried a fresh install of all the Mint 14 versions (Mate, Cinnamon and KDE), all of them with the same issue. I'm using KDE now. Catalyst 13.2, AMD FX 8350 4.33ghz (OC), Motherboard ASUS Sabertooth 990FX, AMD Radeon 6850 1gb 256 bits, 8gb RAM.
Last edited by Rods; Mar 14, 2013 @ 3:43am
Showing 1-15 of 23 comments
< >
s.plisskin [Archlinux] Mar 12, 2013 @ 10:39pm 
If your running 64 bit make sure you have your lib32 files installed. Also find out if you have the games dependencies installed.
{XFCE}Zatorys Mar 13, 2013 @ 4:15am 
try this

sudo apt-get install ia32-libs
Rods Mar 13, 2013 @ 7:05am 
Ok guys, thank you for the answer, i'll try it later when i get home. I thought it couldn't be it, because when i launch the Steam by the first time it opens the terminal and installs some 32libs...Isn't these libs you guys are talking about?
Mai Mar 13, 2013 @ 11:59am 
Just try to install it, if it's already installed, then you would need a graphics driver
{XFCE}Zatorys Mar 13, 2013 @ 3:23pm 
did it works ?
Rods Mar 13, 2013 @ 5:44pm 
didnt work =(, it wasnt installed so i did install, but still doesnt work, and this time after the black window appear(like the game was going to load) the steam also closed.
Teisei Mar 13, 2013 @ 6:45pm 
I'd like to help but I have no recent experiences with AMD graphics cards. By the way, you should try installing XFCE. It's a fast and beautiful desktop environment for gaming.
Rods Mar 13, 2013 @ 6:58pm 
That was the only version i didnt test, about the others, all of them with serious bugs, most of them related with personalizations, and i do have machine enough for KDE =T. About my issue? Does anybody have any sugestion?
{XFCE}Zatorys Mar 13, 2013 @ 7:46pm 
ok open Synaptic Package Manager
and type libgl1-mesa then download every pickage start with mesa
if not works try to delete ur new amd driver and get the old back
sry man i didnt use amd since 2004

and if u want my advice try Xubuntu 12.10 with xfce ..so far 0 issue for me and very stable
http://xubuntu.org/getxubuntu/

if ur done with ubuntu try openSUSE 12.3 ! is very stable and friendly
Last edited by {XFCE}Zatorys; Mar 13, 2013 @ 8:03pm
Rods Mar 14, 2013 @ 3:41am 
I've already tried to use the Opensuse, and i'm really done with Ubuntu, that "LTS" stable version is a joke, i got like 5 crashs in the first hour of use. Anyway, is that XFCE this great? Never tried it. About installing another drivers, doesnt make sense, im using the oficial package from amd website, and it was working really fine, the version 13.2 im using, but some how, its not working anymore, at all, doesnt matter wich version of window manager i use. Ill try to open the steam using the terminal later, and post the crash here, is something like "CRASH segmentation fault". This is really frustrating, i can run mostly of the games with full graphics in the Windows with my specs.
Teisei Mar 14, 2013 @ 3:51am 
Yes, XFCE is in my opinion one of the most "foolproof" desktops there is. It's fairly simple, yet configurable. It is also fast and pleases the eye.
Rods Mar 14, 2013 @ 3:53am 
thanks for the tip, gonna be the next wm i'll try
Rods Mar 15, 2013 @ 5:34pm 
dudes this is what happens in terminal when i try to launch the game Trine 2 and them it crash:

libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.

any ideas?
Rods Mar 16, 2013 @ 1:31pm 
up =/
Showing 1-15 of 23 comments
< >
Per page: 15 30 50

Date Posted: Mar 12, 2013 @ 9:16pm
Posts: 23