Osarusan Mar 12, 2013 @ 4:40pm
Performance Decrease on Linux?
During the Steam for Linux beta period, I was able to get great results on Team Fortress. It ran smooth, with no skipping at all. Since the official version was released, though, TF2 has been very skippy and full of visual tearing, in addition to a very strange delay between my mouse movements and what shows up on screen -- to the point where I just can't play the game on linux anymore.

I am running Ubuntu 12.10 x64 and I have an ATI Radeon HD 7750... I'm not sure why the performance would suddenly decrease. Am I the only one having this problem?
Showing 1-15 of 28 comments
< >
LOLCAT Mar 12, 2013 @ 4:44pm 
1. AMD drivers are crap. Try multiple versions and use the one that works best for you.
2. No matter which driver you use, turn off AA and AF. They're seriously unoptimized in fglrx.
3. Turn off vsync in the game and in your desktop environment. Also all HW acceleration in the latter one if you use something like that.
Kano Mar 12, 2013 @ 4:58pm 
AA is really slow with fglrx. If possible use a ppa for latest beta drivers and do not force vsync/tearfree.
ToTeX_Baked Mar 12, 2013 @ 6:40pm 
Originally posted by LOLCAT:
1. AMD drivers are crap. Try multiple versions and use the one that works best for you.

Amd drivers are not crap! ubuntu is crap. i have no trouble with performance. it only got better and better!
Osarusan Mar 12, 2013 @ 7:10pm 
I'm using the latest Catalyst 13.1, which for the most part works pretty well for me -- just not on TF. I've had both AA and AF turned off and it really didn't improve anything; nor does lowering resolution. I've just disabled Sync to VBlank in compiz config settings so we'll see if that fixes anything.

One odd thing I noticed is that sometimes, if I do the Training Exercises first, I can get a usable multiplayer game afterwards. It's not 100% guaranteed, but it seems to help some of the time. Thanks for the advice anyway. Hopefully the next Catalyst update will improve things. I was really just bewildered because it was working so smoothly in the beta, and just suddenly went to crap...
-FwG- ^ Bucky21659 Mar 12, 2013 @ 9:56pm 
Originally posted by ToTeX_Baked:
Originally posted by LOLCAT:
1. AMD drivers are crap. Try multiple versions and use the one that works best for you.

Amd drivers are not crap! ubuntu is crap. i have no trouble with performance. it only got better and better!
LOL NOOB!
StarFscker (RIP Braco) Mar 12, 2013 @ 10:40pm 
Ubuntu *is* crap, but only when compared to better Linux distros.

Obligatory "Debian User" mention.. because someone else said that we have to.
LOLCAT Mar 13, 2013 @ 1:17am 
Originally posted by ToTeX_Baked:
Originally posted by LOLCAT:
1. AMD drivers are crap. Try multiple versions and use the one that works best for you.

Amd drivers are not crap! ubuntu is crap. i have no trouble with performance. it only got better and better!
I do use a Radeon card (6850) and Fedora, so even though you're right and Ubuntu IS crap, it has nothing to do with the problem at hand.
sounds like a wooosh Mar 13, 2013 @ 2:28am 
* bah * just stop bashing and go on with more productive things. I mean - just take a look - you act like trolls (!) – do better!
LOLCAT Mar 13, 2013 @ 7:16am 
Originally posted by sounds like a wooosh:
* bah * just stop bashing and go on with more productive things. I mean - just take a look - you act like trolls (!) – do better!
Says someone who didn't contribute anything to the issue at hand to someone how actually did. Very funny.
Shark Mar 13, 2013 @ 8:00am 
Performance with amd drivers is idd not very consistent.
Last edited by Shark; Mar 13, 2013 @ 8:00am
Tweakedenigma Mar 13, 2013 @ 8:05am 
I haven't had any performance issues myself. However I am using an Nvidia 660GTX and I am running 12.10 32bit, So my experience probably isn't the best comparison.

LOLCAT is probably on the right path though. Could possibly be that Vsync is disabled in game.

I noticed recently that TF2 seems to override my desktop settings (EG: I have Vsync enabled via Nvidia settings, but I am getting 300fps in TF2).

Maybe setting the max FPS in game to 60 or enabling vsync in game will correct the problem.

Side note: As for the Distro wars. I think Ubuntu, Mint, Fedora, Suse, Arch, Gentoo, Debian, Slackware, Etc are all great in their own way and that they all keep doing what they are doing.
Last edited by Tweakedenigma; Mar 13, 2013 @ 8:38am
Osarusan Mar 13, 2013 @ 8:36am 
Ah okay, I didn't realize there was an in-game vsync option. I'll give that a try too and see if there are any improvements.
Osarusan Mar 13, 2013 @ 4:38pm 
Well, it turns out I already had vsync disabled in-game so that wasn't any help.
I'm 100% sure this is Compiz' fault actually. I know that the version included in 12.10 uses "Unredirect fullscreen windows" by default, which is supposed to disable compositing for games and the like, but it must not be worknig right. The game actually runs smooth *until* some kind of compositing feature shows up, like the Steam overlay, or by pressing the volume keys on my keyboard. It works fine on Crusader Kings II, and it didn't cause any problems during the Steam beta, but now it's not working right.
Unfortunately as Compiz Fusion Icon doesn't work in Unity, and there is no easy way to turn Compiz on and off, this still means logging into a different session each time I want to play a game. Yeah, I know, first world problems, right? Hopefully this is something they'll figure out soon, if they're serious about getting things working for games on linux.
Touch My Box Mar 13, 2013 @ 8:07pm 
I get this on the machine I've got with an ATI card too, but with that machine TF2 never ran great in linux. The input lag is horrible with vsync enabled, but there's still a little bit with vsync disabled.

I don't got much advice for you other than either wait for valve and/or amd to work it out or pick up a GTX 650 Ti or something.
Last edited by Touch My Box; Mar 13, 2013 @ 8:08pm
gradinaruvasile Mar 14, 2013 @ 1:53am 
I have a 7560D (integrated in A8-5500) and TF2 runs just fine (Debian Wheezy with Xfce, 13.1 driver, no compositing). I DID have some weird issues like that the OP mentions, but setting the following stuff did the trick:


Vsync - on in the driver, off in-game. Just me hating the tearing.
Mouse settings in-game - "use raw input" checked. Before i had some mouse lag. At one update this option, despite being checked, wasnt taken in consideration so i unchecked, re-checked it and restarted TF2.
AA off in-game.
Filtering: Trilinear.
HDR off.
Steam overlay - off (this can be specified in the Steam control panel). This setting brought a big speed improvement.

I get a smooth 50-75 FPS (the game sometimes reports spikes of >75 FPS for a fraction of the seconds, maybe the game engine fights the drivers settings or something), no tearing.
There are some initial stutters at the beginning of the level (the game loads something from the HDD, i see the hdd led blinking and hear it working) , but they go away so it must be the crappy loading issue (the game files are decompressed run time, an issue that supposedly will go away, already implemented in the beta version's changed file handling).
Showing 1-15 of 28 comments
< >
Per page: 15 30 50
Date Posted: Mar 12, 2013 @ 4:40pm
Posts: 28