|NAC²| D.Cent 18 oct 2013 à 14h02
TF2 always crashing after 2-3 map loading cycles?
I play TF2 at highest settings possible and the game runs great (NVIDIA GeForce 460 GTX). The only problem I have is that the game crashes after 2 or 3 map loading cycles (most of the time while loading a new map). If I look into nvidia-settings I can see that the video RAM is almost completely used, like 970 MB out of 1024 MB, so I think it might be some memory leak that causes the crashes? I'll append some console output tomorrow, but does anyone experience the same problem?
Affichage des commentaires 1 à 10 sur 10
< >
[Linux] Junior s2 Camila 18 oct 2013 à 15h31 
These TF2 problems (and now L4D2) come clearly from Valve.
Either frames-per-second drops, crashes when ALT+TAB, freezing, memory dumps.

Hope they fix them.
Swell Subset 19 oct 2013 à 12h40 
I have run into the same problem on a Sandy bridge machine with AMD 6850. After few minutes of TF2 I have seen 12GB of memory being used! Then it lags, obviously :-(
[Linux] Junior s2 Camila 19 oct 2013 à 12h56 
Swell Subset a écrit :
I have run into the same problem on a Sandy bridge machine with AMD 6850. After few minutes of TF2 I have seen 12GB of memory being used! Then it lags, obviously :-(
Then your fps drops, right?

Can you post your full system specs + distro?
And if you modified you BIOS please post it too (overclock/overvoltage/AMD Cool 'n Quiet etc)
Swell Subset 21 oct 2013 à 9h55 
Yes fps drops and I can't free the memory that was allocated either.
I am on Ubuntu 13.10 with kernel 3.12.rc5. AMD Proprietary 13.11 drivers.
I haven't overclocked or any of that jazz. This might just be catalyst drivers being really bad. I will try a more stable version of catalyst and see if that changes.
[Linux] Junior s2 Camila 21 oct 2013 à 14h31 
Go to your BIOS and search for "AMD Cool and quiet". See if it's enabled or not.
LOLCAT 22 oct 2013 à 4h11 
Go to your BIOS and search for "AMD Cool and quiet". See if it's enabled or not.
C&Q is a feture that drops the CPU multiplier to 4x if the CPU is idle. It has nothing to do with memory usage. Also it won't (shouldn't) drop during gaming.
Swell Subset 23 oct 2013 à 13h12 
Go to your BIOS and search for "AMD Cool and quiet". See if it's enabled or not.

LOLCAT is right, I have an intel processor so I have to deal with Intel's CnQ counterpart SpeedStep.
I finally managed to do some testing. It seems the fglrx latest beta drivers has a major regression. Although the fps during gameplay with the latest beta version is excellent, memory leak makes it fairly unusable. I reverted to an earlier version of the beta. There is no leak in this version, but performance loss is notable when compared to the latest beta drivers.
I guess I will have to stick to poor drivers for the time being.

Sorry OP to have taken over your thread. I don't have access to GTX460, but it might be worthwhile if you could try another version of the drivers you are using.
[Linux] Junior s2 Camila 23 oct 2013 à 19h13 
I also noticed that the legacy drivers for my card work better.
Swell Subset 26 oct 2013 à 12h39 
It seems like the drivers released yesterday fixed the memory bug!
whetzell 6 nov 2013 à 20h35 
Could this be an issue on an intel mac?
Affichage des commentaires 1 à 10 sur 10
< >
Par page : 15 30 50