f1ckratte Dec 8, 2013 @ 7:32pm
[solved]DOTA 2 on openSUSE 13.1 x64 660mgtx Optimus [solved]
Hi

Somehow I cant get DOTA 2 to run on my machine, im really frustrated geez, why does everything involving linux, graphics and sound has to be a pain in the ♥♥♥???

The intro wont show up, just black screen. If I dont do anything nothing happens, if i press space i see the cursor and after a little time im in the Menue.
The Screen is all red in the Menue and ingame i have poor performance and no Textures and Interface also red.
Tried both, High and low settings, results are the same....


Pics with low settings:

http://i.imagebanana.com/img/qeg5yj32/thumb/snapshot1.png
http://i.imagebanana.com/img/pjg45d5q/thumb/snapshot2.png
http://i.imagebanana.com/img/xqh762mu/thumb/snapshot3.png
http://i.imagebanana.com/img/4gss5l8r/thumb/snapshot4.png

Can someone help me?

I have openSUSE 13.1 x64 Out of the box, just installed Knurpht 's Bumblebee Optimus Driver and Steam from the game: tools pakage from the openSUSE.
I also have the primus pakage from knurpht installed. I guess somehow it runs on the intel card because of the poor performance. Primusrun also doesnt run correctly, thats what i think

primusrun glxspheres
gives me this output:
/usr/bin/primusrun: line 35: exec: glxspheres: not found

when i try to start dota with the primusrun %command% prefix it wont even start.

my primusrun is posted here (note that line 35 is at the verry end ofthe doccument)

#!/bin/bash

# Readback-display synchronization method
# 0: no sync, 1: D lags behind one frame, 2: fully synced
# export PRIMUS_SYNC=${PRIMUS_SYNC:-0}

# Verbosity level
# 0: only errors, 1: warnings (default), 2: profiling
# export PRIMUS_VERBOSE=${PRIMUS_VERBOSE:-1}

# Secondary display
# export PRIMUS_DISPLAY=${PRIMUS_DISPLAY:-:8}

# "Accelerating" libGL
# $LIB will be interpreted by the dynamic linker
export PRIMUS_libGLa=${PRIMUS_libGLa:-'/usr/$LIB/nvidia/libGL.so.1'}

# "Displaying" libGL
export PRIMUS_libGLd=${PRIMUS_libGLd:-'/usr/$LIB/libGL.so.1'}

# Directory containing primus libGL
PRIMUS_libGL=/usr/lib64/primus:/usr/lib/primus:/usr/lib64/nvidia:/usr/lib/nvidia${PRIMUS_libGL:-$(dirname `readlink -ne $0`)/'$LIB'}

# On some distributions, e.g. on Gentoo, libnvidia-tls.so is not available
# in default search paths. Add its path manually after the primus library
# PRIMUS_libGL=/usr/$LIB/primus:/usr/lib64/nvidia:/usr/lib/nvidia${PRIMUS_libGL}:/usr/\$LIB/opengl/nvidia/lib

# Mesa drivers need a few symbols to be visible
# export PRIMUS_LOAD_GLOBAL=${PRIMUS_LOAD_GLOBAL:-'libglapi.so.0'}

# Need functions from primus libGL to take precedence
export LD_LIBRARY_PATH=${PRIMUS_libGL}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}

# And go!
exec "$@"



can please somebody help me? it's 4:30 am now lol

Specs:
Lenovo Y580 UEFI
NVIDIA 660mGTX with Optimus
Intel Core i 7 3630QM
Last edited by f1ckratte; Dec 10, 2013 @ 6:01pm
Showing 1-2 of 2 comments
< >
f1ckratte Dec 10, 2013 @ 6:00pm 
Seems that I haven't installed Bumblebee correctly, the whole time it was runing on the intel Card. Missing packages were VirtualGL
ElPasso27 Jan 24 @ 12:58am 
I have exactly the same problem but with a NVidia 330M.

The whole game is red like in your screen, but primus and bumblebee are installed correctly (I use them in other programs / games).

The launch options are set to :
primusrun %command%

The load time is a little longer so I think the Nvidia Card is activated...

Has anyone a workaround for this ?
Showing 1-2 of 2 comments
< >
Per page: 15 30 50
Date Posted: Dec 8, 2013 @ 7:32pm
Posts: 2