[FL] Mavis Dracula Dec 4, 2013 @ 9:56am
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'
I get this error when trying to run Garry's Mod. Now garry's mod can be run of Windows XP, but because Arch is faster I want it on linux. The embedded videocard is supported so how can I fix or bypass this error?

My laptop: EEEPC 901 < Upgraded with 2GB Ram and 64GB HDD

Already Thanks!
~Darrell
Last edited by [FL] Mavis Dracula; Dec 4, 2013 @ 10:22am
Showing 1-9 of 9 comments
< >
^1Gentoo Dec 4, 2013 @ 11:18am 
You need to tell people what GPU your using and which drivers.
Yoyosan Dec 4, 2013 @ 11:22am 
Hello.

What GPU do you have? What drivers are you using for the GPU?

You can find the answers for these questions using:
sudo lspci -Qv

You will get blocks of detailed information of all your PCI devices.
Look for a line containing "VGA compatible controller" and paste here its contents, along with the lines following it(the whole block).

It will look similar to this:
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Device 360b
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e8000000 (64-bit, prefetchable) [size=128M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
[virtual] Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] #19
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia
Letalis Sonus Dec 4, 2013 @ 12:34pm 
Forget it, the OpenGL support of your ancient Intel GMA is WAY too low and the OpenGL requirements of the Source engine's D3D wrapper are WAY too high.
[FL] Mavis Dracula Dec 4, 2013 @ 1:58pm 
On windows it was working correctly and smooth
so there must be a way... I'll post the specs asap
Letalis Sonus Dec 5, 2013 @ 8:37am 
The Source engine uses a D3D wrapper to be able to use OpenGL on other platforms. For some reason that wrapper requires OpenGL 3. The Intel GPU used for the 901 is already quite ancient, you don't even have OpenGL 2 support available, only OpenGL 1.4.

No, there is absolutely no way to get it running, you can only use Wine instead.
[FL] Mavis Dracula Dec 5, 2013 @ 8:41am 
Okay, I will use one then. Thanks anyway!
~RootedCore~ Feb 23 @ 3:18am 
01:00.0 VGA compatible controller: NVIDIA Corporation G73 [GeForce 7600 GT] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Micro-Star International Co., Ltd. Device 0630
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at dc00 [size=128]
[virtual] Expansion ROM at feae0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Kernel driver in use: nvidia



Can i run it??
Fibbles Feb 23 @ 8:51pm 
Sorry but Source games on Linux (such as Garry's Mod,) require at least OpenGL 2.1 support. The first nVidia cards to include this were the Geforce 8000 series.
Last edited by Fibbles; Feb 23 @ 8:53pm
~RootedCore~ Feb 24 @ 5:30am 
damn it :P:physgun:
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Dec 4, 2013 @ 9:56am
Posts: 9