hashworks May 3 @ 9:58am
[SOLVED] Start etherwake as a 3rd party tool
I'm currently trying to wake my windows machine from my linux box using Big Picture / Steam.

I wrote the following script:
#!/bin/bash
sudo etherwake BC:5F:F4:DC:A6:0B -i em1 -D > output;

Additionaly I told sudo to allow root etherwake without any password by anyone.

When I start the script by console as the same user steam is running, the windows machine boots and everything is fine.
Originally posted by output:
Sendto worked ! 116.

However, starting the bash script over steam as a 3rd party application results in the script creating an empty output file and not sending the magic packet.

Any idea?
Last edited by hashworks; May 3 @ 10:37am
Showing 1-1 of 1 comments
< >
hashworks May 3 @ 10:36am 
Got it, mistake in the /etc/sudoers file.

The unix console is fine with the following:
ALL ALL = /usr/sbin/etherwake

But starting the script over steam will result in sudo asking for a password.
The NOPASSWD: setting needs to be used:
ALL ALL = NOPASSWD: /usr/sbin/etherwake
Showing 1-1 of 1 comments
< >
Per page: 15 30 50