jertan May 1, 2014 @ 8:50am
[Semi-Solved] [Kubuntu 14.04] Fresh install of steam doesnt start. Errors inside.
jordan@kbu:~$ steam
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140501115014_1.dmp
/home/jordan/.local/share/Steam/steam.sh: line 755: 17623 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
mv: cannot stat ‘/home/jordan/.steam/registry.vdf’: No such file or directory
Installing bootstrap /home/jordan/.local/share/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME has been set by the user to: /home/jordan/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140501115015_1.dmp
/home/jordan/.local/share/Steam/steam.sh: line 755: 17749 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-1f52792b-c7c8-4b0c-914f-a38e02140501
Finished uploading minidump (out-of-process): success = no
error: Failure when receiving data from the peer
Last edited by jertan; May 1, 2014 @ 6:32pm
Showing 1-4 of 4 comments
< >
Jo Ma May 1, 2014 @ 9:32am 
wow from all the threads on ubuntu (and flavours) problems with steam i'm kind of going to hang on to xubuntu 12.04 64 bit for a bit longer. As for this error check this out "https://support.steampowered.com/kb_article.php?ref=3473-UFGX-4622"

i think the best would be to zip up the logs, contact support and somehow get them the logs.
jertan May 1, 2014 @ 6:33pm 
It appears its an issue with the proprietary AMD drivers. The card I am using is a 7870 Ghz. Switching to the free drivers allowed me to launch steam.
[FPD] George Zimmerman May 3, 2014 @ 8:18am 
Yeah 14.04 versions are breaking Steam, mine broke after updating to Lubuntu 14.04 as well.
[FPD] George Zimmerman May 3, 2014 @ 7:13pm 
Figured it out...and it's stupid.

Uninstall your proprietary drivers and install Steam first, after Steam is installed install your proprietary drivers.

Good luck dudes...I still have a million other things to fix, stable release my ♥♥♥.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: May 1, 2014 @ 8:50am
Posts: 4