c0b2a Apr 16 @ 5:27am
Not able to get Steam to start w/ Ubuntu 12.04
First let me say I am brand new to unix in general. I installed Ubuntu on a new laptop and am attempting to get Steam to work. I have tried installing via USC as well as downloading from Steam website. I end up with the same error. When trying to open by clicking icon nothing at all happens, no process tree or anything. When I try and run in terminal this is what I end up with.
josh@mobilejc:~$ steam
Running Steam on ubuntu 12.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
/home/josh/.local/share/Steam/steam.sh: line 755: 12356 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
mv: cannot stat `/home/josh/.steam/registry.vdf': No such file or directory
Installing bootstrap /home/josh/.local/share/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on ubuntu 12.04 64-bit
STEAM_RUNTIME has been set by the user to: /home/josh/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(0_client)
/home/josh/.local/share/Steam/steam.sh: line 755: 12477 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
josh@mobilejc:~$

If anyone could help me out with some troubleshooting this problem it would be greatly appreciated.

System details:
Ubuntu 12.04 LTS fully updated
Mem 16gb
Proc i7-4700MQ @ 2.4ghz x 8
Graph SLI geforce 755m's (newest drivers installed)
OS type 64-bit
Disk 1TB
Showing 1-4 of 4 comments
< >
c0b2a Apr 16 @ 5:43am 
GPU drivers 331.67
SamCoupe Apr 16 @ 6:03am 
I take it you're using a laptop and that steam has never worked?

Assuming all this I'm going to hazard a guess that this is related to nvidia's optimus graphics stuff, have a look here:

https://support.steampowered.com/kb_article.php?ref=6316-GJKC-7437
(NB the link right at the bottom about installing on a 64bit system!)

This is just a guess as I don't have anything with optimus myself.

You'll also want to make sure you aren't trying to use SLI as this is basically broken on Linux and a single one of your cards should be able to handle pretty much all games available on Linux anyway.
c0b2a Apr 16 @ 7:46am 
I was able to follow the directions on that page, then had to reinstall my GPU drivers. Seems like it did the trick. Steam is now updating correctly. Thank you for the help.
SamCoupe Apr 16 @ 9:29am 
GOOD JOB!

As a nix new guy you just had a bit of a baptism of fire!

Optimus makes things a lot more complicated.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Apr 16 @ 5:27am
Posts: 4