Xauth Feb 25 @ 4:05am
Cannot get Nvidia drivers to work at all. (Ubuntu 13.10 x64)
I've tried literally every how-to on google, all end up resulting in either a blank screen with no cli or even a blinking underscore, blank screen with underscore and nothing else, or just the desktop with no UI/Unity.

I've tried doing it through ppa's, using 'apt-get install nvidia-current-updates' etc, tried the Additional Drivers page but there was nothing there, as well as somehow managing to get passed Nouveau's driver and installing the official Nvidia drivers, all resulting in the same issues as stated above.

My graphics card is an Nvidia EVGA GTX 670 FTW edition and I'm attempting this on a fresh install of Ubuntu 13.10 on a dual boot with Windows 7 (on a seperate hard drive.)

Please, any help on any other ideas or ways of getting these drivers installed would be much appreciated.

Thanks!

****EDIT****
I have resolved the issue somehow by installing Ubuntu through Wubi installer and am now able to get the latest Nvidia drivers working flawlessly. There was literally 0 issues compared to when I had it installed on my seperate drive. So now I just have it dual booted this way instead and installed my steam games onto the drive I originally had ubuntu on instead. Works perfect.

Not sure why this is, perhaps maybe something with the boot order, motherboard/bios, or maybe even just an issue with dual booting the way I did. I'm completely clueless as to what caused this at all, but at least I have it working either way.

Thanks all for your help!
Last edited by Xauth; Feb 26 @ 1:07am
Showing 1-14 of 14 comments
< >
Revernus Feb 25 @ 5:55am 
Have you tryed Ubuntu forums for help?
Xauth Feb 25 @ 6:12am 
I have, haven't seemed to have any luck as barely anyone there who's responded uses Steam or the official/correct nvidia drivers needed for it. Which is why I've come here now.
Last edited by Xauth; Feb 25 @ 6:12am
^1Gentoo Feb 25 @ 6:16am 
Did you activate all the repos in Ubuntu and do every update first? Disable xorg-edgers and other repos like it.

I've recently been having the same problem and this is the one that somehow worked for me.
Xauth Feb 25 @ 6:18am 
Originally posted by ^1Gentoo:
Did you activate all the repos in Ubuntu and do every update first? Disable xorg-edgers and other repos like it.

I've recently been having the same problem and this is the one that somehow worked for me.

Yup, I've tried just about anything. Not sure if maybe it's the dual boot or something as I've got ubuntu on a different harddrive, so I just wiped the drive, going to install alongside Win 7 on my C drive and see if I get similar issues. Thanks.
^1Gentoo Feb 25 @ 6:41am 
...why would that affect the drivers to your GPU...?
Revernus Feb 25 @ 7:19am 
This is not a Steam issue, it's clearly a distro specific driver issue since you lose all your graphics. If you've already tryed all these alternatives you mentioned, I suggest you to try other distro. I recommend OpenSUSE 13.1, everything worked for me out of the box and installing proprietary drivers with YaST is very easy.
CrisFigueira Feb 25 @ 7:21am 
Please try this pressing ctrl + alt + f1 to go to the console and type the command below:
sudo apt-get remove --purge bumblebee primus nvidia-prime

After this, reboot. This command should be used after the installation of the nvidia drivers. It doesn't work if you didn't install it yet.

The problem is probably this: the new nvidia drivers recommend the prime/bumblebee packages, which set up laptops with dual GPU (intel + nvidia). Unfortunatelly, they break evertything else.
Last edited by CrisFigueira; Feb 25 @ 7:22am
POINTS: Feb 25 @ 8:08am 
Instead of xorg-edgers, try x-updates (http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu). They are a little behind xorg-edgers but usually stable.

You can also try downloading from NVIDIA's website. I usually have issues installing their drivers directly (such as the settings program not working). To use x-updates, try doing the following:

1. Open up Software & Updates (e.g. click on Dash Home, search for "updates", and click on "Software & Updates".
2. If there is a check mark next to xorg-edgers, click the box next to clear it. Enter your password if prompted.
3. Click on Add and enter this "deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu saucy main"
4. Click Close.
5. You may need to update. You can either use the Update GUI or run this from the terminal: "sudo apt-get update && sudo apt-get upgrade"
6. Reboot. Choose the "Recovery" option from grub. (Typically, you can get to this from the main menu in grub, by choosing the 2nd option in the list, e.g. "Advanced options for Ubuntu" and then selecting the 2nd option in the sub menu which should have "Recovery" in the name.)
7. At the Recovery prompt, select "Enable Networking". This will mount your drives as well as enable networking.
8. Select "Drop to a Root prompt". From there you'll want to uninstall any Nvidia drivers you currently have. Type "sudo apt-get remove --purge nvidia*".
9. After this, you should probably reboot, select recovery again, enable networking and drop to a root prompt again.
10. At the root prompt install the nvidia drivers. You can type this "sudo apt-get install nvidia-331". This should install nvidia-settings and nvidia-persistenced as well.
11. Run "nvidia-xconfig". This well setup you /etc/X11/xorg.conf file.
11. Reboot again. Try to log in to Ubuntu as usual. If you have any issues, you can check the xorg log file. Run this at a terminal: "cat /var/log/Xorg.0.log".
Last edited by POINTS:; Feb 25 @ 8:20am
Xauth Feb 25 @ 1:10pm 
Thanks for all the replies, I attempted my method, had the same result as before. I also tried POINTS's method as well and had no avail. I am not using bumblebee at all as I'm not using a laptop and am doing this on a desktop. Perhaps I'll try OpenSUSE or Arch Linux instead as I've always had 0 issues with it in the past. Problem seems to be a conflict with the Nouveau drivers and the NVIDIA ones that I install somehow, even if I backlist Nouveau entirely.

Something strange also to note here, when going into the recovery mode and going to "Resume" everything has loaded up fine and the drivers for some reason seemed to work partially (was testing with Metro: Last Light.) However when I'd boot into Ubuntu normally I'd get nothing but a black screen with no cli or ability to login, literally nothing but a black screen and my mouse cursor as a black X.
Last edited by Xauth; Feb 25 @ 1:24pm
CrisFigueira Feb 26 @ 10:59am 
Are you really sure that bumblebee is not present? It was installed automatically on my desktop when I installed the nvidia drivers and had to get rid of it using the instructions above.
Xauth Feb 26 @ 2:25pm 
Originally posted by CrisFigueira:
Are you really sure that bumblebee is not present? It was installed automatically on my desktop when I installed the nvidia drivers and had to get rid of it using the instructions above.

Bumblebee was not present, I can confirm that. Somehow having it dual booted from my C drive fixed it instead.
barrackar Mar 17 @ 9:29am 
I have nearly exactly the same setup and encountered the same problem - including the strange thing of it working upon resume from recovery mode. I also have Nvidia EVGA GTX 670, Intel i-7 3770k, Ubuntu 13.10, but I have a single Ubuntu operating system.

I can confirm that bumblebee is not present in the installed packages with ppa:xorg-edgers/ppa installing nvidia-current and nvidia-settings, as of 3/16/2014. It installs nvidia version 304 as the current and not 331.

I have further tested the nvidia driver after a resume from recovery and confirmed it fully functions in games known to crash this nouveau driver/GPU combination. I'm going to continue debugging to see if there is better fix than dual booting or resuming from recovery mode.
barrackar Mar 17 @ 1:24pm 
Tried different ppa (ppa:ubuntu-x-swat/x-updates), same result.
Tried installing Bumblebee - added new problems, made it even worse.

Tried editing /etc/default/grub to be "noquiet nosplash" - this made the black screen of the normal boot lose its cursor (even blacker) and the recovery resume to boot into low-graphics mode. I had to boot to a live USB to reinstall/repair grub.

I ended up with purge nvidia* and removing the ppa to just go back to the default nouveau. I also read on another forum that resuming from recovery causes it to bypass the GPU by rendering with the CPU. I can't verify this but that could explain why it doesn't crash on recovery resume - but that isn't a solution for performance reasons.
Xauth Mar 17 @ 2:24pm 
Originally posted by barrackar:
Tried different ppa (ppa:ubuntu-x-swat/x-updates), same result.
Tried installing Bumblebee - added new problems, made it even worse.

Tried editing /etc/default/grub to be "noquiet nosplash" - this made the black screen of the normal boot lose its cursor (even blacker) and the recovery resume to boot into low-graphics mode. I had to boot to a live USB to reinstall/repair grub.

I ended up with purge nvidia* and removing the ppa to just go back to the default nouveau. I also read on another forum that resuming from recovery causes it to bypass the GPU by rendering with the CPU. I can't verify this but that could explain why it doesn't crash on recovery resume - but that isn't a solution for performance reasons.

It usually seems to be a conflict issue with the Nouveau drivers installed by default in the latest debian versions.
As to why this is even an issue is beyond me. I gave up on it for now and decided to go with Arch linux and do everything from scratch. So far no issues whatsoever. May be a hardware issue, perhaps chipset issue, or maybe just an OS issue with the install path. I couldn't figure it out, was pretty much beyond me so I gave up with Ubuntu for now sadly.
When I study/learn more on Linux I'll come back to it and see if there's a resolution, for now I'll just stick with my Win7 and Arch dual boot. Best of luck to those having this same issue I had.
Last edited by Xauth; Mar 17 @ 2:24pm
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Feb 25 @ 4:05am
Posts: 14