[PLEX RP] Chizbang Feb 24 @ 9:39am
Steam and lib.so
I have the latest Crunchbang installed and have apt-get install steam which installs fine but then complains about not having lib.so 32 bit or something so I install the 32 bit compatibility libraries in the nvidia installer or whatever its called and that installed fine. I still get no luck wiht it, still spits out the same error each time. I tried installing steam-debian and it just returns: Segmentation Fault. Halp!
Showing 1-15 of 24 comments
< >
Yoyosan Feb 24 @ 9:47am 
We can't help you if you don't mention your hardware, Linux distro, drivers version installed.
Zyro Feb 24 @ 9:48am 
And there is no lib.so, it's name should be something else (and it really matters).
[PLEX RP] Chizbang Feb 24 @ 10:07am 
My bad, typo. its libGL.so.1

Specs:
GTX 570 1.3GB from PNY (304.108)

12GB of DDR3 ram
i7 2600k Sandy Bridge
Crunchbang Waldorf
MadXav Feb 24 @ 10:53am 
I'm pretty sure you are still missing 32 bit libraries on your OS. Maybe you didn't installed the right ones. That's common mistake.
Last edited by MadXav; Feb 24 @ 10:55am
Apocryphus Feb 24 @ 10:54am 
Have you tried a soft link with libGL.so?
[PLEX RP] Chizbang Feb 24 @ 11:05am 
I think so, what does that involve?
Apocryphus Feb 24 @ 11:29am 
Originally posted by PLEX RP Chizbang:
I think so, what does that involve?

Locate the original libGL.so with
locate libGL.so
or
find / -iname libGL.so

And then use the path to the appropriate libGL.so file with libGL.so.1 with:

ln -sf libGL.so libGL.so.1

If you're experiencing the same issues still, then we'll need more info as to your drivers, so:

dpkg -l | grep NVIDIA

Update: I just checked the thread over once more and since it's possible you're missing 32-bit libraries, try this as well:

dpkg --add-architecture i386
sudo apt-get update && sudo apt-get upgrade

The foresaid commands should only be used if the last commands fail to resolve your issue.
Last edited by Apocryphus; Feb 24 @ 11:33am
[PLEX RP] Chizbang Feb 24 @ 12:28pm 
Tried ii libnvidia-ml1:amd64 319.82-1 amd64 NVIDIA Management Library (NVML) runtime library

All the commands entered above I have done (appart from sudo apt-get upgrade which im doing right now, didnt think itd be needed), il keep you posted. Thanks a lot
[PLEX RP] Chizbang Feb 24 @ 1:08pm 
Sadly that didnt do anything either
Kranky K. Krackpot Sr. Feb 24 @ 1:25pm 
Did you find any libGL.so.1 in your system? Say, in /usr/lib32?
Run Steam in terminal, copy its output, paste it on pastebin.com and give here link to it.
[PLEX RP] Chizbang Feb 24 @ 4:43pm 
Will do, Im away from the machine at the moment but il post soon.
[PLEX RP] Chizbang Feb 25 @ 1:37pm 
Oh and yeah, I did find libngGL.so just fine, have it where it is expected.
Apocryphus Feb 25 @ 2:04pm 
Originally posted by PLEX RP Chizbang:
Oh and yeah, I did find libngGL.so just fine, have it where it is expected.

Have you output the commands I listed? Pastebin them.
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Feb 24 @ 9:39am
Posts: 24