[RS] The Letter M Feb 24 @ 1:58am
Steam Games and my Screensaver
So when I play a game with the gamepad, after a while the screen starts to fade and then lock unless I move the mouse around. Obviously the power management doesn't acknowledge the gamepad and proper input to keep the screen awake.

I was using Unity and XFCE in Ubuntu 64bit for a long time. I recently switched to OpenSuse 13.1 64bit with Gnome and it still happens. I know Windows has a way that it will recognize fullscreen applications and not engage the screensaver but Linux doesn't have anything like that in the Kernel yet.

I was wondering what work around others have used in Linux for this issue?

(I added this to the GitHub Bug Report since perhaps Valve may be able to add something to the Steam Client itself to fix this)
Last edited by [RS] The Letter M; Feb 24 @ 2:13am
Showing 1-3 of 3 comments
< >
Zyro Feb 24 @ 2:43am 
I've got another problem: My screensaver seems to be disabled. Is it possible that an early version of Steam for Linux (beta?) did so? If they changed that behaviour later, they probably had some other solution to it?
MedicByCall Feb 24 @ 5:52am 
XFCE4 is using 'xscreensaver'
Gnome might use 'gnome-scrensaver'

Man-Page of 'gnome-scrensaver' refers to:


How about to uninstall your gnome-screensaver?
  • I am not using the screensaver of gnome. After reading this article I would give you the advice to uninstall this electronic waste and to use (x)-screensaver:

@Zyro

You can enable your screensaver in your 'power settings' and/or in you 'screensaver settings'.

My steam client leaves screensaver untouched.
Last edited by MedicByCall; Feb 24 @ 6:04am
MadXav Feb 24 @ 6:46am 
I had the same problem on ElementaryOS. Had to disable the screensaver. It was really annoying.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Feb 24 @ 1:58am
Posts: 3