Steam for Linux

Steam for Linux

narcowski Feb 14, 2014 @ 10:47am
Linux Steam client still does not recognize east asian language input from ibus
Issue raised on github over a year ago, still exists. This is extremely annoying.
< >
Showing 1-8 of 8 comments
Dusk of Oolacile Feb 15, 2014 @ 3:18am 
You mean you can't type Asian characters into Steam chat and stuff like that?
narcowski Feb 15, 2014 @ 3:34am 
Yes. I use ibus (more specifically, ibus-mozc) for Japanese character input and it works beautifully with everything except Steam and Steam games. When I toggle the IME on Steam, it just continues to take direct keyboard input instead.
Last edited by narcowski; Feb 15, 2014 @ 3:47am
Sensei Aizen Feb 15, 2014 @ 6:21pm 
Sounds exotic. If I were you I would also try to create a support account.
An answer directly from valve support sounds helpful.

Which WindowManager and desktop enviroment are you using?

How about to set another 'default font' in settings like 'Appearance'
I can open and set default font in xfce with this command:

> xfce4-appearance-settings

You need equivalent command for gnome, unity or what ever you are using.
Maybe steam client can not handle to display Japanese characters with default system font.

Having no idea what the meaning of this chars are. I can see them.
However I set my steam client (debian 7 amd64bit) to Japanese Langauge:



Which font are you using?
Last edited by Sensei Aizen; Feb 15, 2014 @ 6:28pm
narcowski Feb 15, 2014 @ 6:44pm 
I'm using gnome-shell on ArchLinux on my desktop and i3wm on ArchLinux on my laptop. Both are configured with ibus-mozc, which works perfectly fine in both gtk+ and qt4-based applications other than Steam.

My default fonts on both machines are IPAGothic and IPAMincho (non-serif/serif). I do use Adobe Source Code Pro as my monospaced font, but Steam isn't monospaced so that shouldn't matter.

I can see asian characters, so I can read what you wrote, and I can copy-paste them into Steam. However, steam does not accept ibus input, so I cannot type them into Steam directly. Instead, I have to open gedit or some other program, type my message, and copy-paste it.

4月7日(月 << proof that I can copy-paste.
ison Feb 15, 2014 @ 10:35pm 
I can confirm this is still an issue. I also checked out the bug report when it was first made and have been patiently waiting for a fix.

Just as the OP said, steam renders the fonts just fine, so copy-pasting the characters is not a problem. But we can't type them directly into steam.

I'm using UIM and Anthy system wide to type japanese characters and the only place it doesn't work is steam.
Interestingly (and I think this was mentioned in the bug report too) if I run steam in WINE then it accepts japanese input flawlessly. Not sure why the native steam client can't do it.
Sensei Aizen Feb 16, 2014 @ 6:48am 
You might read this:

I would make backup files by manipulating them.

It seems to be that ibus-daemon does not recognize Steam as an input window.
Therefore it could be less a problem of steam.

I can not believe that Valve is not caring about the great quantity of such users.

To understand the concept of ibus I would read this:
(scroll down to title ' A tale of IBus, GIR and queries' )

How about to disable ibus at start up and starting it manually to analyze it:

# Seperately save outputs in log files:
> ibus-daemon 1> std_out.log 2> std_err.log

# or Saving both outputs in one:
> ibus-daemo > std_out_and_sdt_err.log 2>&1

### Keep in mind by last command:
# ----------------------------------------------
# The redirecting is happening from left to right:
# at first: stdout is written to log-file (here: "> std_out_and_sdt_err.log" )
# and then stderr written to stdout by appending (here: "sdt_err.log 2>&1"
# or in words: the error_output_stream with ID 2 is also redirected to
# the default output_stream with ID 1)

### Input/Output-Streams in Unix/Linux are defined (handeled) by this way:
# -------------------------
# 0 - stdin - Standard input
# 1 - stdout - Standard output
# 2 - stderr - Standard error
Last edited by Sensei Aizen; Feb 16, 2014 @ 7:11am
ison Feb 18, 2014 @ 10:09am 
I would do what you recommended above, but with my uim-anthy setup. However, I cannot figure out how to get errors reported from uim/scim/anthy.

I've been trying to find a way to restart uim or if a uim-daemon even exists but I'm getting nothing.
I'm starting to think that uim-anthy is just a set of libraries that are called by programs individually and that there is no daemon or a way to restart it.

In which case the problem would be that steam just isn't calling those libraries?

I'm wondering if running steam with STEAM_RUNTIME=0 might do something, but I'm not able to test it. Turning off the runtime used to work for me in early steam linux beta, but I think I'd have to do a lot of changes to my system to get it working now.
Last edited by ison; Feb 18, 2014 @ 10:13am
ison Jun 28, 2014 @ 9:31pm 
I've upgraded to iBus a few months ago, so I figured it might be time for me to give this a try again.

I did your suggestion to send output to the 2 files but no matter what I do they remain empty, so it doesn't look like there is an error.

However, I did get something to happen at least. In CS:S if I press my hotkeys to toggle the japanese IME on (whether it was on already or not when the game started) then I can no longer type in the chat window, it comes up but just stays blank. However all other game inputs still works, so I can press esc to close chat window, but if I open it again the input is still blank. Even pressing the hotkeys again does not fix it. It remains impossible to type in the chatbox until I alt+tab out of the game and back in.

So at least something is happening in the game. Although in the steam client itself it seems to be entirely unresponsive to iBus in every way.

Perhaps this just means iBus is capturing the input but doesn't know how to send it to the steam chat window.
Last edited by ison; Jun 28, 2014 @ 10:28pm
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Feb 14, 2014 @ 10:47am
Posts: 8