Steam for Linux > 一般討論 > 主題細節
iKursed 02 月 9 @ 1:27下午
Notification Issues
My problem is that once I attempt to play games through steam, they usually work fine until, they lag up and become unplayable, once I receive a notification. Such as a notification of a friend coming online or that I received an item.
最後修改者:iKursed; 02 月 9 @ 1:28下午
顯示 1-8,共 8 則回應
< >
-FwG- ^ Bucky21659 02 月 9 @ 1:49下午 
AMD?

If so it's an old bug.
iKursed 02 月 10 @ 1:31下午 
What do u mean by amd?
If you are referring to graphics card, I have: Geforce 8800 GTS
Kranky K. Krackpot 02 月 10 @ 1:40下午 
iKursed 發表:
What do u mean by amd?
If you are referring to graphics card, I have: Geforce 8800 GTS
AMD/ATI GPU, so you don't have it.
Did you try to disable "Enable Steam community in-game" in Steam's settings? It should disable these notifications in games completely.
Don't know why it happens, it might be GPU or a problem in libnotify/
iKursed 02 月 10 @ 1:43下午 
I did try that, but from what I last checked i still receive the "you have received an item" notification, and due to this notification just like any other scenario my game proceeds to lagging out and becoming unplayable.
Another question besides this one is that sometimes, when attemtping to start up a game it would say "failed to launch opengl" or something along those lines, however other times it works perfectly fine.
Kranky K. Krackpot 02 月 10 @ 1:57下午 
iKursed 發表:
I did try that, but from what I last checked i still receive the "you have received an item" notification, and due to this notification just like any other scenario my game proceeds to lagging out and becoming unplayable.
Another question besides this one is that sometimes, when attemtping to start up a game it would say "failed to launch opengl" or something along those lines, however other times it works perfectly fine.
Weapons, card, achievements, etc. nofitications can't be disabled, as far as I could understand. At least, in TF2 I still receive them, and with no problems so far.
It now looks more like it's a problem with video-driver, though I can't tell what exactly is wrong and how to fix it.
What is your distro? Run Steam in terminal, and when the bug happens, copy-paste terminal output on pastebin.com and give here link to it. Contents of /var/log/Xorg.0.log will be good too.
And "failed to launch opengl" looks very suspicious.
iKursed 02 月 11 @ 2:14下午 
How exactly would I run steam in terminal ?
Kranky K. Krackpot 02 月 11 @ 11:15下午 
iKursed 發表:
How exactly would I run steam in terminal ?
Start a terminal emulator program (like Terminal, must be somewhere under System or Accessories, etc), then in its command line type "steam" and Enter.
Letalis Sonus 02 月 12 @ 10:45上午 
Steam dumps its whole output to /tmp/dumps/, starting it in a terminal shouldn't be necessary anymore.
顯示 1-8,共 8 則回應
< >
每頁: 15 30 50