iKursed Feb 6 @ 1:31pm
Steam unusable
So I have two problems:
1. My first problem is that once I attempt to play games through steam, they usually work fine until, they lag up and become unplayable, once I receive a notification. Such as a notification of a friend coming online or that I received an item. other examples would be when running skype, and playing a steam game, if I receive a notification on skype it, pretty much as stated before makes the game unplayable and it begins to lag out, I usually have to proceed to turn off the game, which becomes even bigger of a problem..
2. So after using steam for quite some time everything was fine, and before switching to linux I remembered I had Terraria installed, and wanting to play this game I installed "Playonlinux" because original Terraria is unplayable on steam alone. Therefore using playonlinux I installed terraria, and attempted to play it, but the end result was that single player worked, but when attempting to join my friends server I was unable to, therefore I gave up on all efforts of playonlinux. Playonlinux installed steam as well as terraria, and was running steam separately, this is where my second problem appears. My second problem is that after uninstalling playonlinux, and returning to using original Steam, steam completely did not work, what i mean by this is once I opened steam, it would long in and everything would work normally, however once I got into the menu interface I became completely unable to do anything, I would attempt to click anything, but nothing would work. I attempted uninstall and reinstall, but the problem still existed. I believe the solution is to appropriately uninstall it considering that i might be uninstalling steam incorrectly.
Showing 1-8 of 8 comments
< >
Oerthling Feb 6 @ 2:04pm 
ad 1: You have an AND/ATI card?

ad 2: Your problem acessing your friends server could possibly a problem with your or your friends firewall (i.e. a port needs unblocking).

In your description of point 2 it's not quite clear when you talk about the Linux version or the Windows version.
I'm assuming that you were talking about Steam for Linux at first.
PlayOnLinux will have install the Windows version of Steam (completely independant from the Linux version). After removing PlayOnLinux it's clear why your Windows Steam might no longer work.

Do you then talk about the Linux Steam when you say "original Steam" ?
iKursed Feb 6 @ 2:13pm 
With problem #2 I've fixed it by properly uninstalling and reinstalling steam.

- The steam run through "Playonlinux" runs Windows client of steam

- The "orignal steam" refers to the Linux based client of steam.
Last edited by iKursed; Feb 6 @ 2:27pm
LOLCAT Feb 6 @ 2:19pm 
#1 is probably an audio issue. There was a thread recently about how crappy sound under linux is and how it cannot deal with more than one programs trying to handle audio at the same time.

I wonder what distro you have and what handles sound on it. If you don't have pulse, that may be the reason as both steam and skype are optimized for pulse. Also most recent games I guess.
iKursed Feb 6 @ 2:25pm 
Considering problem #1 everything was working fine, like single player and what not, but once I tried to join my friend's server, which my other friends were easily capable of joining, It would just show up "requesting tile data", and I ran a debug using playonlinux and these two errors kept appearing :

ALSA lib pcm.c:7843:dsnd_pcm_recover) underrun occurred

then after a certain point this error started repeating itself:

fixme:thread:NtQueryInformationThread info class 16 not supported yet

AND one more thing now that I've completely reinstalled steam I have this other problem, when I click away from steam, such as to my browser, and once I click back my steam screen it's completely black and have to wait a couple of minutes before the actual interface reappears.
Letalis Sonus Feb 6 @ 3:00pm 
Originally posted by LOLCAT:
#1 is probably an audio issue. There was a thread recently about how crappy sound under linux is and how it cannot deal with more than one programs trying to handle audio at the same time.
That is pretty much limited to ALSA's old OSS emulation layer. However, ALSA defines a software mixer by default and pretty much every single Linux game on Steam already supports native ALSA, not to mention that most systems are using PulseAudio anyway, which is always software-mixing everything trying to use it either directly or via its default ALSA redirection.

It has nothing to do with the software, BTW. Even without software mixing ALSA is perfectly able to handle more than one audio stream - however, that requires certain hardware mixing capabilities that only very few audio chip support.

Originally posted by iKursed:
ALSA lib pcm.c:7843:dsnd_pcm_recover) underrun occurred
That may occur with a lot of sound cards whose driver is not yet perfectly working. However, it doesn't even need to have any consequences, you most likely won't even hear anything suspicious. It's more of a harmless warning message, nothing that could cause mayor issues by itself.

Terraria is a .NET program, you don't even need Wine to run it (except maybe for its Steam integration), Mono should already be able to do so. The only problem is the XNA framework it is relying upon (and that's exactly why it runs so terribly in Wine as well AFAIR), you need some replacement Mono framework for that. Apparently MonoGame got quite far by now, there are already several .NET games on Steam that use it to offer an official Linux client. However, I have no idea if it runs with Terraria just as well.
iKursed Feb 6 @ 7:52pm 
So sonus, I understand what you are getting at, but it a more basics sense what do you reccommend for me to be able to terraria. Should I install the windows client of steam and attempt to run it through there, or update my .net or something along those lines? or are you recommending I run terraria a different way? If so I only have a basic understanding of steam, so if you can please walk me through what exactly you recommend I do.
iKursed Feb 6 @ 7:57pm 
Besides Terraria, Is anyone aware of how I can solve the issue of whenever receiving a notification, the game completely lagging out and being completely unplayable and me having to resort to turn off the game. Anyone know of a way of solving that issue, so I can just keep playing the game, what ever it happens to be at the time, and yet still receive awareness of the notification?
Last edited by iKursed; Feb 6 @ 7:57pm
Letalis Sonus Feb 7 @ 5:01am 
Don't know, I don't own the game myself.

Have you already checked AppDB for Terraria? There's apparently some workaround for the multiplayer issue by making it connect locally through port forwarding.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 6 @ 1:31pm
Posts: 8