Walnut Jun 25 @ 4:16pm
Why is it CJK is still broken?
Kind of ridiculous

Chinese/Japanese fonts still render garbled no matter what you do really on the Linux client only. (Big Picture Mode works fine) You'd think Valve would've fixed this by now

It's kind of sad when running the client in WINE makes it almost more stable than the native client (Almost.)
Showing 1-15 of 15 comments
< >
LOLCAT Jun 26 @ 10:02am 
Using localized software is always a bad idea, no matter what language it is. I can only suggest that you open an issue about it on github or if one exists, make sure it stays alive.
Kranky K. Krackpot Sr. Jun 26 @ 11:56am 
Do you have a unicode font installed?
Arial Uni MS is the easiest technically, but you have to buy it from Microsoft or somewhere. Maybe unifont package will do too.
Walnut Jun 26 @ 4:29pm 
I do - system is set to en_us UTF-8 and I have a variety of fonts installed (Including all of the Windows 8.1 fonts ripped from my dual boot)

It's been the same problem over time on multiple computers; just doesn't work well. It's aggravating
Kranky K. Krackpot Sr. Jun 28 @ 9:51am 
Originally posted by Walnut:
I do - system is set to en_us UTF-8 and I have a variety of fonts installed (Including all of the Windows 8.1 fonts ripped from my dual boot)
Ok, do you have Arial Unicode MS installed?
Not sure what exactly "garbled" you mean, but I tried to change interface language to Trad Chinese and Korean, and didn't notice anything strange.
http://imgur.com/RapxDxX
http://imgur.com/JLX9pqe
However, I don't know neither Chinese nor Korean...
spl Jun 28 @ 10:18pm 
They did fix it at one point.

However, it's also "garbled" -> http://s12.postimg.org/cry7qziul/273.png
for me as well right now.

Although I can't say if that's due to another update from valve breaking it again on their end, or me doing something. Because I've been messing around with my fonts a lot trying to solve various other issues in steam games.

Originally posted by Kranky K. Krackpot IIX:
Arial Uni MS is the easiest technically
So I'm guessing you used Arial Uni MS in the screenshots?
Walnut Jun 28 @ 11:16pm 
No idea if I have Arial Unicode MS installed or not on my system, I'd have to boot into Linux and get back to you on that. (I'd imagine I probably do though? I for sure have the Microsoft font suite installed) Just wanted to say that your output looks perfect and mine looks more like what mearo is getting (That's what I mean by garbled text)
Kranky K. Krackpot Sr. Jun 29 @ 12:31am 
Originally posted by mearo (´・ω・`):
Originally posted by Kranky K. Krackpot IIX:
Arial Uni MS is the easiest technically
So I'm guessing you used Arial Uni MS in the screenshots?
Good question... Nope, it seems I don't have arialuni, unless i've put it in some very unusual place. I really don't remember, I messed with fonts, fontconfig and infinality long before Steam, and now it just works for me. I have somehow similar issue on my another PC, with fresh installed Debian -- some letters go "blind", adding fonts doesn't help much, it looks more like graphics issue in old Intel driver, and I still couldn't fix it...

Anyway, installing Arial Uni is worth trying. Another options can be disabling bitmap fonts in fontconfig, or setting locale to en_US. Gentoo and Arch wikis also have suggestions about Steam's fonts.
Steam makes heavy usage of the Arial font. A decent Arial font to use is ttf-liberation or the fonts provided by Steam. Asian languages require wqy-zenhei to display properly.
https://wiki.archlinux.org/index.php/steam
http://wiki.gentoo.org/wiki/Steam#Fonts
spl Jun 29 @ 2:28am 
Originally posted by Kranky K. Krackpot IIX:
Another options can be disabling bitmap fonts in fontconfig, or setting locale to en_US. Gentoo and Arch wikis also have suggestions about Steam's fonts.

I tried disabling bitmap fonts after my last post, still no luck.
Also, I have the wqy-zenhei and liberation fonts and have been using the en_US.UTF-8 locale already
Last edited by spl; Jun 29 @ 2:31am
Walnut Jul 3 @ 7:46pm 
I *do not* have Arial Uni MS btw, just Arial as described here:
http://www.microsoft.com/typography/fonts/font.aspx?FMID=1909

I wonder if that's been my problem this entire time. It's worth investigating for sure!
spl Jul 9 @ 10:51pm 
Well I just installed Arial Unicode MS and it didn't change anything.
Walnut Jul 12 @ 4:41pm 
I fixed this problem by the way by removing ttf-ms-win8 and related fonts (Took more than just the Japanese one to fix it so idk)

Everything is rendering correctly even if it's kinda ugly :\ That's the trade-off I suppose
spl Jul 12 @ 7:13pm 
glad you got it working.

I looked up that package and checked every font in it against the fonts on my system.
Removing "meiryo", corefonts, and baekmuk-fonts should have removed all of the fonts from my system that you removed, but the issue still exists for me.
Walnut Jul 12 @ 7:28pm 
No idea - moral of the story though is there's probably some conflicting font that the Linux client doesn't work so if you get some free time you may experiment with pulling some fonts (and keeping track of what you remove so you can reinstall some)

Just make sure you restart steam afterwards so it "flushes the cache" so to speak
spl Jul 12 @ 8:33pm 
Originally posted by Walnut:
No idea - moral of the story though is there's probably some conflicting font that the Linux client doesn't work so if you get some free time you may experiment with pulling some fonts (and keeping track of what you remove so you can reinstall some)

Just make sure you restart steam afterwards so it "flushes the cache" so to speak

I just found the problem font, for me it was ipamonafont
which is a shame since it's my favorite font to use for everything.

I wonder if it doesn't work because it has embedded bitmaps fonts for sizes 10-16, which might explain why the screenshot I posted earlier only showed scrambled words for the small text while the larger words were able to render because it would use the truetype font for those

Shouldn't disabling bitmaps in my fontconfig have resolved this though?
[31] 70-no-bitmaps.conf *
[32] 70-yes-bitmaps.conf
I guess that doesn't effect embedded bitmaps

In this case it would be a bug with steam not being able to render bitmap CJK fonts
Last edited by spl; Jul 12 @ 8:39pm
spl Jul 17 @ 11:43am 
I just noticed something

Using wqy-zenhei will cause the interface to become garbled as in the screenshot because it has embedded bitmap fonts.
I even have Arial Unicode installed but steam prefers wqy-zenhei over any other font for CJK

removing wqy-zenhei will fix the interface font but will cause CJK text in source engine games to disappear.

So it seems I'm not able to get CJK to display correctly on the steam interface and within source games at the same time.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Jun 25 @ 4:16pm
Posts: 15