Steam for Linux

Steam for Linux

Kai Aug 11, 2014 @ 5:54am
problems with when using apt-get update (Ubuntu)
It seems that there are problems with updating steam on my computer: Whenever I run
sudo apt-get update
it hangs a few minutes at
97% [Waiting for headers]
then apt prints
Ign precise/steam Translation-en_US
98% [Waiting for headers]
and then
Ign precise/steam Translation-en
and finally I get the following statistics:
Fetched 548 B in 5min 30s (1 B/s)
Reading package lists... Done

Something takes too long here!
I am sure that it is not a problem with my internet connection - tells me that my download speed is 10.97Mb/s and my upload speed is 760Kb/s.

/etc/apt/sources.list.d/steam.list contains the following:
deb [arch=amd64,i386] precise steam
deb-src [arch=amd64,i386] precise steam

/etc/apt/sources.list.d/ contains the following:
deb [arch=amd64,i386] precise steam
# deb-src [arch=amd64,i386] precise steam

For now I disabled the steam repository in "Software and Updates" -> "Other Software", but this is just a temporary workaround and definitely not a fix.

My operating system is Ubuntu 14.04

What could cause this problem? Is there a better workaround or a proper way of solving this problem?
Last edited by Kai; Aug 11, 2014 @ 5:58am
< >
Showing 1-9 of 9 comments
jeromykeloway Aug 24, 2014 @ 5:34am 
Same problem here, I think there is a problem with the steam repository

Also deactivated the steam repository for the moment.
TLabs-Peti Aug 25, 2014 @ 7:19am 
Same problem.
Same version of Ubuntu (14.04)
Internet connection: is also fast 30Mb/s
Sargas Aug 25, 2014 @ 9:24am 
This is for Ubuntu 14.04 LTS
For now you can update steam using the application itself. And if you want to use "apt-get update" for other things, use this work-around: just open up the Ubuntu Software Center then go to

Edit > Software Sources... > Other Software

and uncheck the steampowered repositories.

Run sudo apt-get update and re-check the boxes.
Last edited by Sargas; Aug 25, 2014 @ 9:25am
instabilis Aug 25, 2014 @ 10:10am 
Why are you using the steampowered Ubuntu 12.04 repo?

Download it from here
Last edited by instabilis; Aug 25, 2014 @ 10:11am
Sargas Aug 25, 2014 @ 4:08pm 
The link provided by instabilis uses the correct repository for Steam. Installing Steam from the website gives you the 12.04 repository.

Uninstalling Steam and downloading it from the link above (or from the Ubuntu Software Center), solved the problem.

From Ubuntu Software Center, download the "Steam (steam-launcher)" one.
ftn.kneipe Aug 26, 2014 @ 8:01am 
Thanks for the info. Was wondering why I could not use Steam from the 12.04 repo after updating to 14.04.

The Steam site should mention that Steam is now a standard Ubuntu package.

Originally posted by instabilis:
Why are you using the steampowered Ubuntu 12.04 repo?

Download it from here
Kellzap Aug 28, 2014 @ 6:30pm 
I have the same problem. It takes about 5 minutes to finish.
ftn.kneipe Aug 30, 2014 @ 5:51pm 
Originally posted by gbf:
Why ? steam is a package in debian and archlinux repositories too, and many others distros. The Steam site should mention that ?

The Steam site should mention it at least for Ubuntu, because the Steam package mentioned on does not work with the current Long Term Support Version of Ubuntu 14.04
maxXx Apr 27 @ 2:22am 
Same problem.
elementary OS
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Aug 11, 2014 @ 5:54am
Posts: 12