Steam for Linux

Steam for Linux

da.schizzle Aug 22, 2014 @ 6:43am
Steam (chroot ubuntu) - Controller Issues
Hey,
im trying to get Steam working in a chroot (ubuntu 14.04, x86) enviroment.
The System is running OpenELEC and i have used a chroot ubuntu to get many linux game working on this.
OpenELEC is a small readonly linux media system. Its very fast and works even on slower hardware. xbmc is used as GUI.

I sucessfully created a chroot ubuntu system to get most of my commercial drmfree linux games working. Audio, Gamepad input (xboxdrv), and GL Graphics work great. (Tested Games: Braid, Bit.Trip.Runner, CaveStory, Limbo, Shank).

Now i wanted to get steam (big picture mode) working for inhome Streaming and the Couch Webbrowser.

I have to admit that im running steam as root user, because there are normally no other users available on this linux system and because its only used for games and media playback i dont see a problem with this.

Well long story short, i successfully installed steam and tried streaming as well but for some reason steam wont find my 360 wireless controllers (xboxdrv).
I read the other post about controller issues related to /dev/input/event* permission but this cant be the problem because im running steam as root user i guess.
All other linux games with gamepad support work fine and i also tried the access to the right input event (event14) with evtest. no errors.

Any idea why its not working with steam when any other game or application works fine?
< >
Showing 1-2 of 2 comments
Did you bind mount /dev inside your chroot?
da.schizzle Aug 23, 2014 @ 5:53am 
Of course :)
like i said all standalone games and programs work fine and can access the hardware....

mount -o bind /dev /storage/data/ubuntu-x32/dev
mount -o bind /sys /storage/data/ubuntu-x32/sys
mount -t proc proc-chroot /storage/data/ubuntu-x32/proc/
mount -t devpts devpts-chroot /storage/data/ubuntu-x32/dev/pts
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Aug 22, 2014 @ 6:43am
Posts: 2