Downlord Apr 21, 2013 @ 12:37pm
I want my money back
Seriously. If I were the guy that gave the OK to release this game, I'd be deeply ashamed for what I have done and quit my job right now.
Showing 1-15 of 18 comments
< >
Fratzengulasch Apr 25, 2013 @ 8:46am 
That´s the same i think.
I am annoyed that i bought this game.
Either stopping the Multiplayer Game with synchronisation errors or everything runs in slowmotion.
I was happy when i heard that my fovorite game was revived ... but now i am very disappointed about this failed try.

BigBeefy Apr 25, 2013 @ 9:11am 
With all the money they made so far, they should be able to afford a 24/7 supply of coffee to keep them up all night, round the clock to fix this issue. It's April 25th, the new "patch" updated the game this week, and not only has the multiplayer issue not been fixed, but it may be worse. Its still unplayable. The last update was a bunch of crap. We need a date when they think they will fix the game to the point that it has some kind of value for our money other than worthless. If its next month, say it, if its in the next 2 years, say it. Other than that I can only assume it is in fact a scam, especially after the faux patch, and we should get our money back.
benoit.delort May 15, 2013 @ 1:52pm 
in order to put it in a nutchell.... nobody has a solution guys ????
Garmonbozia81 May 15, 2013 @ 1:53pm 
Originally posted by benoit.delort:
in order to put it in a nutchell.... nobody has a solution guys ????
What solution are you looking for? Can you please clarify?
boostdeuce May 15, 2013 @ 4:17pm 
Yup i wanted my money back but i guess i'm out 17 dollars and certainly never going to be wanting to purchase a game from this developer.

How long has it been out? i've spent more time launching the game just to test it than i have actually playing the game. This is just terrible.
Jeff May 16, 2013 @ 2:38am 
I have never whined about devs before. Yet I'm thinking about getting a refund too at this point which I doubt is still possible so long after the launch.
I've been dreaming about a re-release for many years. Had fond memories of this game that I've put at least 500 hours in. But it's just not working. I've started it 20+ times over the last month and a half!!! But it's still laggy as hell. And I'm talking about Single Player at this point. Only did one MP match but that was just as bad. So only tried to do SP since then. Already put up my specs in topics twice so wont look em up again. Since I doubt it'll help. I run brand hardware of ASUS and Nvidia which I can run modern games on without trouble. Skyrim on Ultra? No problem!
Everything is up to date. So I'm guessing at this point that it's a Windows 8 Pro 64bit issue. This left me with a bitter taste. Since I was really excited for this game. And was among the first to respond to the reveal post and got other people excited on Facebook.
Bizeps May 16, 2013 @ 7:34am 
Originally posted by ᕠᕟᕠ PSITrancer ᕠᕟᕠ:
That´s the same i think.
I am annoyed that i bought this game.
Either stopping the Multiplayer Game with synchronisation errors or everything runs in slowmotion.
I was happy when i heard that my fovorite game was revived ... but now i am very disappointed about this failed try.

slowmo on high population games is soooo annoying even on a dual 7970 and newest intel hexa core pc :O
boostdeuce May 16, 2013 @ 3:57pm 
So no updates from the developers in how long? They took our money and ran. Moved on to other projects now
to@st May 18, 2013 @ 3:57pm 
Yeah, I feel completely ripped off. The entire reason I got the "HD" version was so that I could play lag-free with my friends. Instead all I get is 300 ping games on my 24mbps connection and i5-2500K. They literally just added the old high-res patch and charged $17 for it. Just fix the damn thing soon or I want my money back.
Saikotik Gunman May 19, 2013 @ 9:00am 
At least you guys can almost kind of play. I'm still in the XP x64 crowd where the game won't even launch due to it not detecting or having an error with DirectDraw...
Garmonbozia81 May 19, 2013 @ 12:36pm 
Originally posted by Saikotik Gunman:
At least you guys can almost kind of play. I'm still in the XP x64 crowd where the game won't even launch due to it not detecting or having an error with DirectDraw...
XP users are generally experiencing issues if they do not have SP3 installed. The graphics error usually comes from a graphics card that is not DirectX 9.0c capable, shader model 3 not being supported, or not having the most recent graphics driver installed (See this thread: http://steamcommunity.com/app/221380/discussions/2/828939163857602483/ ).
Saikotik Gunman May 20, 2013 @ 6:39am 
Originally posted by Garmonbozia81:
Originally posted by Saikotik Gunman:
At least you guys can almost kind of play. I'm still in the XP x64 crowd where the game won't even launch due to it not detecting or having an error with DirectDraw...
XP users are generally experiencing issues if they do not have SP3 installed. The graphics error usually comes from a graphics card that is not DirectX 9.0c capable, shader model 3 not being supported, or not having the most recent graphics driver installed (See this thread: http://steamcommunity.com/app/221380/discussions/2/828939163857602483/ ).

As I've stated in another thread on this issue, I'm fully up todate on all my shots... SP2 is the latest Service Pack for 64 bit XP, there is no SP3. I went through and did every hotfix, including small security ones to make sure, and I manually removed and replaced all my DirectX 9.0c files. My graphics card, a Radeon HD 4800 supports Shader Model 4.1, and I'm assuming backwards compatibility as the rule. I've also tried both rolling back to the old video drivers from my driver disc, and am currently running the most recent Catalyst drivers from ATI.

If you've got any other suggestions, I'm more than willing to try them, but I think I've covered all the usual bases pretty well.
boostdeuce May 20, 2013 @ 4:54pm 
hellooooo developers? are we going to do anything here soon or does it satisfy you to know how disappointed so many people are with this game?
Semple May 21, 2013 @ 7:51pm 
Originally posted by Saikotik Gunman:
Originally posted by Garmonbozia81:
XP users are generally experiencing issues if they do not have SP3 installed. The graphics error usually comes from a graphics card that is not DirectX 9.0c capable, shader model 3 not being supported, or not having the most recent graphics driver installed (See this thread: http://steamcommunity.com/app/221380/discussions/2/828939163857602483/ ).

As I've stated in another thread on this issue, I'm fully up todate on all my shots... SP2 is the latest Service Pack for 64 bit XP, there is no SP3. I went through and did every hotfix, including small security ones to make sure, and I manually removed and replaced all my DirectX 9.0c files. My graphics card, a Radeon HD 4800 supports Shader Model 4.1, and I'm assuming backwards compatibility as the rule. I've also tried both rolling back to the old video drivers from my driver disc, and am currently running the most recent Catalyst drivers from ATI.

If you've got any other suggestions, I'm more than willing to try them, but I think I've covered all the usual bases pretty well.

As far as I am aware, they do NOT support 64bit XP.

I know you type of people are too simple minded to do so, but I suggest switching to win 7, because win 8 is crap. Get used to not playing any newer games in the next few years if you wont at least keep up your OS. *waits for the 'but the origninal game runs on XP crying*
FryCaptain May 21, 2013 @ 11:54pm 
Originally posted by Noobiesnack:
Originally posted by Saikotik Gunman:

As I've stated in another thread on this issue, I'm fully up todate on all my shots... SP2 is the latest Service Pack for 64 bit XP, there is no SP3. I went through and did every hotfix, including small security ones to make sure, and I manually removed and replaced all my DirectX 9.0c files. My graphics card, a Radeon HD 4800 supports Shader Model 4.1, and I'm assuming backwards compatibility as the rule. I've also tried both rolling back to the old video drivers from my driver disc, and am currently running the most recent Catalyst drivers from ATI.

If you've got any other suggestions, I'm more than willing to try them, but I think I've covered all the usual bases pretty well.

As far as I am aware, they do NOT support 64bit XP.

I know you type of people are too simple minded to do so, but I suggest switching to win 7, because win 8 is crap. Get used to not playing any newer games in the next few years if you wont at least keep up your OS. *waits for the 'but the origninal game runs on XP crying*

Your kind is the problem, Noobsack. Suggesting that it is the users problem the game doesn’t work as advertised and flaming them for their disappointment. Shame on you! It's people like you that have lowered the bar for what is acceptable. In the future, thanks to your kind and “The Cloud” we will all be beta-testers since releasing untested software will be the norm.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Apr 21, 2013 @ 12:37pm
Posts: 18